summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/xen/files/0001-xen-fix-header-guard-inconsistencies-gcc15.patch54
-rw-r--r--recipes-extended/xen/xen_4.20.bb3
2 files changed, 56 insertions, 1 deletions
diff --git a/recipes-extended/xen/files/0001-xen-fix-header-guard-inconsistencies-gcc15.patch b/recipes-extended/xen/files/0001-xen-fix-header-guard-inconsistencies-gcc15.patch
new file mode 100644
index 00000000..4b2c0bdf
--- /dev/null
+++ b/recipes-extended/xen/files/0001-xen-fix-header-guard-inconsistencies-gcc15.patch
@@ -0,0 +1,54 @@
1From 70f96461462a5a0437398022aa71a2033c8c5c3a Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Thu, 15 May 2025 14:26:47 -0400
4Subject: [PATCH] xen: fix header guard inconsistencies (gcc15)
5
6Fixing the following header inconsistencies
7
8 | In file included from arch/arm/platforms/midway.c:22:
9 | ./arch/arm/include/asm/platforms/midway.h:1: error: header guard '__ASM_ARM_PLATFORMS_MIDWAY_H' followed by '#define' of a different macro [-Werror=header-guard]
10 | 1 | #ifndef __ASM_ARM_PLATFORMS_MIDWAY_H
11 | ./arch/arm/include/asm/platforms/midway.h:2: note: '__ASM_ASM_PLATFORMS_MIDWAY_H' is defined here; did you mean '__ASM_ARM_PLATFORMS_MIDWAY_H'?
12 | 2 | #define __ASM_ASM_PLATFORMS_MIDWAY_H
13 | In file included from arch/arm/platforms/omap5.c:21:
14 | ./arch/arm/include/asm/platforms/omap5.h:1: error: header guard '__ASM_ARM_PLATFORMS_OMAP5_H' followed by '#define' of a different macro [-Werror=header-guard]
15 | 1 | #ifndef __ASM_ARM_PLATFORMS_OMAP5_H
16 | ./arch/arm/include/asm/platforms/omap5.h:2: note: '__ASM_ASM_PLATFORMS_OMAP5_H' is defined here; did you mean '__ASM_ARM_PLATFORMS_OMAP5_H'?
17
18It is unclear whether this is on purpose or not, but for our limited
19set of permuations, we change them to match and no issues have been
20found.
21
22Upstream-Status: Pending [the xen folks understand the code and the right fix .. I don't]
23
24Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
25---
26 xen/arch/arm/include/asm/platforms/midway.h | 2 +-
27 xen/arch/arm/include/asm/platforms/omap5.h | 2 +-
28 2 files changed, 2 insertions(+), 2 deletions(-)
29
30diff --git a/xen/arch/arm/include/asm/platforms/midway.h b/xen/arch/arm/include/asm/platforms/midway.h
31index 099e4350f9..69143931c2 100644
32--- a/xen/arch/arm/include/asm/platforms/midway.h
33+++ b/xen/arch/arm/include/asm/platforms/midway.h
34@@ -1,5 +1,5 @@
35 #ifndef __ASM_ARM_PLATFORMS_MIDWAY_H
36-#define __ASM_ASM_PLATFORMS_MIDWAY_H
37+#define __ASM_ARM_PLATFORMS_MIDWAY_H
38
39 /* addresses of SREG registers for resetting the SoC */
40 #define MW_SREG_PWR_REQ 0xfff3cf00
41diff --git a/xen/arch/arm/include/asm/platforms/omap5.h b/xen/arch/arm/include/asm/platforms/omap5.h
42index c559c84b61..8867b4589a 100644
43--- a/xen/arch/arm/include/asm/platforms/omap5.h
44+++ b/xen/arch/arm/include/asm/platforms/omap5.h
45@@ -1,5 +1,5 @@
46 #ifndef __ASM_ARM_PLATFORMS_OMAP5_H
47-#define __ASM_ASM_PLATFORMS_OMAP5_H
48+#define __ASM_ARM_PLATFORMS_OMAP5_H
49
50 #define REALTIME_COUNTER_BASE 0x48243200
51 #define INCREMENTER_NUMERATOR_OFFSET 0x10
52--
532.39.2
54
diff --git a/recipes-extended/xen/xen_4.20.bb b/recipes-extended/xen/xen_4.20.bb
index d8324033..85c56296 100644
--- a/recipes-extended/xen/xen_4.20.bb
+++ b/recipes-extended/xen/xen_4.20.bb
@@ -1,4 +1,4 @@
1SRCREV ?= "3ad5d648cda5add395f49fc3704b2552aae734f7" 1SRCREV ?= "47d911f69eb976785fd17cae4e39de4d55b94b9e"
2 2
3XEN_REL ?= "4.20.0" 3XEN_REL ?= "4.20.0"
4XEN_BRANCH ?= "stable-4.20" 4XEN_BRANCH ?= "stable-4.20"
@@ -6,6 +6,7 @@ XEN_BRANCH ?= "stable-4.20"
6SRC_URI = " \ 6SRC_URI = " \
7 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \ 7 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \
8 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \ 8 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \
9 file://0001-xen-fix-header-guard-inconsistencies-gcc15.patch \
9 " 10 "
10 11
11LIC_FILES_CHKSUM ?= "file://COPYING;md5=d1a1e216f80b6d8da95fec897d0dbec9" 12LIC_FILES_CHKSUM ?= "file://COPYING;md5=d1a1e216f80b6d8da95fec897d0dbec9"