summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/podman/podman_git.bb12
1 files changed, 3 insertions, 9 deletions
diff --git a/recipes-containers/podman/podman_git.bb b/recipes-containers/podman/podman_git.bb
index 4f6d58a2..f805cb6d 100644
--- a/recipes-containers/podman/podman_git.bb
+++ b/recipes-containers/podman/podman_git.bb
@@ -17,9 +17,9 @@ DEPENDS = " \
17 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ 17 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
18" 18"
19 19
20SRCREV = "72031783c5152cc715a8f1b6dc39bb5de8bfc3ca" 20SRCREV = "717edd7b844dcd66468f5d991991d87e9fc14c12"
21SRC_URI = " \ 21SRC_URI = " \
22 git://github.com/containers/libpod.git;branch=v3.4;protocol=https \ 22 git://github.com/containers/libpod.git;branch=v4.0;protocol=https \
23" 23"
24 24
25LICENSE = "Apache-2.0" 25LICENSE = "Apache-2.0"
@@ -29,7 +29,7 @@ GO_IMPORT = "import"
29 29
30S = "${WORKDIR}/git" 30S = "${WORKDIR}/git"
31 31
32PV = "3.4.2+git${SRCPV}" 32PV = "4.0.1+git${SRCPV}"
33 33
34PACKAGES =+ "${PN}-contrib" 34PACKAGES =+ "${PN}-contrib"
35 35
@@ -92,12 +92,6 @@ do_install() {
92 if ${@bb.utils.contains('PACKAGECONFIG', 'docker', 'true', 'false', d)}; then 92 if ${@bb.utils.contains('PACKAGECONFIG', 'docker', 'true', 'false', d)}; then
93 oe_runmake install.docker DESTDIR="${D}" 93 oe_runmake install.docker DESTDIR="${D}"
94 fi 94 fi
95 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
96 install -d ${D}${systemd_unitdir}/system
97 install -m 644 ${S}/src/import/contrib/systemd/system/podman.service ${D}/${systemd_unitdir}/system
98 install -m 644 ${S}/src/import/contrib/systemd/system/podman.socket ${D}/${systemd_unitdir}/system
99 rm -f ${D}/${systemd_unitdir}/system/docker.service.rpm
100 fi
101} 95}
102 96
103FILES:${PN} += " \ 97FILES:${PN} += " \