summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/python/python-docker.inc15
-rw-r--r--recipes-devtools/python/python3-docker_4.2.0.bb3
-rw-r--r--recipes-devtools/python/python3-docker_4.2.1.bb19
3 files changed, 19 insertions, 18 deletions
diff --git a/recipes-devtools/python/python-docker.inc b/recipes-devtools/python/python-docker.inc
deleted file mode 100644
index 884fb64e..00000000
--- a/recipes-devtools/python/python-docker.inc
+++ /dev/null
@@ -1,15 +0,0 @@
1SUMMARY = "A Python library for the Docker Engine API."
2HOMEPAGE = "https://github.com/docker/docker-py"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=34f3846f940453127309b920eeb89660"
5
6SRC_URI[md5sum] = "19f803f6a7113301daa5d82a2d1d0c30"
7SRC_URI[sha256sum] = "ddae66620ab5f4bce769f64bcd7934f880c8abe6aa50986298db56735d0f722e"
8
9RDEPENDS_${PN} += " \
10 ${PYTHON_PN}-misc \
11 ${PYTHON_PN}-six \
12 ${PYTHON_PN}-docker-pycreds \
13 ${PYTHON_PN}-requests \
14 ${PYTHON_PN}-websocket-client \
15"
diff --git a/recipes-devtools/python/python3-docker_4.2.0.bb b/recipes-devtools/python/python3-docker_4.2.0.bb
deleted file mode 100644
index 052cbe8a..00000000
--- a/recipes-devtools/python/python3-docker_4.2.0.bb
+++ /dev/null
@@ -1,3 +0,0 @@
1inherit pypi setuptools3
2DEPENDS += "${PYTHON_PN}-pip-native"
3require python-docker.inc
diff --git a/recipes-devtools/python/python3-docker_4.2.1.bb b/recipes-devtools/python/python3-docker_4.2.1.bb
new file mode 100644
index 00000000..32b24eb3
--- /dev/null
+++ b/recipes-devtools/python/python3-docker_4.2.1.bb
@@ -0,0 +1,19 @@
1SUMMARY = "A Python library for the Docker Engine API."
2HOMEPAGE = "https://github.com/docker/docker-py"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=34f3846f940453127309b920eeb89660"
5
6SRC_URI[md5sum] = "65111a1e4a2ab83d2ba104cdb17f1326"
7SRC_URI[sha256sum] = "380a20d38fbfaa872e96ee4d0d23ad9beb0f9ed57ff1c30653cbeb0c9c0964f2"
8
9DEPENDS += "${PYTHON_PN}-pip-native"
10
11RDEPENDS_${PN} += " \
12 ${PYTHON_PN}-misc \
13 ${PYTHON_PN}-six \
14 ${PYTHON_PN}-docker-pycreds \
15 ${PYTHON_PN}-requests \
16 ${PYTHON_PN}-websocket-client \
17"
18
19inherit pypi setuptools3