diff options
-rw-r--r-- | recipes-devtools/go/notary_git.bb | 41 |
1 files changed, 0 insertions, 41 deletions
diff --git a/recipes-devtools/go/notary_git.bb b/recipes-devtools/go/notary_git.bb deleted file mode 100644 index ace7174d..00000000 --- a/recipes-devtools/go/notary_git.bb +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | DESCRIPTION = "Notary is a Docker project that allows anyone to have trust over arbitrary collections of data" | ||
2 | HOMEPAGE = "https://github.com/docker/notary" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=3596b980bb036e0875174ed15e4b982a" | ||
6 | |||
7 | SRCNAME = "notary" | ||
8 | |||
9 | PKG_NAME = "github.com/docker/${SRCNAME}" | ||
10 | SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME};branch=master;protocol=https" | ||
11 | |||
12 | SRCREV = "d6e1431feb32348e0650bf7551ac5cffd01d857b" | ||
13 | PV = "0.6.1+git" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | inherit meta-virt-depreciated-warning | ||
18 | |||
19 | # NO-OP the do compile rule because this recipe is source only. | ||
20 | do_compile() { | ||
21 | } | ||
22 | |||
23 | do_install() { | ||
24 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
25 | for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go"); do | ||
26 | if [ ! -d ${D}${prefix}/local/go/$(dirname $j) ]; then | ||
27 | mkdir -p ${D}${prefix}/local/go/$(dirname $j) | ||
28 | fi | ||
29 | cp $j ${D}${prefix}/local/go/$j | ||
30 | done | ||
31 | cp -r ${S}/src/${PKG_NAME}/LICENSE ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
32 | } | ||
33 | |||
34 | SYSROOT_PREPROCESS_FUNCS += "go_notary_sysroot_preprocess" | ||
35 | |||
36 | go_notary_sysroot_preprocess () { | ||
37 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} | ||
38 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | ||
39 | } | ||
40 | |||
41 | FILES:${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||