diff options
-rw-r--r-- | recipes-extended/xen/xen-4.1.2/allow_disable_xend.patch | 75 | ||||
-rw-r--r-- | recipes-extended/xen/xen_4.1.2.bb | 24 |
2 files changed, 0 insertions, 99 deletions
diff --git a/recipes-extended/xen/xen-4.1.2/allow_disable_xend.patch b/recipes-extended/xen/xen-4.1.2/allow_disable_xend.patch deleted file mode 100644 index 33187045..00000000 --- a/recipes-extended/xen/xen-4.1.2/allow_disable_xend.patch +++ /dev/null | |||
@@ -1,75 +0,0 @@ | |||
1 | --- xen-4.1.2/config/StdGNU.mk.sav 2012-03-08 12:30:26.047303578 -0700 | ||
2 | +++ xen-4.1.2/config/StdGNU.mk 2012-03-08 12:31:48.826696508 -0700 | ||
3 | @@ -56,6 +56,9 @@ | ||
4 | XEN_CONFIG_DIR = $(CONFIG_DIR)/xen | ||
5 | XEN_SCRIPT_DIR = $(XEN_CONFIG_DIR)/scripts | ||
6 | |||
7 | +# Allow xend to be disabled in lieu of only libxl | ||
8 | +CONFIG_ENABLE_XEND ?= y | ||
9 | + | ||
10 | SOCKET_LIBS = | ||
11 | CURSES_LIBS = -lncurses | ||
12 | PTHREAD_LIBS = -lpthread | ||
13 | --- xen-4.1.2/tools/Makefile.sav 2012-03-08 11:25:10.177301492 -0700 | ||
14 | +++ xen-4.1.2/tools/Makefile 2012-03-08 12:33:48.807302767 -0700 | ||
15 | @@ -15,7 +15,7 @@ | ||
16 | SUBDIRS-$(CONFIG_X86) += firmware | ||
17 | SUBDIRS-$(ACM_SECURITY) += security | ||
18 | SUBDIRS-y += console | ||
19 | -SUBDIRS-y += xenmon | ||
20 | +SUBDIRS-$(CONFIG_ENABLE_XEND) += xenmon | ||
21 | SUBDIRS-$(VTPM_TOOLS) += vtpm_manager | ||
22 | SUBDIRS-$(VTPM_TOOLS) += vtpm | ||
23 | SUBDIRS-y += xenstat | ||
24 | @@ -36,17 +36,19 @@ | ||
25 | |||
26 | SUBDIRS-y += xenpmd | ||
27 | SUBDIRS-y += libxl | ||
28 | -SUBDIRS-y += remus | ||
29 | +SUBDIRS-$(CONFIG_ENABLE_XEND) += remus | ||
30 | SUBDIRS-$(CONFIG_X86) += xenpaging | ||
31 | SUBDIRS-$(CONFIG_X86) += debugger/gdbsx | ||
32 | SUBDIRS-$(CONFIG_X86) += debugger/kdd | ||
33 | |||
34 | # These don't cross-compile | ||
35 | ifeq ($(XEN_COMPILE_ARCH),$(XEN_TARGET_ARCH)) | ||
36 | +ifneq ($(XEN_ENABLE_XEND),y) | ||
37 | SUBDIRS-$(PYTHON_TOOLS) += python | ||
38 | SUBDIRS-$(PYTHON_TOOLS) += pygrub | ||
39 | SUBDIRS-$(OCAML_TOOLS) += ocaml | ||
40 | endif | ||
41 | +endif | ||
42 | |||
43 | # For the sake of linking, set the sys-root | ||
44 | ifneq ($(CROSS_COMPILE),) | ||
45 | --- xen-4.1.2/tools/misc/Makefile.sav 2012-03-08 12:23:10.107321955 -0700 | ||
46 | +++ xen-4.1.2/tools/misc/Makefile 2012-03-08 12:34:54.466721729 -0700 | ||
47 | @@ -19,11 +19,13 @@ | ||
48 | SUBDIRS-$(CONFIG_MINITERM) += miniterm | ||
49 | SUBDIRS := $(SUBDIRS-y) | ||
50 | |||
51 | -INSTALL_BIN-y := xencons | ||
52 | +INSTALL_BIN-y := | ||
53 | +INSTALL_BIN-$(CONFIG_ENABLE_XEND) += xencons | ||
54 | INSTALL_BIN-$(CONFIG_X86) += xen-detect | ||
55 | INSTALL_BIN := $(INSTALL_BIN-y) | ||
56 | |||
57 | -INSTALL_SBIN-y := xm xen-bugtool xen-python-path xend xenperf xsview xenpm xen-tmem-list-parse gtraceview gtracestat xenlockprof xenwatchdogd | ||
58 | +INSTALL_SBIN-y := xenperf xsview xenpm xen-tmem-list-parse gtraceview gtracestat xenlockprof xenwatchdogd | ||
59 | +INSTALL_SBIN-$(CONFIG_ENABLE_XEND) += xm xend xsview xen-python-path xen-bugtool | ||
60 | INSTALL_SBIN-$(CONFIG_X86) += xen-hvmctx xen-hvmcrash | ||
61 | INSTALL_SBIN-$(CONFIG_MIGRATE) += xen-hptool | ||
62 | INSTALL_SBIN := $(INSTALL_SBIN-y) | ||
63 | --- xen-4.1.2/tools/hotplug/NetBSD/Makefile.sav 2012-03-08 12:54:56.247306596 -0700 | ||
64 | +++ xen-4.1.2/tools/hotplug/NetBSD/Makefile 2012-03-08 12:57:50.337339410 -0700 | ||
65 | @@ -8,7 +8,9 @@ | ||
66 | XEN_SCRIPTS += vif-ip | ||
67 | |||
68 | XEN_SCRIPT_DATA = | ||
69 | -XEN_RCD_PROG = rc.d/xencommons rc.d/xend rc.d/xendomains rc.d/xen-watchdog | ||
70 | +XEN_RCD_PROG-y := rc.d/xencommons rc.d/xendomains rc.d/xen-watchdog | ||
71 | +XEN_RCD_PROG-$(CONFIG_ENABLE_XEND) += rc.d/xend | ||
72 | +XEN_RCD_PROG := $(XEN_RCD_PROG-y) | ||
73 | |||
74 | .PHONY: all | ||
75 | all: | ||
diff --git a/recipes-extended/xen/xen_4.1.2.bb b/recipes-extended/xen/xen_4.1.2.bb deleted file mode 100644 index 5a87bc41..00000000 --- a/recipes-extended/xen/xen_4.1.2.bb +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | # Xen official download | ||
2 | |||
3 | require xen.inc | ||
4 | |||
5 | PR="r1" | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=f46a39d9fa181e4933b1acdfdcd72017" | ||
8 | |||
9 | SRCREV = "3cf61880403b4e484539596a95937cc066243388" | ||
10 | |||
11 | SRC_URI = "http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz \ | ||
12 | git://xenbits.xensource.com/qemu-xen-4.1-testing.git \ | ||
13 | file://ioemu-cross-gl-check.patch \ | ||
14 | file://allow_disable_xend.patch \ | ||
15 | file://xend-config.sxp \ | ||
16 | file://xenminiinit.sh" | ||
17 | |||
18 | SRC_URI[md5sum] = "73561faf3c1b5e36ec5c089b5db848ad" | ||
19 | SRC_URI[sha256sum] = "7d9c93057cf480d3f1efa792b19285a84fa3c06060ea5c5c453be00887389b0d" | ||
20 | |||
21 | S = "${WORKDIR}/xen-${PV}" | ||
22 | |||
23 | # Include python and xend support | ||
24 | require xen-python.inc | ||