summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/lxc/lxc_2.0.8.bb33
1 files changed, 15 insertions, 18 deletions
diff --git a/recipes-containers/lxc/lxc_2.0.8.bb b/recipes-containers/lxc/lxc_2.0.8.bb
index 4918d913..547c44f0 100644
--- a/recipes-containers/lxc/lxc_2.0.8.bb
+++ b/recipes-containers/lxc/lxc_2.0.8.bb
@@ -81,13 +81,17 @@ export STAGING_LIBDIR
81 81
82inherit autotools pkgconfig ptest update-rc.d systemd python3native 82inherit autotools pkgconfig ptest update-rc.d systemd python3native
83 83
84SYSTEMD_PACKAGES = "${PN}-setup" 84SYSTEMD_PACKAGES = "${PN} ${PN}-networking"
85SYSTEMD_SERVICE_${PN}-setup = "lxc.service" 85SYSTEMD_SERVICE_${PN} = "lxc.service"
86SYSTEMD_AUTO_ENABLE_${PN}-setup = "disable" 86SYSTEMD_AUTO_ENABLE_${PN} = "disable"
87 87SYSTEMD_SERVICE_${PN}-networking = "lxc-net.service"
88INITSCRIPT_PACKAGES = "${PN}-setup" 88SYSTEMD_AUTO_ENABLE_${PN}-networking = "enable"
89INITSCRIPT_NAME_{PN}-setup = "lxc" 89
90INITSCRIPT_PARAMS_${PN}-setup = "defaults" 90INITSCRIPT_PACKAGES = "${PN} ${PN}-networking"
91INITSCRIPT_NAME_${PN} = "lxc"
92INITSCRIPT_PARAMS_${PN} = "defaults"
93INITSCRIPT_NAME_${PN}-networking = "lxc-net"
94INITSCRIPT_PARAMS_${PN}-networking = "defaults"
91 95
92FILES_${PN}-doc = "${mandir} ${infodir}" 96FILES_${PN}-doc = "${mandir} ${infodir}"
93# For LXC the docdir only contains example configuration files and should be included in the lxc package 97# For LXC the docdir only contains example configuration files and should be included in the lxc package
@@ -96,18 +100,13 @@ FILES_${PN} += "${libdir}/python3*"
96FILES_${PN} += "${datadir}/bash-completion" 100FILES_${PN} += "${datadir}/bash-completion"
97FILES_${PN}-dbg += "${libexecdir}/lxc/.debug" 101FILES_${PN}-dbg += "${libexecdir}/lxc/.debug"
98FILES_${PN}-dbg += "${libexecdir}/lxc/hooks/.debug" 102FILES_${PN}-dbg += "${libexecdir}/lxc/hooks/.debug"
99PACKAGES =+ "${PN}-templates ${PN}-setup ${PN}-networking ${PN}-lua" 103PACKAGES =+ "${PN}-templates ${PN}-networking ${PN}-lua"
100FILES_lua-${PN} = "${datadir}/lua ${libdir}/lua" 104FILES_lua-${PN} = "${datadir}/lua ${libdir}/lua"
101FILES_lua-${PN}-dbg += "${libdir}/lua/lxc/.debug" 105FILES_lua-${PN}-dbg += "${libdir}/lua/lxc/.debug"
102FILES_${PN}-templates += "${datadir}/lxc/templates" 106FILES_${PN}-templates += "${datadir}/lxc/templates"
103RDEPENDS_${PN}-templates += "bash" 107RDEPENDS_${PN}-templates += "bash"
104 108
105ALLOW_EMPTY_${PN}-networking = "1" 109FILES_${PN}-networking += "${sysconfdir}/init.d/lxc-net"
106
107FILES_${PN}-setup += "/etc/tmpfiles.d"
108FILES_${PN}-setup += "/lib/systemd/system"
109FILES_${PN}-setup += "/usr/lib/systemd/system"
110FILES_${PN}-setup += "/etc/init.d"
111 110
112PRIVATE_LIBS_${PN}-ptest = "liblxc.so.1" 111PRIVATE_LIBS_${PN}-ptest = "liblxc.so.1"
113 112
@@ -128,10 +127,8 @@ do_install_append() {
128 for i in `grep -l "#! */bin/bash" ${D}${datadir}/lxc/hooks/*`; do \ 127 for i in `grep -l "#! */bin/bash" ${D}${datadir}/lxc/hooks/*`; do \
129 sed -e 's|#! */bin/bash|#!/bin/sh|' -i $i; done 128 sed -e 's|#! */bin/bash|#!/bin/sh|' -i $i; done
130 129
131 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 130 install -d ${D}${sysconfdir}/init.d
132 install -d ${D}${sysconfdir}/init.d 131 install -m 755 config/init/sysvinit/lxc* ${D}${sysconfdir}/init.d
133 install -m 755 config/init/sysvinit/lxc* ${D}${sysconfdir}/init.d
134 fi
135 132
136 # since python3-native is used for install location this will not be 133 # since python3-native is used for install location this will not be
137 # suitable for the target and we will have to correct the package install 134 # suitable for the target and we will have to correct the package install