summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/fuse-overlayfs/fuse-overlayfs/0001-utils-Add-missing-include-on-limits.h.patch36
-rw-r--r--recipes-extended/fuse-overlayfs/fuse-overlayfs_1.14.bb15
-rw-r--r--recipes-extended/fuse-overlayfs/fuse-overlayfs_1.9.bb18
3 files changed, 15 insertions, 54 deletions
diff --git a/recipes-extended/fuse-overlayfs/fuse-overlayfs/0001-utils-Add-missing-include-on-limits.h.patch b/recipes-extended/fuse-overlayfs/fuse-overlayfs/0001-utils-Add-missing-include-on-limits.h.patch
deleted file mode 100644
index cd504ce5..00000000
--- a/recipes-extended/fuse-overlayfs/fuse-overlayfs/0001-utils-Add-missing-include-on-limits.h.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1From b48e958aaecfdfc3bb48db082a548a09d6487181 Mon Sep 17 00:00:00 2001
2From: Andrei Gherzan <andrei.gherzan@huawei.com>
3Date: Wed, 13 Jul 2022 12:05:07 +0200
4Subject: [PATCH] utils: Add missing include on limits.h
5
6This happens to not be an issue with glibc because it gets indirectly
7included via dirent.h:
8
9.. /usr/include/dirent.h
10[...]
11..... /usr/include/linux/limits.h
12
13When using the musl libc implementation, that is not the case anymore
14and the build fails.
15
16Signed-off-by: Andrei Gherzan <andrei.gherzan@huawei.com>
17Upstream-Status: Submitted [https://github.com/containers/fuse-overlayfs/pull/362]
18---
19 utils.h | 1 +
20 1 file changed, 1 insertion(+)
21
22diff --git a/utils.h b/utils.h
23index 13a177e..6fbc328 100644
24--- a/utils.h
25+++ b/utils.h
26@@ -32,6 +32,7 @@
27 # include <sys/types.h>
28 # include <fcntl.h>
29 # include "fuse-overlayfs.h"
30+# include <limits.h>
31
32 # define XATTR_OVERRIDE_STAT "user.fuseoverlayfs.override_stat"
33 # define XATTR_PRIVILEGED_OVERRIDE_STAT "security.fuseoverlayfs.override_stat"
34--
352.25.1
36
diff --git a/recipes-extended/fuse-overlayfs/fuse-overlayfs_1.14.bb b/recipes-extended/fuse-overlayfs/fuse-overlayfs_1.14.bb
new file mode 100644
index 00000000..0f6d0fb6
--- /dev/null
+++ b/recipes-extended/fuse-overlayfs/fuse-overlayfs_1.14.bb
@@ -0,0 +1,15 @@
1SUMMARY = "FUSE implementation of overlayfs."
2DESCRIPTION = "An implementation of overlay+shiftfs in FUSE for rootless \
3containers."
4
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRCREV = "33cb788edc05f5e3cbb8a7a241f5a04bee264730"
9SRC_URI = "git://github.com/containers/fuse-overlayfs.git;nobranch=1;protocol=https"
10
11DEPENDS = "fuse3"
12
13S = "${WORKDIR}/git"
14
15inherit autotools pkgconfig
diff --git a/recipes-extended/fuse-overlayfs/fuse-overlayfs_1.9.bb b/recipes-extended/fuse-overlayfs/fuse-overlayfs_1.9.bb
deleted file mode 100644
index 31199928..00000000
--- a/recipes-extended/fuse-overlayfs/fuse-overlayfs_1.9.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1SUMMARY = "FUSE implementation of overlayfs."
2DESCRIPTION = "An implementation of overlay+shiftfs in FUSE for rootless \
3containers."
4
5LICENSE = "GPL-3.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8SRCREV = "51592ea406f48faeccab288f65dcba6c4a67cd90"
9SRC_URI = " \
10 git://github.com/containers/fuse-overlayfs.git;nobranch=1;protocol=https \
11 file://0001-utils-Add-missing-include-on-limits.h.patch \
12"
13
14DEPENDS = "fuse3"
15
16S = "${WORKDIR}/git"
17
18inherit autotools pkgconfig