diff options
-rw-r--r-- | recipes-core/runv/runv_git.bb | 87 |
1 files changed, 0 insertions, 87 deletions
diff --git a/recipes-core/runv/runv_git.bb b/recipes-core/runv/runv_git.bb deleted file mode 100644 index 9cf5e491..00000000 --- a/recipes-core/runv/runv_git.bb +++ /dev/null | |||
@@ -1,87 +0,0 @@ | |||
1 | HOMEPAGE = "https://github.com/hyperhq/runv" | ||
2 | SUMMARY = "Hypervisor-based Runtime for OCI" | ||
3 | DESCRIPTION = "Hypervisor-based Runtime for OCI" | ||
4 | |||
5 | SRCREV_runv = "b360a686abc6c6e896382990ef1b93ef07c7a677" | ||
6 | SRC_URI = "\ | ||
7 | git://github.com/hyperhq/runv.git;nobranch=1;name=runv;protocol=https;destsuffix=${GO_SRCURI_DESTSUFFIX} \ | ||
8 | " | ||
9 | |||
10 | LICENSE = "Apache-2.0" | ||
11 | LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4106a50540bdec3b9734f9c70882d382" | ||
12 | |||
13 | GO_IMPORT = "import" | ||
14 | |||
15 | PV = "0.4.0+git${SRCREV_runv}" | ||
16 | |||
17 | inherit go | ||
18 | inherit goarch | ||
19 | inherit pkgconfig | ||
20 | inherit autotools-brokensep | ||
21 | |||
22 | # accord with qemu | ||
23 | COMPATIBLE_HOST:mipsarchn32 = "null" | ||
24 | COMPATIBLE_HOST:mipsarchn64 = "null" | ||
25 | COMPATIBLE_HOST:riscv32 = "null" | ||
26 | COMPATIBLE_HOST:powerpc = "null" | ||
27 | |||
28 | PACKAGECONFIG[xen] = "--with-xen,--without-xen," | ||
29 | AUTOTOOLS_SCRIPT_PATH = "${S}/src/import/" | ||
30 | |||
31 | RDEPENDS:${PN} += " qemu hyperstart" | ||
32 | |||
33 | do_compile() { | ||
34 | export GOARCH="${TARGET_GOARCH}" | ||
35 | export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go" | ||
36 | export GOPATH="${S}/src/import:${S}/src/import/vendor" | ||
37 | |||
38 | # Pass the needed cflags/ldflags so that cgo | ||
39 | # can find the needed headers files and libraries | ||
40 | export CGO_ENABLED="1" | ||
41 | export CFLAGS="" | ||
42 | export LDFLAGS="" | ||
43 | export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}" | ||
44 | export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" | ||
45 | |||
46 | # link fixups for compilation | ||
47 | rm -f ${S}/src/import/vendor/src | ||
48 | ln -sf ./ ${S}/src/import/vendor/src | ||
49 | |||
50 | mkdir -p ${S}/src/import/vendor/github.com/hyperhq/runv | ||
51 | |||
52 | echo fff | ||
53 | pwd | ||
54 | ln -sf src/import/cli | ||
55 | ln -sf ../../../../api ${S}/src/import/vendor/github.com/hyperhq/runv/api | ||
56 | ln -sf ../../../../cli ${S}/src/import/vendor/github.com/hyperhq/runv/cli | ||
57 | ln -sf ../../../../lib ${S}/src/import/vendor/github.com/hyperhq/runv/lib | ||
58 | ln -sf ../../../../driverloader ${S}/src/import/vendor/github.com/hyperhq/runv/driverloader | ||
59 | ln -sf ../../../../factory ${S}/src/import/vendor/github.com/hyperhq/runv/factory | ||
60 | ln -sf ../../../../hyperstart ${S}/src/import/vendor/github.com/hyperhq/runv/hyperstart | ||
61 | ln -sf ../../../../hypervisor ${S}/src/import/vendor/github.com/hyperhq/runv/hypervisor | ||
62 | ln -sf ../../../../template ${S}/src/import/vendor/github.com/hyperhq/runv/template | ||
63 | |||
64 | export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" | ||
65 | export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go" | ||
66 | |||
67 | # Pass the needed cflags/ldflags so that cgo | ||
68 | # can find the needed headers files and libraries | ||
69 | export CGO_ENABLED="1" | ||
70 | export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}" | ||
71 | export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" | ||
72 | |||
73 | oe_runmake build-runv | ||
74 | } | ||
75 | |||
76 | do_install() { | ||
77 | localbindir="/usr/local/bin" | ||
78 | |||
79 | install -d ${D}${localbindir} | ||
80 | install -m 755 ${S}/runv ${D}/${localbindir} | ||
81 | } | ||
82 | |||
83 | deltask compile_ptest_base | ||
84 | |||
85 | FILES:${PN} += "/usr/local/bin/*" | ||
86 | |||
87 | INSANE_SKIP:${PN} += "ldflags already-stripped" | ||