summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/containerd/containerd-opencontainers/0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch15
-rw-r--r--recipes-containers/containerd/containerd-opencontainers_git.bb8
2 files changed, 10 insertions, 13 deletions
diff --git a/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch b/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch
index 32da401b..3a69d76d 100644
--- a/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch
+++ b/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch
@@ -19,12 +19,12 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
19 Makefile | 3 ++- 19 Makefile | 3 ++-
20 1 file changed, 2 insertions(+), 1 deletion(-) 20 1 file changed, 2 insertions(+), 1 deletion(-)
21 21
22diff --git git.orig/Makefile git.orig/Makefile 22Index: containerd/Makefile
23index c61418e60..54a10eb42 100644 23===================================================================
24--- git.orig/Makefile 24--- containerd.orig/Makefile
25+++ git.orig/Makefile 25+++ containerd/Makefile
26@@ -112,7 +112,8 @@ endif 26@@ -127,7 +127,8 @@
27 GOPATHS=$(shell echo ${GOPATH} | tr ":" "\n" | tr ";" "\n") 27 GOPATHS=$(shell go env GOPATH | tr ":" "\n" | tr ";" "\n")
28 28
29 TESTFLAGS_RACE= 29 TESTFLAGS_RACE=
30-GO_BUILD_FLAGS= 30-GO_BUILD_FLAGS=
@@ -33,6 +33,3 @@ index c61418e60..54a10eb42 100644
33 # See Golang issue re: '-trimpath': https://github.com/golang/go/issues/13809 33 # See Golang issue re: '-trimpath': https://github.com/golang/go/issues/13809
34 GO_GCFLAGS=$(shell \ 34 GO_GCFLAGS=$(shell \
35 set -- ${GOPATHS}; \ 35 set -- ${GOPATHS}; \
36--
372.19.1
38
diff --git a/recipes-containers/containerd/containerd-opencontainers_git.bb b/recipes-containers/containerd/containerd-opencontainers_git.bb
index 5fe3e4fa..d85b3470 100644
--- a/recipes-containers/containerd/containerd-opencontainers_git.bb
+++ b/recipes-containers/containerd/containerd-opencontainers_git.bb
@@ -5,8 +5,8 @@ DESCRIPTION = "containerd is a daemon to control runC, built for performance and
5 support as well as checkpoint and restore for cloning and live migration of containers." 5 support as well as checkpoint and restore for cloning and live migration of containers."
6 6
7 7
8SRCREV = "ccfc27e30d9f599efe6a7471ea1932dedf2beec8" 8SRCREV = "f2cf411b79fab1cb95ae1bc968c8f35b5f4eef35"
9SRC_URI = "git://github.com/containerd/containerd;branch=release/1.6;protocol=https;destsuffix=git/src/github.com/containerd/containerd \ 9SRC_URI = "git://github.com/containerd/containerd;branch=main;protocol=https;destsuffix=git/src/github.com/containerd/containerd \
10 file://0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch \ 10 file://0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch \
11 file://0001-build-don-t-use-gcflags-to-define-trimpath.patch \ 11 file://0001-build-don-t-use-gcflags-to-define-trimpath.patch \
12 " 12 "
@@ -15,8 +15,8 @@ SRC_URI = "git://github.com/containerd/containerd;branch=release/1.6;protocol=ht
15LICENSE = "Apache-2.0" 15LICENSE = "Apache-2.0"
16LIC_FILES_CHKSUM = "file://LICENSE;md5=1269f40c0d099c21a871163984590d89" 16LIC_FILES_CHKSUM = "file://LICENSE;md5=1269f40c0d099c21a871163984590d89"
17 17
18CONTAINERD_VERSION = "v1.6.12" 18CONTAINERD_VERSION = "v1.7.0-beta"
19CVE_VERSION = "1.6.12" 19CVE_VERSION = "1.7.0-beta"
20 20
21# EXTRA_OEMAKE += "GODEBUG=1" 21# EXTRA_OEMAKE += "GODEBUG=1"
22 22