diff options
-rw-r--r-- | recipes-extended/kvmtool/files/external-crosscompiler.patch | 31 | ||||
-rw-r--r-- | recipes-extended/kvmtool/kvmtool.bb | 23 |
2 files changed, 54 insertions, 0 deletions
diff --git a/recipes-extended/kvmtool/files/external-crosscompiler.patch b/recipes-extended/kvmtool/files/external-crosscompiler.patch new file mode 100644 index 00000000..75cef3b1 --- /dev/null +++ b/recipes-extended/kvmtool/files/external-crosscompiler.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | Upstream-Status: Inappropriate [embedded specific] | ||
2 | |||
3 | This allows OpenEmbedded to pass in cross compiler configuration using | ||
4 | the default envirnment variables. It is required so that kvmtool can | ||
5 | be linked against the cross-compiled libfdt library. | ||
6 | |||
7 | diff --git a/Makefile b/Makefile | ||
8 | index 1f0196f..8bfb068 100644 | ||
9 | --- a/Makefile | ||
10 | +++ b/Makefile | ||
11 | @@ -14,11 +14,6 @@ export E Q | ||
12 | include config/utilities.mak | ||
13 | include config/feature-tests.mak | ||
14 | |||
15 | -CC := $(CROSS_COMPILE)gcc | ||
16 | -CFLAGS := | ||
17 | -LD := $(CROSS_COMPILE)ld | ||
18 | -LDFLAGS := | ||
19 | - | ||
20 | FIND := find | ||
21 | CSCOPE := cscope | ||
22 | TAGS := ctags | ||
23 | @@ -297,7 +292,7 @@ $(warning No static libc found. Skipping guest init) | ||
24 | endif | ||
25 | |||
26 | ifeq (y,$(ARCH_WANT_LIBFDT)) | ||
27 | - ifneq ($(call try-build,$(SOURCE_LIBFDT),$(CFLAGS),-lfdt),y) | ||
28 | + ifneq ($(call try-build,$(SOURCE_LIBFDT),$(CPPFLAGS) $(CFLAGS),-lfdt),y) | ||
29 | $(error No libfdt found. Please install libfdt-dev package) | ||
30 | else | ||
31 | CFLAGS_DYNOPT += -DCONFIG_HAS_LIBFDT | ||
diff --git a/recipes-extended/kvmtool/kvmtool.bb b/recipes-extended/kvmtool/kvmtool.bb new file mode 100644 index 00000000..3f299dd5 --- /dev/null +++ b/recipes-extended/kvmtool/kvmtool.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | SUMMARY = "Native Linux KVM tool" | ||
2 | DESCRIPTION = "kvmtool is a lightweight tool for hosting KVM guests." | ||
3 | |||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067" | ||
6 | |||
7 | DEPENDS = "dtc libaio zlib" | ||
8 | |||
9 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/will/kvmtool.git \ | ||
10 | file://external-crosscompiler.patch \ | ||
11 | " | ||
12 | |||
13 | SRCREV = "0093df80d754e1a05b016e5a4ccd4b51a00c562c" | ||
14 | PV = "3.18.0+git${SRCREV}" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | EXTRA_OEMAKE='ARCH="${TARGET_ARCH}" V=1' | ||
19 | |||
20 | do_install() { | ||
21 | install -d ${D}${bindir} | ||
22 | install -m 0755 ${S}/lkvm ${D}${bindir}/ | ||
23 | } | ||