diff options
-rw-r--r-- | recipes-containers/docker/docker-moby_git.bb | 6 | ||||
-rw-r--r-- | recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch | 14 |
2 files changed, 9 insertions, 11 deletions
diff --git a/recipes-containers/docker/docker-moby_git.bb b/recipes-containers/docker/docker-moby_git.bb index 9f45f175..dfbfa706 100644 --- a/recipes-containers/docker/docker-moby_git.bb +++ b/recipes-containers/docker/docker-moby_git.bb | |||
@@ -44,8 +44,8 @@ DESCRIPTION = "Linux container runtime \ | |||
44 | # so we get that tag, and make it our SRCREVS: | 44 | # so we get that tag, and make it our SRCREVS: |
45 | # | 45 | # |
46 | 46 | ||
47 | SRCREV_moby = "43fc912ef59a83054ea7f6706df4d53a7dea4d80" | 47 | SRCREV_moby = "bbd0a17ccc67e48d4a69393287b7fcc4f0578683" |
48 | SRCREV_cli = "d41cb083c352853f94b292a87df4859c4a96dcc2" | 48 | SRCREV_cli = "068a01ea9470df6494cc92d9e64e240805ae47a7" |
49 | SRCREV_FORMAT = "moby" | 49 | SRCREV_FORMAT = "moby" |
50 | SRC_URI = "\ | 50 | SRC_URI = "\ |
51 | git://github.com/moby/moby.git;nobranch=1;name=moby;protocol=https;destsuffix=${GO_SRCURI_DESTSUFFIX} \ | 51 | git://github.com/moby/moby.git;nobranch=1;name=moby;protocol=https;destsuffix=${GO_SRCURI_DESTSUFFIX} \ |
@@ -64,7 +64,7 @@ require docker.inc | |||
64 | LICENSE = "Apache-2.0" | 64 | LICENSE = "Apache-2.0" |
65 | LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28" | 65 | LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28" |
66 | 66 | ||
67 | DOCKER_VERSION = "27.5.0-rc.2" | 67 | DOCKER_VERSION = "28.0.1" |
68 | PV = "${DOCKER_VERSION}+git${SRCREV_moby}" | 68 | PV = "${DOCKER_VERSION}+git${SRCREV_moby}" |
69 | 69 | ||
70 | CVE_PRODUCT = "docker mobyproject:moby" | 70 | CVE_PRODUCT = "docker mobyproject:moby" |
diff --git a/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch b/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch index 160a3bca..9079d81e 100644 --- a/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch +++ b/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch | |||
@@ -48,7 +48,7 @@ Index: import/hack/make/.binary | |||
48 | echo -n '.exe' | 48 | echo -n '.exe' |
49 | fi | 49 | fi |
50 | } | 50 | } |
51 | @@ -16,33 +16,12 @@ | 51 | @@ -16,31 +16,10 @@ |
52 | ( | 52 | ( |
53 | export GOGC=${DOCKER_BUILD_GOGC:-1000} | 53 | export GOGC=${DOCKER_BUILD_GOGC:-1000} |
54 | 54 | ||
@@ -73,17 +73,15 @@ Index: import/hack/make/.binary | |||
73 | - fi | 73 | - fi |
74 | - fi | 74 | - fi |
75 | - | 75 | - |
76 | # -buildmode=pie is not supported on Windows arm64 and Linux mips*, ppc64be | ||
77 | # https://github.com/golang/go/blob/go1.19.4/src/cmd/internal/sys/supported.go#L125-L132 | ||
78 | if ! [ "$DOCKER_STATIC" = "1" ]; then | 76 | if ! [ "$DOCKER_STATIC" = "1" ]; then |
79 | # -buildmode=pie not supported when -race is enabled | 77 | # -buildmode=pie not supported when -race is enabled |
80 | if [[ " $BUILDFLAGS " != *" -race "* ]]; then | 78 | if [[ " $BUILDFLAGS " != *" -race "* ]]; then |
81 | - case "$(go env GOOS)/$(go env GOARCH)" in | 79 | - case "$(go env GOOS)/$(go env GOARCH)" in |
82 | + case "$(${GO} env GOOS)/$(${GO} env GOARCH)" in | 80 | + case "$(${GO} env GOOS)/$(${GO} env GOARCH)" in |
83 | windows/arm64 | linux/mips* | linux/ppc64) ;; | 81 | linux/mips* | linux/ppc64) |
84 | *) | 82 | # -buildmode=pie is not supported on Linux mips*, ppc64be |
85 | BUILDFLAGS+=("-buildmode=pie") | 83 | # https://github.com/golang/go/blob/go1.23.0/src/internal/platform/supported.go#L189-L197 |
86 | @@ -66,11 +45,11 @@ | 84 | @@ -67,11 +46,11 @@ |
87 | # only necessary for non-sandboxed invocation where TARGETPLATFORM is empty | 85 | # only necessary for non-sandboxed invocation where TARGETPLATFORM is empty |
88 | PLATFORM_NAME=$TARGETPLATFORM | 86 | PLATFORM_NAME=$TARGETPLATFORM |
89 | if [ -z "$PLATFORM_NAME" ]; then | 87 | if [ -z "$PLATFORM_NAME" ]; then |
@@ -100,7 +98,7 @@ Index: import/hack/make/.binary | |||
100 | fi | 98 | fi |
101 | fi | 99 | fi |
102 | 100 | ||
103 | @@ -82,7 +61,7 @@ | 101 | @@ -95,7 +74,7 @@ |
104 | if [ -n "$DOCKER_DEBUG" ]; then | 102 | if [ -n "$DOCKER_DEBUG" ]; then |
105 | set -x | 103 | set -x |
106 | fi | 104 | fi |