diff options
-rw-r--r-- | recipes-extended/images/xen-guest-image-minimal.bb | 16 | ||||
-rw-r--r-- | recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend | 13 |
2 files changed, 26 insertions, 3 deletions
diff --git a/recipes-extended/images/xen-guest-image-minimal.bb b/recipes-extended/images/xen-guest-image-minimal.bb index ab7e92c3..bca60178 100644 --- a/recipes-extended/images/xen-guest-image-minimal.bb +++ b/recipes-extended/images/xen-guest-image-minimal.bb | |||
@@ -1,14 +1,24 @@ | |||
1 | DESCRIPTION = "A Xen guest image." | 1 | DESCRIPTION = "A Xen guest image." |
2 | 2 | ||
3 | inherit core-image | 3 | inherit core-image distro_features_check |
4 | 4 | ||
5 | IMAGE_INSTALL += " \ | 5 | IMAGE_INSTALL += " \ |
6 | packagegroup-core-boot \ | 6 | packagegroup-core-boot \ |
7 | ${@bb.utils.contains('MACHINE_FEATURES', 'acpi', 'kernel-module-xen-acpi-processor', '', d)} \ | 7 | ${@bb.utils.contains('MACHINE_FEATURES', 'acpi', 'kernel-module-xen-acpi-processor', '', d)} \ |
8 | " | 8 | " |
9 | 9 | ||
10 | IMAGE_INSTALL += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' xf86-video-fbdev', '', d)}" | 10 | IMAGE_INSTALL += "${@bb.utils.contains('IMAGE_FEATURES', 'x11', ' xf86-video-fbdev', '', d)}" |
11 | IMAGE_INSTALL += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' xf86-video-vesa', '', d)}" | 11 | |
12 | # Install xf86-video-vesa on x86 platforms. | ||
13 | IMAGE_INSTALL_append_x86-64 = "${@bb.utils.contains('IMAGE_FEATURES', 'x11', ' xf86-video-vesa', '', d)}" | ||
14 | IMAGE_INSTALL_append_x86 = "${@bb.utils.contains('IMAGE_FEATURES', 'x11', ' xf86-video-vesa', '', d)}" | ||
15 | |||
16 | # When xf86-video-vesa is not present, add opengl and don't require wayland: | ||
17 | DISTRO_FEATURES_append = "${@bb.utils.contains('IMAGE_FEATURES', 'x11', \ | ||
18 | bb.utils.contains('IMAGE_INSTALL', 'xf86-video-vesa', '', ' opengl', d), '', d)}" | ||
19 | DISTRO_FEATURES_remove = "${@bb.utils.contains('IMAGE_INSTALL', 'xf86-video-vesa', '', 'wayland', d)}" | ||
20 | |||
21 | REQUIRED_DISTRO_FEATURES += "${@bb.utils.contains('IMAGE_FEATURES', 'x11', ' x11', '', d)} xen" | ||
12 | 22 | ||
13 | LICENSE = "MIT" | 23 | LICENSE = "MIT" |
14 | 24 | ||
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend new file mode 100644 index 00000000..95034045 --- /dev/null +++ b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend | |||
@@ -0,0 +1,13 @@ | |||
1 | # Change the default Xserver OpenGL configuration for non-x86 distros with Xen: deselect 'glamor'. | ||
2 | # This removes the dependency on libegl to simplify the domU build. | ||
3 | # | ||
4 | # To override this (eg. if wanted for dom0 images) define: | ||
5 | # REMOVED_OPENGL_PKGCONFIGS = "" | ||
6 | |||
7 | XEN_REMOVED_OPENGL_PKGCONFIGS ?= "glamor" | ||
8 | XEN_REMOVED_OPENGL_PKGCONFIGS_x86 = "" | ||
9 | XEN_REMOVED_OPENGL_PKGCONFIGS_x86-64 = "" | ||
10 | |||
11 | REMOVED_OPENGL_PKGCONFIGS ?= "${@bb.utils.contains('DISTRO_FEATURES', 'xen', "${XEN_REMOVED_OPENGL_PKGCONFIGS}", '', d)}" | ||
12 | |||
13 | OPENGL_PKGCONFIGS_remove = "${REMOVED_OPENGL_PKGCONFIGS}" | ||