diff options
16 files changed, 428 insertions, 0 deletions
diff --git a/recipes-devtools/python/gunicorn_19.1.1.bb b/recipes-devtools/python/gunicorn_19.1.1.bb new file mode 100644 index 00000000..bbe03ea3 --- /dev/null +++ b/recipes-devtools/python/gunicorn_19.1.1.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | SUMMARY = "WSGI HTTP Server for UNIX" | ||
2 | DESCRIPTION = "\ | ||
3 | Gunicorn ‘Green Unicorn’ is a Python WSGI HTTP Server for UNIX. It’s \ | ||
4 | a pre-fork worker model ported from Ruby’s Unicorn project. The \ | ||
5 | Gunicorn server is broadly compatible with various web frameworks, \ | ||
6 | simply implemented, light on server resource usage, and fairly speedy. \ | ||
7 | " | ||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=19a2e253a273e390cd1b91d19b6ee236" | ||
10 | |||
11 | SRC_URI = "https://pypi.python.org/packages/source/g/gunicorn/${PN}-${PV}.tar.gz" | ||
12 | SRC_URI[md5sum] = "eaa72bff5341c05169b76ce3dcbb8140" | ||
13 | SRC_URI[sha256sum] = "82715511fb6246fad4ba66d812eb93416ae8371b464fa88bf3867c9c177daa14" | ||
14 | |||
15 | inherit setuptools | ||
diff --git a/recipes-devtools/python/python-backports-lzma/fix_paths.patch b/recipes-devtools/python/python-backports-lzma/fix_paths.patch new file mode 100644 index 00000000..c2b374f6 --- /dev/null +++ b/recipes-devtools/python/python-backports-lzma/fix_paths.patch | |||
@@ -0,0 +1,17 @@ | |||
1 | --- | ||
2 | setup.py | 4 ++-- | ||
3 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
4 | |||
5 | --- a/setup.py | ||
6 | +++ b/setup.py | ||
7 | @@ -32,8 +32,8 @@ | ||
8 | extens = [Extension('backports/lzma/_lzma', | ||
9 | ['backports/lzma/_lzmamodule.c'], | ||
10 | libraries = ['lzma'], | ||
11 | - include_dirs = [os.path.join(home, 'include'), '/opt/local/include', '/usr/local/include'], | ||
12 | - library_dirs = [os.path.join(home, 'lib'), '/opt/local/lib', '/usr/local/lib'] | ||
13 | + include_dirs = [], | ||
14 | + library_dirs = [] | ||
15 | )] | ||
16 | |||
17 | descr = "Backport of Python 3.3's 'lzma' module for XZ/LZMA compressed files." | ||
diff --git a/recipes-devtools/python/python-backports-lzma_0.0.3.bb b/recipes-devtools/python/python-backports-lzma_0.0.3.bb new file mode 100644 index 00000000..a3586c04 --- /dev/null +++ b/recipes-devtools/python/python-backports-lzma_0.0.3.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | HOMEPAGE = "https://github.com/peterjc/backports.lzma" | ||
2 | SUMMARY = "\ | ||
3 | Backport of Python 3.3's 'lzma' module for XZ/LZMA compressed files." | ||
4 | DESCRIPTION = "\ | ||
5 | This is a backport of the 'lzma' module included in Python 3.3 or later \ | ||
6 | by Nadeem Vawda and Per Oyvind Karlsen, which provides a Python wrapper \ | ||
7 | for XZ Utils (aka LZMA Utils v2) by Igor Pavlov. \ | ||
8 | . \ | ||
9 | In order to compile this, you will need to install XZ Utils from \ | ||
10 | http://tukaani.org/xz/ \ | ||
11 | " | ||
12 | SECTION = "devel/python" | ||
13 | LICENSE = "BSD" | ||
14 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=db4345b3b9524aabc8fe8c65f235c6b2" | ||
15 | |||
16 | SRC_URI[md5sum] = "c3d109746aefa86268e500c07d7e8e0f" | ||
17 | SRC_URI[sha256sum] = "bac58aec8d39ac3d22250840fb24830d0e4a0ef05ad8f3f09172dc0cc80cdbca" | ||
18 | |||
19 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
20 | |||
21 | inherit setuptools | ||
22 | |||
23 | DEPENDS += "xz" | ||
24 | |||
25 | SRCNAME = "backports.lzma" | ||
26 | |||
27 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
28 | |||
29 | SRC_URI = "\ | ||
30 | https://pypi.python.org/packages/source/b/backports.lzma/${SRCNAME}-${PV}.tar.gz \ | ||
31 | file://fix_paths.patch \ | ||
32 | " | ||
diff --git a/recipes-devtools/python/python-blinker_1.3.bb b/recipes-devtools/python/python-blinker_1.3.bb new file mode 100644 index 00000000..24e19b50 --- /dev/null +++ b/recipes-devtools/python/python-blinker_1.3.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | HOMEPAGE = "https://pypi.python.org/pypi/blinker" | ||
2 | SUMMARY = "Fast, simple object-to-object and broadcast signaling" | ||
3 | DESCRIPTION = " \ | ||
4 | Blinker provides a fast dispatching system that allows any number of \ | ||
5 | interested parties to subscribe to events, or “signals”. \ | ||
6 | . \ | ||
7 | Signal receivers can subscribe to specific senders or receive signals \ | ||
8 | sent by any sender. \ | ||
9 | " | ||
10 | SECTION = "devel/python" | ||
11 | LICENSE = "MIT" | ||
12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8baf1d53a00de619f60052e4752a89af" | ||
13 | |||
14 | SRCNAME = "blinker" | ||
15 | SRC_URI = "https://pypi.python.org/packages/source/b/blinker/${SRCNAME}-${PV}.tar.gz" | ||
16 | SRC_URI[md5sum] = "66e9688f2d287593a0e698cd8a5fbc57" | ||
17 | SRC_URI[sha256sum] = "6811010809262261e41ab7b92f3f6d23f35cf816fbec2bc05077992eebec6e2f" | ||
18 | |||
19 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
20 | |||
21 | inherit setuptools | ||
22 | |||
diff --git a/recipes-devtools/python/python-boto_2.34.0.bb b/recipes-devtools/python/python-boto_2.34.0.bb new file mode 100644 index 00000000..f94f3244 --- /dev/null +++ b/recipes-devtools/python/python-boto_2.34.0.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | HOMEPAGE = "https://github.com/boto/boto" | ||
2 | SUMMARY = "Amazon Web Services API" | ||
3 | DESCRIPTION = "\ | ||
4 | Boto is a Python package that provides interfaces to Amazon Web Services. \ | ||
5 | Currently, all features work with Python 2.6 and 2.7. Work is under way to \ | ||
6 | support Python 3.3+ in the same codebase. Modules are being ported one at \ | ||
7 | a time with the help of the open source community, so please check below \ | ||
8 | for compatibility with Python 3.3+. \ | ||
9 | " | ||
10 | SECTION = "devel/python" | ||
11 | LICENSE = "MIT" | ||
12 | LIC_FILES_CHKSUM = "file://setup.py;md5=182ef81236d3fac2c6ed8e8d3c988ec8" | ||
13 | |||
14 | PR = "r0" | ||
15 | SRCNAME = "boto" | ||
16 | |||
17 | SRC_URI = "https://pypi.python.org/packages/source/b/boto/${SRCNAME}-${PV}.tar.gz" | ||
18 | |||
19 | SRC_URI[md5sum] = "5556223d2d0cc4d06dd4829e671dcecd" | ||
20 | SRC_URI[sha256sum] = "33baab022ecb803414ad0d6cf4041d010cfc2755ff8acc3bea7b32e77ba98be0" | ||
21 | |||
22 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
23 | |||
24 | inherit setuptools | ||
25 | |||
diff --git a/recipes-devtools/python/python-bugsnag_2.0.2.bb b/recipes-devtools/python/python-bugsnag_2.0.2.bb new file mode 100644 index 00000000..edf880fb --- /dev/null +++ b/recipes-devtools/python/python-bugsnag_2.0.2.bb | |||
@@ -0,0 +1,26 @@ | |||
1 | HOMEPAGE = "https://bugsnag.com/" | ||
2 | SUMMARY = "Automatic error monitoring for django, flask, etc." | ||
3 | DESCRIPTION = "\ | ||
4 | The official Python notifier for `Bugsnag <https://bugsnag.com/>`_. \ | ||
5 | Provides support for automatically capturing and sending exceptions \ | ||
6 | in your Django and other Python apps to Bugsnag, to help you find \ | ||
7 | and solve your bugs as fast as possible. \ | ||
8 | " | ||
9 | SECTION = "devel/python" | ||
10 | LICENSE = "MIT" | ||
11 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=f6df6ab9f1b615a140ebb2a48f61bddc" | ||
12 | |||
13 | PR = "r0" | ||
14 | SRCNAME = "bugsnag" | ||
15 | |||
16 | SRC_URI = "https://pypi.python.org/packages/source/b/bugsnag/${SRCNAME}-${PV}.tar.gz" | ||
17 | |||
18 | SRC_URI[md5sum] = "e16360d86979890892cd388635f213e7" | ||
19 | SRC_URI[sha256sum] = "093934b3cd1d36ba2b89cfe1673b14ba59043417fe500a02dbf6de0df43ea962" | ||
20 | |||
21 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
22 | |||
23 | inherit setuptools | ||
24 | |||
25 | DEPENDS += "python-webob python-flask python-blinker" | ||
26 | |||
diff --git a/recipes-devtools/python/python-docker-registry-core_2.0.3.bb b/recipes-devtools/python/python-docker-registry-core_2.0.3.bb new file mode 100644 index 00000000..7aa6825e --- /dev/null +++ b/recipes-devtools/python/python-docker-registry-core_2.0.3.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | HOMEPAGE = "https://pypi.python.org/pypi/docker-registry-core" | ||
2 | SUMMARY = "Docker registry core package" | ||
3 | DESCRIPTION = "core package for docker-registry (drivers) developers" | ||
4 | SECTION = "devel/python" | ||
5 | LICENSE = "Apache-2.0" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
7 | |||
8 | SRCNAME = "docker-registry-core" | ||
9 | |||
10 | SRC_URI = "https://pypi.python.org/packages/source/d/docker-registry-core/${SRCNAME}-${PV}.tar.gz" | ||
11 | |||
12 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
13 | |||
14 | SRC_URI[md5sum] = "610ef9395f2e9a2f91c68d13325fce7b" | ||
15 | SRC_URI[sha256sum] = "347e804f1f35b28dbe27bf8d7a0b630fca29d684032139bf26e3940572360360" | ||
16 | |||
17 | inherit setuptools | ||
18 | |||
19 | DEPENDS += "\ | ||
20 | python-distribute \ | ||
21 | python-boto (= 2.34.0) \ | ||
22 | python-redis (= 2.10.3) \ | ||
23 | python-simplejson (= 3.6.2) \ | ||
24 | " | ||
25 | |||
26 | # boto 2.34.0 | ||
27 | # redis 2.10.3 | ||
28 | # simplejson 3.6.2 | ||
29 | # setuptools 5.8 | ||
diff --git a/recipes-devtools/python/python-flask-cors_1.10.3.bb b/recipes-devtools/python/python-flask-cors_1.10.3.bb new file mode 100644 index 00000000..c39e9b26 --- /dev/null +++ b/recipes-devtools/python/python-flask-cors_1.10.3.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | HOMEPAGE = "https://pypi.python.org/pypi/Flask-Cors/1.10.3" | ||
2 | SUMMARY = "A Flask extension adding a decorator for CORS support" | ||
3 | DESCRIPTION = "\ | ||
4 | A Flask extension for handling Cross Origin Resource Sharing (CORS), making cross-origin AJAX possible \ | ||
5 | " | ||
6 | SECTION = "devel/python" | ||
7 | LICENSE = "MIT" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4784781a5ee9fed9c50272e733e07685" | ||
9 | |||
10 | DEPENDS += "python-six python-flask" | ||
11 | |||
12 | PR = "r0" | ||
13 | SRCNAME = "Flask-Cors" | ||
14 | |||
15 | SRC_URI = "https://pypi.python.org/packages/source/F/Flask-Cors/${SRCNAME}-${PV}.tar.gz" | ||
16 | |||
17 | SRC_URI[md5sum] = "4f3c75ace0f724d1de167bd73745c965" | ||
18 | SRC_URI[sha256sum] = "9e6927aa0a46f314bca0ec63eb871cee898a162adfdd5b65224db7a008287423" | ||
19 | |||
20 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
21 | |||
22 | inherit setuptools | ||
diff --git a/recipes-devtools/python/python-gevent/libev-conf.patch b/recipes-devtools/python/python-gevent/libev-conf.patch new file mode 100644 index 00000000..283705f8 --- /dev/null +++ b/recipes-devtools/python/python-gevent/libev-conf.patch | |||
@@ -0,0 +1,19 @@ | |||
1 | Due to differences in library locations, the cross compile test can fail because it can't run | ||
2 | the conftest binary (dynamically linked). Building it statically instead. | ||
3 | |||
4 | Signed-off-by: Amy Fong <amy.fong@windriver.com> | ||
5 | --- | ||
6 | libev/configure | 2 +- | ||
7 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
8 | |||
9 | --- a/libev/configure | ||
10 | +++ b/libev/configure | ||
11 | @@ -2730,7 +2730,7 @@ | ||
12 | ac_ext=c | ||
13 | ac_cpp='$CPP $CPPFLAGS' | ||
14 | ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5' | ||
15 | -ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5' | ||
16 | +ac_link='$CC -static -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5' | ||
17 | ac_compiler_gnu=$ac_cv_c_compiler_gnu | ||
18 | if test -n "$ac_tool_prefix"; then | ||
19 | # Extract the first word of "${ac_tool_prefix}gcc", so it can be a program name with args. | ||
diff --git a/recipes-devtools/python/python-gevent_1.0.1.bb b/recipes-devtools/python/python-gevent_1.0.1.bb new file mode 100644 index 00000000..f42979be --- /dev/null +++ b/recipes-devtools/python/python-gevent_1.0.1.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | HOMEPAGE = "http://www.gevent.org" | ||
2 | SUMMARY = "A coroutine-based Python networking library" | ||
3 | DESCRIPTION = "\ | ||
4 | gevent is a coroutine-based Python networking library that uses greenlet \ | ||
5 | to provide a high-level synchronous API on top of the libevent event \ | ||
6 | loop. \ | ||
7 | " | ||
8 | SECTION = "devel/python" | ||
9 | LICENSE = "MIT" | ||
10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2dbb33d00e1fd31c7041460a81ac0bd2" | ||
11 | DEPENDS += "python-greenlet libevent" | ||
12 | RDEPENDS_${PN} += "python-greenlet python-mime python-pprint python-re" | ||
13 | |||
14 | SRCNAME = "gevent" | ||
15 | |||
16 | SRC_URI = "http://pypi.python.org/packages/source/g/gevent/${SRCNAME}-${PV}.tar.gz" | ||
17 | SRC_URI[md5sum] = "7b952591d1a0174d6eb6ac47bd975ab6" | ||
18 | SRC_URI[sha256sum] = "4627e215d058f71d95e6b26d9e7be4c263788a4756bd2858a93775f6c072df43" | ||
19 | |||
20 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
21 | |||
22 | inherit setuptools | ||
23 | |||
24 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
25 | SRC_URI += "file://libev-conf.patch" | ||
diff --git a/recipes-devtools/python/python-m2crypto_0.22.3.bb b/recipes-devtools/python/python-m2crypto_0.22.3.bb new file mode 100644 index 00000000..33254552 --- /dev/null +++ b/recipes-devtools/python/python-m2crypto_0.22.3.bb | |||
@@ -0,0 +1,60 @@ | |||
1 | HOMEPAGE = "http://chandlerproject.org/bin/view/Projects/MeTooCrypto" | ||
2 | SUMMARY = "A Python crypto and SSL toolkit" | ||
3 | DESCRIPTION = "\ | ||
4 | M2Crypto is the most complete Python wrapper for OpenSSL featuring RSA, \ | ||
5 | DSA, DH, EC, HMACs, message digests, symmetric ciphers (including \ | ||
6 | AES); SSL functionality to implement clients and servers; HTTPS \ | ||
7 | extensions to Python's httplib, urllib, and xmlrpclib; unforgeable \ | ||
8 | HMAC'ing AuthCookies for web session management; FTP/TLS client and \ | ||
9 | server; S/MIME; ZServerSSL: A HTTPS server for Zope and ZSmime: An \ | ||
10 | S/MIME messenger for Zope. M2Crypto can also be used to provide SSL \ | ||
11 | for Twisted. \ | ||
12 | " | ||
13 | LICENSE = "BSD" | ||
14 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=0ccca7097c1d29fa42e75e9c15c6ff2e" | ||
15 | |||
16 | SRCNAME = "M2Crypto" | ||
17 | SRC_URI = "http://pypi.python.org/packages/source/M/M2Crypto/${SRCNAME}-${PV}.tar.gz" | ||
18 | |||
19 | SRC_URI[md5sum] = "573f21aaac7d5c9549798e72ffcefedd" | ||
20 | SRC_URI[sha256sum] = "6071bfc817d94723e9b458a010d565365104f84aa73f7fe11919871f7562ff72" | ||
21 | |||
22 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
23 | |||
24 | inherit setuptools | ||
25 | |||
26 | DEPENDS += "openssl swig-native" | ||
27 | |||
28 | DISTUTILS_BUILD_ARGS += "build_ext -I${STAGING_INCDIR}" | ||
29 | |||
30 | inherit setuptools | ||
31 | |||
32 | SWIG_FEATURES_x86-64 = "-D__x86_64__" | ||
33 | SWIG_FEATURES ?= "" | ||
34 | export SWIG_FEATURES | ||
35 | |||
36 | # Get around a problem with swig, but only if the | ||
37 | # multilib header file exists. | ||
38 | # | ||
39 | do_compile_prepend() { | ||
40 | sed -i -e 's/self.add_multiarch_paths.*$/# &/;' ${S}/setup.py | ||
41 | sed -i -e 's/opensslIncludeDir = .*$/opensslIncludeDir = os.getenv("STAGING_INCDIR")/;' ${S}/setup.py | ||
42 | sed -i -e 's/opensslLibraryDir = .*$/opensslLibraryDir = os.getenv("STAGING_LIBDIR")/;' ${S}/setup.py | ||
43 | |||
44 | if [ "${SITEINFO_BITS}" = "64" ];then | ||
45 | bit="64" | ||
46 | else | ||
47 | bit="32" | ||
48 | fi | ||
49 | |||
50 | if [ -e ${STAGING_INCDIR}/openssl/opensslconf-${bit}.h ]; then | ||
51 | for i in SWIG/_ec.i SWIG/_evp.i; do | ||
52 | sed -i -e "s/opensslconf.*\./opensslconf-${bit}\./" "$i" | ||
53 | done | ||
54 | elif [ -e ${STAGING_INCDIR}/openssl/opensslconf-n${bit}.h ] ;then | ||
55 | for i in SWIG/_ec.i SWIG/_evp.i; do | ||
56 | sed -i -e "s/opensslconf.*\./opensslconf-n${bit}\./" "$i" | ||
57 | done | ||
58 | fi | ||
59 | } | ||
60 | |||
diff --git a/recipes-devtools/python/python-newrelic_2.22.0.19.bb b/recipes-devtools/python/python-newrelic_2.22.0.19.bb new file mode 100644 index 00000000..38918249 --- /dev/null +++ b/recipes-devtools/python/python-newrelic_2.22.0.19.bb | |||
@@ -0,0 +1,26 @@ | |||
1 | HOMEPAGE = "http://www.newrelic.com" | ||
2 | SUMMARY = "New Relic Python Agent" | ||
3 | DESCRIPTION = "\ | ||
4 | Python agent for the New Relic web application performance monitoring \ | ||
5 | service. Check the release notes for what has changed in this version. \ | ||
6 | " | ||
7 | SECTION = "devel/python" | ||
8 | LICENSE = "BSD-3-Clause & MIT & Python-2.0 & BSD-2-Clause & NewRelic" | ||
9 | LIC_FILES_CHKSUM = "file://newrelic/LICENSE;md5=0f6cc160a8ed6759faa408a30b6ac978" | ||
10 | |||
11 | PR = "r0" | ||
12 | SRCNAME = "newrelic" | ||
13 | |||
14 | SRC_URI = "https://pypi.python.org/packages/source/n/newrelic/${SRCNAME}-${PV}.tar.gz" | ||
15 | |||
16 | SRC_URI[md5sum] = "f8c9bf996d040a11847d14682b290eff" | ||
17 | SRC_URI[sha256sum] = "aa8869413c21aff441a77582df1e0fdc0f67342760eb7560d33ed3bbed7edf7b" | ||
18 | |||
19 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
20 | |||
21 | inherit setuptools | ||
22 | |||
23 | FILES_${PN}-dbg += "\ | ||
24 | ${PYTHON_SITEPACKAGES_DIR}/newrelic-${PV}/newrelic/*/.debug \ | ||
25 | ${PYTHON_SITEPACKAGES_DIR}/newrelic-${PV}/newrelic/packages/*/.debug/ \ | ||
26 | " | ||
diff --git a/recipes-devtools/python/python-pyyaml_3.11.bb b/recipes-devtools/python/python-pyyaml_3.11.bb new file mode 100644 index 00000000..cb1db8c6 --- /dev/null +++ b/recipes-devtools/python/python-pyyaml_3.11.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | HOMEPAGE = "http://www.pyyaml.org" | ||
2 | SUMMARY = "Python support for YAML" | ||
3 | DESCRIPTION = "\ | ||
4 | YAML is a data serialization format designed for human readability \ | ||
5 | and interaction with scripting languages. PyYAML is a YAML parser \ | ||
6 | and emitter for Python. \ | ||
7 | . \ | ||
8 | PyYAML features a complete YAML 1.1 parser, Unicode support, pickle \ | ||
9 | support, capable extension API, and sensible error messages. PyYAML \ | ||
10 | supports standard YAML tags and provides Python-specific tags that \ | ||
11 | allow to represent an arbitrary Python object. \ | ||
12 | . \ | ||
13 | PyYAML is applicable for a broad range of tasks from complex \ | ||
14 | configuration files to object serialization and persistance. \ | ||
15 | " | ||
16 | SECTION = "devel/python" | ||
17 | LICENSE = "MIT" | ||
18 | LIC_FILES_CHKSUM = "file://LICENSE;md5=6015f088759b10e0bc2bf64898d4ae17" | ||
19 | |||
20 | SRCNAME = "PyYAML" | ||
21 | SRC_URI = "http://pyyaml.org/download/pyyaml/${SRCNAME}-${PV}.tar.gz" | ||
22 | |||
23 | SRC_URI[md5sum] = "f50e08ef0fe55178479d3a618efe21db" | ||
24 | SRC_URI[sha256sum] = "c36c938a872e5ff494938b33b14aaa156cb439ec67548fcab3535bb78b0846e8" | ||
25 | |||
26 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
27 | |||
28 | inherit setuptools | ||
29 | |||
30 | DEPENDS += "libyaml python-cython-native" | ||
diff --git a/recipes-devtools/python/python-redis_2.10.3.bb b/recipes-devtools/python/python-redis_2.10.3.bb new file mode 100644 index 00000000..9eda8a5c --- /dev/null +++ b/recipes-devtools/python/python-redis_2.10.3.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | HOMEPAGE = "https://pypi.python.org/pypi/redis/" | ||
2 | SUMMARY = "Python client for Redis key-value store" | ||
3 | DESCRIPTION = "The Python interface to the Redis key-value store." | ||
4 | SECTION = "devel/python" | ||
5 | LICENSE = "MIT" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=51d9ad56299ab60ba7be65a621004f27" | ||
7 | |||
8 | PR = "r0" | ||
9 | SRCNAME = "redis" | ||
10 | |||
11 | SRC_URI = "https://pypi.python.org/packages/source/r/redis/${SRCNAME}-${PV}.tar.gz" | ||
12 | |||
13 | SRC_URI[md5sum] = "7619221ad0cbd124a5687458ea3f5289" | ||
14 | SRC_URI[sha256sum] = "a4fb37b02860f6b1617f6469487471fd086dd2d38bbce640c2055862b9c4019c" | ||
15 | |||
16 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
17 | |||
18 | inherit setuptools | ||
19 | |||
20 | RDEPENDS_${PN} = "redis" | ||
diff --git a/recipes-devtools/python/python-requests_2.3.0.bb b/recipes-devtools/python/python-requests_2.3.0.bb new file mode 100644 index 00000000..6f38bf1c --- /dev/null +++ b/recipes-devtools/python/python-requests_2.3.0.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | HOMEPAGE = "http://python-requests.org" | ||
2 | SUMMARY = "Python HTTP for Humans." | ||
3 | DESCRIPTION = "\ | ||
4 | Requests is an Apache2 Licensed HTTP library, written in Python, \ | ||
5 | for human beings. \ | ||
6 | . \ | ||
7 | Most existing Python modules for sending HTTP requests are extremely \ | ||
8 | verbose and cumbersome. Python's builtin urllib2 module provides most \ | ||
9 | of the HTTP capabilities you should need, but the api is thoroughly \ | ||
10 | broken. It requires an enormous amount of work (even method overrides) \ | ||
11 | to perform the simplest of tasks. \ | ||
12 | . \ | ||
13 | Things shouldn't be this way. Not in Python \ | ||
14 | " | ||
15 | SECTION = "devel/python" | ||
16 | LICENSE = "Apache-2.0" | ||
17 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c7869e52c8275537186de35e3cd5f9ec" | ||
18 | |||
19 | PR = "r0" | ||
20 | SRCNAME = "requests" | ||
21 | |||
22 | SRC_URI = "http://pypi.python.org/packages/source/r/requests/${SRCNAME}-${PV}.tar.gz" | ||
23 | |||
24 | SRC_URI[md5sum] = "7449ffdc8ec9ac37bbcd286003c80f00" | ||
25 | SRC_URI[sha256sum] = "1c1473875d846fe563d70868acf05b1953a4472f4695b7b3566d1d978957b8fc" | ||
26 | |||
27 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
28 | |||
29 | inherit setuptools | ||
diff --git a/recipes-devtools/python/python-simplejson_3.6.2.bb b/recipes-devtools/python/python-simplejson_3.6.2.bb new file mode 100644 index 00000000..f13f1f38 --- /dev/null +++ b/recipes-devtools/python/python-simplejson_3.6.2.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson" | ||
2 | SUMMARY = "Simple, fast, extensible JSON encoder/decoder for Python" | ||
3 | DESCRIPTION = "\ | ||
4 | JSON <http://json.org> encoder and decoder for Python 2.5+ \ | ||
5 | and Python 3.3+. It is pure Python code with no dependencies, \ | ||
6 | but includes an optional C extension for a serious speed boost \ | ||
7 | " | ||
8 | SECTION = "devel/python" | ||
9 | LICENSE = "MIT" | ||
10 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e" | ||
11 | PR = "r0" | ||
12 | |||
13 | SRCNAME = "simplejson" | ||
14 | |||
15 | SRC_URI = "https://pypi.python.org/packages/source/s/simplejson/${SRCNAME}-${PV}.tar.gz" | ||
16 | SRC_URI[md5sum] = "deca871b9bfa4b76ea360756b2a22710" | ||
17 | SRC_URI[sha256sum] = "99c092209f88d411858f01b14a97a4fcf8c4f438a685e23d733a3d65de52a35d" | ||
18 | |||
19 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
20 | |||
21 | inherit distutils | ||
22 | |||
23 | RDEPENDS_${PN} = "\ | ||
24 | python-core \ | ||
25 | python-re \ | ||
26 | python-io \ | ||
27 | python-netserver \ | ||
28 | python-numbers \ | ||
29 | " | ||
30 | |||
31 | |||