diff options
-rw-r--r-- | recipes-extended/cloud-init/cloud-init/0001-setup.py-check-for-install-anywhere-in-args.patch | 15 | ||||
-rw-r--r-- | recipes-extended/cloud-init/cloud-init/0001-setup.py-respect-udevdir-variable.patch | 43 | ||||
-rw-r--r-- | recipes-extended/cloud-init/cloud-init_21.4.bb (renamed from recipes-extended/cloud-init/cloud-init_20.3.bb) | 3 |
3 files changed, 28 insertions, 33 deletions
diff --git a/recipes-extended/cloud-init/cloud-init/0001-setup.py-check-for-install-anywhere-in-args.patch b/recipes-extended/cloud-init/cloud-init/0001-setup.py-check-for-install-anywhere-in-args.patch index f61b82ce..5c9c1e6f 100644 --- a/recipes-extended/cloud-init/cloud-init/0001-setup.py-check-for-install-anywhere-in-args.patch +++ b/recipes-extended/cloud-init/cloud-init/0001-setup.py-check-for-install-anywhere-in-args.patch | |||
@@ -16,19 +16,16 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | |||
16 | setup.py | 2 +- | 16 | setup.py | 2 +- |
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | 17 | 1 file changed, 1 insertion(+), 1 deletion(-) |
18 | 18 | ||
19 | diff --git a/setup.py b/setup.py | 19 | Index: git/setup.py |
20 | index cbacf48e..5f13d9eb 100755 | 20 | =================================================================== |
21 | --- a/setup.py | 21 | --- git.orig/setup.py |
22 | +++ b/setup.py | 22 | +++ git/setup.py |
23 | @@ -87,7 +87,7 @@ def render_tmpl(template, mode=None): | 23 | @@ -87,7 +87,7 @@ |
24 | 24 | ||
25 | # older versions of tox use bdist (xenial), and then install from there. | 25 | # older versions of tox use bdist (xenial), and then install from there. |
26 | # newer versions just use install. | 26 | # newer versions just use install. |
27 | - if not (sys.argv[1] == 'install' or sys.argv[1].startswith('bdist*')): | 27 | - if not (sys.argv[1] == "install" or sys.argv[1].startswith("bdist*")): |
28 | + if not ('install' in sys.argv or sys.argv[1].startswith('bdist*')): | 28 | + if not ('install' in sys.argv or sys.argv[1].startswith('bdist*')): |
29 | return template | 29 | return template |
30 | 30 | ||
31 | tmpl_ext = ".tmpl" | 31 | tmpl_ext = ".tmpl" |
32 | -- | ||
33 | 2.25.1 | ||
34 | |||
diff --git a/recipes-extended/cloud-init/cloud-init/0001-setup.py-respect-udevdir-variable.patch b/recipes-extended/cloud-init/cloud-init/0001-setup.py-respect-udevdir-variable.patch index 94ec98ac..e96b5cbd 100644 --- a/recipes-extended/cloud-init/cloud-init/0001-setup.py-respect-udevdir-variable.patch +++ b/recipes-extended/cloud-init/cloud-init/0001-setup.py-respect-udevdir-variable.patch | |||
@@ -16,27 +16,24 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | |||
16 | setup.py | 3 ++- | 16 | setup.py | 3 ++- |
17 | 1 file changed, 2 insertions(+), 1 deletion(-) | 17 | 1 file changed, 2 insertions(+), 1 deletion(-) |
18 | 18 | ||
19 | diff --git a/setup.py b/setup.py | 19 | Index: git/setup.py |
20 | index cbacf48e..5e137a6d 100755 | 20 | =================================================================== |
21 | --- a/setup.py | 21 | --- git.orig/setup.py |
22 | +++ b/setup.py | 22 | +++ git/setup.py |
23 | @@ -142,6 +142,7 @@ INITSYS_ROOTS = { | 23 | @@ -159,6 +159,7 @@ |
24 | 'sysvinit_deb': 'etc/init.d', | 24 | "sysvinit_deb": "etc/init.d", |
25 | 'sysvinit_openrc': 'etc/init.d', | 25 | "sysvinit_openrc": "etc/init.d", |
26 | 'sysvinit_suse': 'etc/init.d', | 26 | "sysvinit_suse": "etc/init.d", |
27 | + 'udevdir': pkg_config_read('udev', 'udevdir'), | 27 | + 'udevdir': pkg_config_read('udev', 'udevdir'), |
28 | 'systemd': pkg_config_read('systemd', 'systemdsystemunitdir'), | 28 | "systemd": pkg_config_read("systemd", "systemdsystemunitdir"), |
29 | 'systemd.generators': pkg_config_read('systemd', | 29 | "systemd.generators": pkg_config_read( |
30 | 'systemdsystemgeneratordir'), | 30 | "systemd", "systemdsystemgeneratordir" |
31 | @@ -264,7 +265,7 @@ if not platform.system().endswith('BSD'): | 31 | @@ -307,7 +308,7 @@ |
32 | (ETC + '/NetworkManager/dispatcher.d/', | 32 | ["tools/hook-network-manager"], |
33 | ['tools/hook-network-manager']), | 33 | ), |
34 | (ETC + '/dhcp/dhclient-exit-hooks.d/', ['tools/hook-dhclient']), | 34 | (ETC + "/dhcp/dhclient-exit-hooks.d/", ["tools/hook-dhclient"]), |
35 | - (LIB + '/udev/rules.d', [f for f in glob('udev/*.rules')]) | 35 | - (LIB + "/udev/rules.d", [f for f in glob("udev/*.rules")]), |
36 | + ('udevdir' + '/rules.d', [f for f in glob('udev/*.rules')]) | 36 | + ('udevdir' + "/rules.d", [f for f in glob("udev/*.rules")]), |
37 | ]) | 37 | ( |
38 | # Use a subclass for install that handles | 38 | ETC + "/systemd/system/sshd-keygen@.service.d/", |
39 | # adding on the right init system configuration files | 39 | ["systemd/disable-sshd-keygen-if-cloud-init-active.conf"], |
40 | -- | ||
41 | 2.27.0 | ||
42 | |||
diff --git a/recipes-extended/cloud-init/cloud-init_20.3.bb b/recipes-extended/cloud-init/cloud-init_21.4.bb index d5605b86..660b808e 100644 --- a/recipes-extended/cloud-init/cloud-init_20.3.bb +++ b/recipes-extended/cloud-init/cloud-init_21.4.bb | |||
@@ -4,7 +4,7 @@ SECTION = "devel/python" | |||
4 | LICENSE = "GPLv3" | 4 | LICENSE = "GPLv3" |
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c6dd79b6ec2130a3364f6fa9d6380408" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c6dd79b6ec2130a3364f6fa9d6380408" |
6 | 6 | ||
7 | SRCREV = "1431c8a1bddaabf85e1bbb32bf316a3aef20036e" | 7 | SRCREV = "a97fd062f7dbd4b824fd006edd08927ef9dbf24a" |
8 | SRC_URI = "git://github.com/canonical/cloud-init;branch=main;protocol=https \ | 8 | SRC_URI = "git://github.com/canonical/cloud-init;branch=main;protocol=https \ |
9 | file://cloud-init-source-local-lsb-functions.patch \ | 9 | file://cloud-init-source-local-lsb-functions.patch \ |
10 | file://0001-setup.py-check-for-install-anywhere-in-args.patch \ | 10 | file://0001-setup.py-check-for-install-anywhere-in-args.patch \ |
@@ -55,5 +55,6 @@ RDEPENDS:${PN} = "python3 \ | |||
55 | python3-jsonschema \ | 55 | python3-jsonschema \ |
56 | python3-pyyaml \ | 56 | python3-pyyaml \ |
57 | python3-oauthlib \ | 57 | python3-oauthlib \ |
58 | bash \ | ||
58 | " | 59 | " |
59 | 60 | ||