summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/xen/xen.inc25
1 files changed, 15 insertions, 10 deletions
diff --git a/recipes-extended/xen/xen.inc b/recipes-extended/xen/xen.inc
index 54d6ffe9..c8fad6c5 100644
--- a/recipes-extended/xen/xen.inc
+++ b/recipes-extended/xen/xen.inc
@@ -274,6 +274,8 @@ FILES_${PN}-libfsimage-dev = "${libdir}/libfsimage.so"
274FILES_${PN}-fsimage = "${libdir}/fs/*/*fsimage.so" 274FILES_${PN}-fsimage = "${libdir}/fs/*/*fsimage.so"
275 275
276FILES_${PN}-hypervisor = "\ 276FILES_${PN}-hypervisor = "\
277 /boot/xen-* \
278 /boot/xen \
277 /boot/xen-*.gz \ 279 /boot/xen-*.gz \
278 /boot/xen.gz \ 280 /boot/xen.gz \
279 /boot/xen-syms-* \ 281 /boot/xen-syms-* \
@@ -656,20 +658,18 @@ EXTRA_OECONF += " \
656 658
657do_configure() { 659do_configure() {
658 # no stubs-32.h in our 64-bit sysroot - hack it into tools/include/gnu 660 # no stubs-32.h in our 64-bit sysroot - hack it into tools/include/gnu
659 test -d ${S}/tools/include/gnu || mkdir ${S}/tools/include/gnu
660 if ! test -f ${STAGING_DIR_TARGET}/usr/include/gnu/stubs-32.h ; then 661 if ! test -f ${STAGING_DIR_TARGET}/usr/include/gnu/stubs-32.h ; then
661 cat ${STAGING_DIR_TARGET}/usr/include/gnu/stubs-64.h | grep -v stub_bdflush | grep -v stub_getmsg | grep -v stub_putmsg > ${S}/tools/include/gnu/stubs-32.h 662 if test -f ${STAGING_DIR_TARGET}/usr/include/gnu/stubs-64.h ; then
662 echo \#define __stub___kernel_cosl >> ${S}/tools/include/gnu/stubs-32.h 663 test -d ${S}/tools/include/gnu || mkdir ${S}/tools/include/gnu
663 echo \#define __stub___kernel_sinl >> ${S}/tools/include/gnu/stubs-32.h 664 cat ${STAGING_DIR_TARGET}/usr/include/gnu/stubs-64.h | grep -v stub_bdflush | grep -v stub_getmsg | grep -v stub_putmsg > ${S}/tools/include/gnu/stubs-32.h
664 echo \#define __stub___kernel_tanl >> ${S}/tools/include/gnu/stubs-32.h 665 echo \#define __stub___kernel_cosl >> ${S}/tools/include/gnu/stubs-32.h
666 echo \#define __stub___kernel_sinl >> ${S}/tools/include/gnu/stubs-32.h
667 echo \#define __stub___kernel_tanl >> ${S}/tools/include/gnu/stubs-32.h
668 fi
665 fi 669 fi
666 670
667 # do configure 671 # do configure
668 oe_runconf 672 oe_runconf
669
670 # seabios needs a patch to specify correct compiler - pull and patch Makefile
671 make -C ${S}/tools/firmware seabios-dir
672 sed -i 's/export HOSTCC.*$(CC)/export HOSTCC ?= $(CC)/g' ${S}/tools/firmware/seabios-dir/Makefile
673} 673}
674 674
675do_compile() { 675do_compile() {
@@ -720,5 +720,10 @@ sysroot_stage_all_append() {
720 sysroot_stage_dir ${D}/boot ${SYSROOT_DESTDIR}/kernel 720 sysroot_stage_dir ${D}/boot ${SYSROOT_DESTDIR}/kernel
721 721
722 install -d ${DEPLOY_DIR_IMAGE} 722 install -d ${DEPLOY_DIR_IMAGE}
723 install -m 0644 ${D}/boot/xen.gz ${DEPLOY_DIR_IMAGE}/xen-${MACHINE}.gz 723 if [ -f ${D}/boot/xen ]; then
724 install -m 0644 ${D}/boot/xen ${DEPLOY_DIR_IMAGE}/xen-${MACHINE}
725 fi
726 if [ -f ${D}/boot/xen.gz ]; then
727 install -m 0644 ${D}/boot/xen.gz ${DEPLOY_DIR_IMAGE}/xen-${MACHINE}.gz
728 fi
724} 729}