summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/podman/podman_git.bb12
1 files changed, 8 insertions, 4 deletions
diff --git a/recipes-containers/podman/podman_git.bb b/recipes-containers/podman/podman_git.bb
index aa6b25b3..af94f0c4 100644
--- a/recipes-containers/podman/podman_git.bb
+++ b/recipes-containers/podman/podman_git.bb
@@ -24,9 +24,9 @@ python __anonymous() {
24 raise bb.parse.SkipRecipe(msg) 24 raise bb.parse.SkipRecipe(msg)
25} 25}
26 26
27SRCREV = "444a19cdd2e6108c75f6c1aadc1a2a9138a8bd73" 27SRCREV = "a11c4ead10177a66ef2810a0a92ea8ce2299da07"
28SRC_URI = " \ 28SRC_URI = " \
29 git://github.com/containers/libpod.git;branch=master \ 29 git://github.com/containers/libpod.git;branch=v2.0 \
30" 30"
31 31
32LICENSE = "Apache-2.0" 32LICENSE = "Apache-2.0"
@@ -36,7 +36,7 @@ GO_IMPORT = "import"
36 36
37S = "${WORKDIR}/git" 37S = "${WORKDIR}/git"
38 38
39PV = "1.8.1+git${SRCREV}" 39PV = "2.0.1+git${SRCPV}"
40 40
41PACKAGES =+ "${PN}-contrib" 41PACKAGES =+ "${PN}-contrib"
42 42
@@ -78,7 +78,7 @@ do_compile() {
78 78
79 cd ${S}/src/.gopath/src/"${PODMAN_PKG}" 79 cd ${S}/src/.gopath/src/"${PODMAN_PKG}"
80 80
81 oe_runmake cmd/podman/varlink/iopodman.go GO=go 81 oe_runmake pkg/varlink/iopodman.go GO=go
82 82
83 # Pass the needed cflags/ldflags so that cgo 83 # Pass the needed cflags/ldflags so that cgo
84 # can find the needed headers files and libraries 84 # can find the needed headers files and libraries
@@ -93,6 +93,10 @@ do_compile() {
93do_install() { 93do_install() {
94 cd ${S}/src/.gopath/src/"${PODMAN_PKG}" 94 cd ${S}/src/.gopath/src/"${PODMAN_PKG}"
95 95
96 export GOARCH="${BUILD_GOARCH}"
97 export GOPATH="${S}/src/.gopath"
98 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
99
96 oe_runmake install DESTDIR="${D}" 100 oe_runmake install DESTDIR="${D}"
97 if ${@bb.utils.contains('PACKAGECONFIG', 'docker', 'true', 'false', d)}; then 101 if ${@bb.utils.contains('PACKAGECONFIG', 'docker', 'true', 'false', d)}; then
98 oe_runmake install.docker DESTDIR="${D}" 102 oe_runmake install.docker DESTDIR="${D}"