summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/runc/runc-opencontainers_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-containers/runc/runc-opencontainers_git.bb b/recipes-containers/runc/runc-opencontainers_git.bb
index 940ae952..902a93da 100644
--- a/recipes-containers/runc/runc-opencontainers_git.bb
+++ b/recipes-containers/runc/runc-opencontainers_git.bb
@@ -6,9 +6,11 @@ RUNC_VERSION = "1.0.0-rc4"
6PROVIDES += "virtual/runc" 6PROVIDES += "virtual/runc"
7RPROVIDES_${PN} = "virtual/runc" 7RPROVIDES_${PN} = "virtual/runc"
8 8
9GO_IMPORT = "import"
10
9do_compile_prepend() { 11do_compile_prepend() {
10 # Go looks in a src directory under any directory in GOPATH but 12 # Go looks in a src directory under any directory in GOPATH but
11 # runc-opencontainers uses 'vendor' instead of 'vendor/src'. We can fix 13 # runc-opencontainers uses 'vendor' instead of 'vendor/src'. We can fix
12 # this with a symlink. 14 # this with a symlink.
13 ln -sfn . "${S}/vendor/src" 15 ln -sfn . "${S}/src/import/vendor/src"
14} 16}