diff options
-rw-r--r-- | recipes-containers/criu/criu_git.bb | 1 | ||||
-rw-r--r-- | recipes-containers/criu/files/0001-kdat-Don-t-open-run-criu.kdat-if-doesn-t-exists.patch | 42 |
2 files changed, 43 insertions, 0 deletions
diff --git a/recipes-containers/criu/criu_git.bb b/recipes-containers/criu/criu_git.bb index 00de417b..45195ea6 100644 --- a/recipes-containers/criu/criu_git.bb +++ b/recipes-containers/criu/criu_git.bb | |||
@@ -21,6 +21,7 @@ SRC_URI = "git://github.com/xemul/criu.git;protocol=git \ | |||
21 | file://0002-criu-Skip-documentation-install.patch \ | 21 | file://0002-criu-Skip-documentation-install.patch \ |
22 | file://0001-criu-Change-libraries-install-directory.patch \ | 22 | file://0001-criu-Change-libraries-install-directory.patch \ |
23 | file://lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch \ | 23 | file://lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch \ |
24 | file://0001-kdat-Don-t-open-run-criu.kdat-if-doesn-t-exists.patch \ | ||
24 | " | 25 | " |
25 | 26 | ||
26 | COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux" | 27 | COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux" |
diff --git a/recipes-containers/criu/files/0001-kdat-Don-t-open-run-criu.kdat-if-doesn-t-exists.patch b/recipes-containers/criu/files/0001-kdat-Don-t-open-run-criu.kdat-if-doesn-t-exists.patch new file mode 100644 index 00000000..805f7996 --- /dev/null +++ b/recipes-containers/criu/files/0001-kdat-Don-t-open-run-criu.kdat-if-doesn-t-exists.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | From b9760919eb3f805dd3d2af5692b49cba9c468595 Mon Sep 17 00:00:00 2001 | ||
2 | From: "Hongzhi.Song" <hongzhi.song@windriver.com> | ||
3 | Date: Mon, 26 Nov 2018 02:39:59 -0500 | ||
4 | Subject: [PATCH] kdat: Don't open /run/criu.kdat if doesn't exists | ||
5 | |||
6 | When CRIU is called for a first time and the /run/criu.kdat file does | ||
7 | not exists, the following warning is shown: | ||
8 | Warn (criu/kerndat.c:847): Can't load /run/criu.kdat | ||
9 | |||
10 | This patch is replacing this warning with a more appropriate debug | ||
11 | message. | ||
12 | File /run/criu.kdat does not exist | ||
13 | |||
14 | Signed-off-by: Radostin Stoyanov <rstoyanov1@gmail.com> | ||
15 | Signed-off-by: Andrei Vagin <avagin@virtuozzo.com> | ||
16 | |||
17 | Upstream-Status: Backport [https://github.com/checkpoint-restore/criu/commit/868de91a099c00f099d8a41557d660d173f72521] | ||
18 | |||
19 | Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com> | ||
20 | --- | ||
21 | criu/kerndat.c | 5 ++++- | ||
22 | 1 file changed, 4 insertions(+), 1 deletion(-) | ||
23 | |||
24 | diff --git a/criu/kerndat.c b/criu/kerndat.c | ||
25 | index 8cb5690..9fb475c 100644 | ||
26 | --- a/criu/kerndat.c | ||
27 | +++ b/criu/kerndat.c | ||
28 | @@ -789,7 +789,10 @@ static int kerndat_try_load_cache(void) | ||
29 | |||
30 | fd = open(KERNDAT_CACHE_FILE, O_RDONLY); | ||
31 | if (fd < 0) { | ||
32 | - pr_warn("Can't load %s\n", KERNDAT_CACHE_FILE); | ||
33 | + if(ENOENT == errno) | ||
34 | + pr_debug("File %s does not exist\n", KERNDAT_CACHE_FILE); | ||
35 | + else | ||
36 | + pr_warn("Can't load %s\n", KERNDAT_CACHE_FILE); | ||
37 | return 1; | ||
38 | } | ||
39 | |||
40 | -- | ||
41 | 2.8.1 | ||
42 | |||