diff options
-rw-r--r-- | recipes-networking/cni/cni_git.bb | 10 | ||||
-rw-r--r-- | recipes-networking/cni/files/modules.txt | 22 | ||||
-rw-r--r-- | recipes-networking/cni/relocation.inc | 6 | ||||
-rw-r--r-- | recipes-networking/cni/src_uri.inc | 68 |
4 files changed, 53 insertions, 53 deletions
diff --git a/recipes-networking/cni/cni_git.bb b/recipes-networking/cni/cni_git.bb index aa9902e3..e8d2b44e 100644 --- a/recipes-networking/cni/cni_git.bb +++ b/recipes-networking/cni/cni_git.bb | |||
@@ -9,9 +9,9 @@ Because of this focus, CNI has a wide range of support and the specification \ | |||
9 | is simple to implement. \ | 9 | is simple to implement. \ |
10 | " | 10 | " |
11 | 11 | ||
12 | SRCREV_cni = "b62753aa2bfa365c1ceaff6f25774a8047c896b5" | 12 | SRCREV_cni = "4c9ae43c0eaa85ec1ab27781e9b258f13e7fd0ca" |
13 | SRCREV_plugins = "b6a0e0bc96906f0d3bd6bfcaab0b5ae72292f46c" | 13 | SRCREV_plugins = "01b3db8e01e491864db3e088a5db401d2f413b00" |
14 | SRCREV_flannel_plugin = "6464faacf5c00e25321573225d74638455ef03a0" | 14 | SRCREV_flannel_plugin = "a3f52e86452cdcdd2d970bb0f89eef248aed0e7c" |
15 | SRCREV_FORMAT = "cni_plugins" | 15 | SRCREV_FORMAT = "cni_plugins" |
16 | SRC_URI = "\ | 16 | SRC_URI = "\ |
17 | git://github.com/containernetworking/cni.git;branch=main;name=cni;protocol=https;destsuffix=${GO_SRCURI_DESTSUFFIX} \ | 17 | git://github.com/containernetworking/cni.git;branch=main;name=cni;protocol=https;destsuffix=${GO_SRCURI_DESTSUFFIX} \ |
@@ -35,8 +35,8 @@ LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464 | |||
35 | GO_IMPORT = "import" | 35 | GO_IMPORT = "import" |
36 | S = "${WORKDIR}/git" | 36 | S = "${WORKDIR}/git" |
37 | 37 | ||
38 | PV = "v1.2.0-rc0+git${SRCREV_cni}" | 38 | PV = "v1.2.3+git${SRCREV_cni}" |
39 | CNI_VERSION = "v1.2.0" | 39 | CNI_VERSION = "v1.2.3" |
40 | 40 | ||
41 | inherit go | 41 | inherit go |
42 | inherit goarch | 42 | inherit goarch |
diff --git a/recipes-networking/cni/files/modules.txt b/recipes-networking/cni/files/modules.txt index 38217c96..dc9f4b91 100644 --- a/recipes-networking/cni/files/modules.txt +++ b/recipes-networking/cni/files/modules.txt | |||
@@ -1,26 +1,26 @@ | |||
1 | # github.com/Masterminds/semver/v3 v3.2.1 | 1 | # github.com/onsi/ginkgo/v2 v2.20.1 |
2 | ## explicit | 2 | ## explicit |
3 | # github.com/onsi/ginkgo/v2 v2.13.2 | 3 | # github.com/onsi/gomega v1.34.1 |
4 | ## explicit | ||
5 | # github.com/onsi/gomega v1.30.0 | ||
6 | ## explicit | 4 | ## explicit |
7 | # github.com/vishvananda/netns v0.0.4 | 5 | # github.com/vishvananda/netns v0.0.4 |
8 | ## explicit | 6 | ## explicit |
9 | # github.com/go-logr/logr v1.3.0 | 7 | # github.com/go-logr/logr v1.4.2 |
10 | ## explicit | 8 | ## explicit |
11 | # github.com/go-task/slim-sprig v0.0.0-20230315185526-52ccab3ef572 | 9 | # github.com/go-task/slim-sprig/v3 v3.0.0 |
12 | ## explicit | 10 | ## explicit |
13 | # github.com/google/go-cmp v0.6.0 | 11 | # github.com/google/go-cmp v0.6.0 |
14 | ## explicit | 12 | ## explicit |
15 | # github.com/google/pprof v0.0.0-20210407192527-94a9f03dee38 | 13 | # github.com/google/pprof v0.0.0-20240727154555-813a5fbdbec8 |
14 | ## explicit | ||
15 | # golang.org/x/exp v0.0.0-20240719175910-8a7402abbf56 | ||
16 | ## explicit | 16 | ## explicit |
17 | # golang.org/x/net v0.17.0 | 17 | # golang.org/x/net v0.28.0 |
18 | ## explicit | 18 | ## explicit |
19 | # golang.org/x/sys v0.14.0 | 19 | # golang.org/x/sys v0.23.0 |
20 | ## explicit | 20 | ## explicit |
21 | # golang.org/x/text v0.13.0 | 21 | # golang.org/x/text v0.17.0 |
22 | ## explicit | 22 | ## explicit |
23 | # golang.org/x/tools v0.14.0 | 23 | # golang.org/x/tools v0.24.0 |
24 | ## explicit | 24 | ## explicit |
25 | # gopkg.in/yaml.v3 v3.0.1 | 25 | # gopkg.in/yaml.v3 v3.0.1 |
26 | ## explicit | 26 | ## explicit |
diff --git a/recipes-networking/cni/relocation.inc b/recipes-networking/cni/relocation.inc index 456e2c8a..c6538dd0 100644 --- a/recipes-networking/cni/relocation.inc +++ b/recipes-networking/cni/relocation.inc | |||
@@ -1,4 +1,5 @@ | |||
1 | export sites="golang.org/x/net:golang.org/x/net:force \ | 1 | export sites="golang.org/x/exp:golang.org/x/exp:force \ |
2 | golang.org/x/net:golang.org/x/net:force \ | ||
2 | golang.org/x/sys:golang.org/x/sys:force \ | 3 | golang.org/x/sys:golang.org/x/sys:force \ |
3 | gopkg.in/yaml.v3:gopkg.in/yaml.v3:force \ | 4 | gopkg.in/yaml.v3:gopkg.in/yaml.v3:force \ |
4 | golang.org/x/text:golang.org/x/text:force \ | 5 | golang.org/x/text:golang.org/x/text:force \ |
@@ -9,8 +10,7 @@ export sites="golang.org/x/net:golang.org/x/net:force \ | |||
9 | github.com/google/go-cmp:github.com/google/go-cmp:force \ | 10 | github.com/google/go-cmp:github.com/google/go-cmp:force \ |
10 | github.com/onsi/ginkgo/v2:github.com/onsi/ginkgo/v2:force \ | 11 | github.com/onsi/ginkgo/v2:github.com/onsi/ginkgo/v2:force \ |
11 | github.com/vishvananda/netns:github.com/vishvananda/netns:force \ | 12 | github.com/vishvananda/netns:github.com/vishvananda/netns:force \ |
12 | github.com/go-task/slim-sprig:github.com/go-task/slim-sprig:force \ | 13 | github.com/go-task/slim-sprig/v3:github.com/go-task/slim-sprig/v3:force" |
13 | github.com/Masterminds/semver/v3:github.com/Masterminds/semver/v3:force" | ||
14 | 14 | ||
15 | do_compile:prepend() { | 15 | do_compile:prepend() { |
16 | cd ${S}/src/import | 16 | cd ${S}/src/import |
diff --git a/recipes-networking/cni/src_uri.inc b/recipes-networking/cni/src_uri.inc index fe90f20f..6659c242 100644 --- a/recipes-networking/cni/src_uri.inc +++ b/recipes-networking/cni/src_uri.inc | |||
@@ -1,41 +1,46 @@ | |||
1 | # golang.org/x/net v0.17.0 | 1 | # golang.org/x/exp v0.0.0-20240719175910-8a7402abbf56 |
2 | # [1] git ls-remote https://go.googlesource.com/net b225e7ca6dde1ef5a5ae5ce922861bda011cfabd | 2 | # [1] git ls-remote https://go.googlesource.com/exp 8a7402abbf56ed11a2540c1d8beb569bd29e22d1 |
3 | SRCREV_net="b225e7ca6dde1ef5a5ae5ce922861bda011cfabd" | 3 | SRCREV_exp="8a7402abbf56ed11a2540c1d8beb569bd29e22d1" |
4 | SRC_URI += "git://go.googlesource.com/exp;name=exp;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/golang.org/x/exp" | ||
5 | |||
6 | # golang.org/x/net v0.28.0 | ||
7 | # [1] git ls-remote https://go.googlesource.com/net 4542a42604cd159f1adb93c58368079ae37b3bf6 | ||
8 | SRCREV_net="4542a42604cd159f1adb93c58368079ae37b3bf6" | ||
4 | SRC_URI += "git://go.googlesource.com/net;name=net;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/golang.org/x/net" | 9 | SRC_URI += "git://go.googlesource.com/net;name=net;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/golang.org/x/net" |
5 | 10 | ||
6 | # golang.org/x/sys v0.14.0 | 11 | # golang.org/x/sys v0.23.0 |
7 | # [1] git ls-remote https://go.googlesource.com/sys cb378ae1ff8cd45e69d4f172df8370bc844e1f86 | 12 | # [1] git ls-remote https://github.com/golang/sys aa1c4c8554e2f3f54247c309e897cd42c9bfc374 |
8 | SRCREV_sys="cb378ae1ff8cd45e69d4f172df8370bc844e1f86" | 13 | SRCREV_sys="aa1c4c8554e2f3f54247c309e897cd42c9bfc374" |
9 | SRC_URI += "git://go.googlesource.com/sys;name=sys;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/golang.org/x/sys" | 14 | SRC_URI += "git://github.com/golang/sys;name=sys;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/golang.org/x/sys" |
10 | 15 | ||
11 | # gopkg.in/yaml.v3 v3.0.1 | 16 | # gopkg.in/yaml.v3 v3.0.1 |
12 | # [1] git ls-remote https://github.com/go-yaml/yaml f6f7691b1fdeb513f56608cd2c32c51f8194bf51 | 17 | # [1] git ls-remote https://github.com/go-yaml/yaml f6f7691b1fdeb513f56608cd2c32c51f8194bf51 |
13 | SRCREV_yaml.v3="f6f7691b1fdeb513f56608cd2c32c51f8194bf51" | 18 | SRCREV_yaml.v3="f6f7691b1fdeb513f56608cd2c32c51f8194bf51" |
14 | SRC_URI += "git://github.com/go-yaml/yaml;name=yaml.v3;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/gopkg.in/yaml.v3" | 19 | SRC_URI += "git://github.com/go-yaml/yaml;name=yaml.v3;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/gopkg.in/yaml.v3" |
15 | 20 | ||
16 | # golang.org/x/text v0.13.0 | 21 | # golang.org/x/text v0.17.0 |
17 | # [1] git ls-remote https://go.googlesource.com/text f488e191e67ed95a5b9b7b39024e5a5f5f1ffd02 | 22 | # [1] git ls-remote https://go.googlesource.com/text b2bec85eb9df7c6fcf50218bde3db5e22b35e481 |
18 | SRCREV_text="f488e191e67ed95a5b9b7b39024e5a5f5f1ffd02" | 23 | SRCREV_text="b2bec85eb9df7c6fcf50218bde3db5e22b35e481" |
19 | SRC_URI += "git://go.googlesource.com/text;name=text;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/golang.org/x/text" | 24 | SRC_URI += "git://go.googlesource.com/text;name=text;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/golang.org/x/text" |
20 | 25 | ||
21 | # golang.org/x/tools v0.14.0 | 26 | # golang.org/x/tools v0.24.0 |
22 | # [1] git ls-remote https://go.googlesource.com/tools 3f4194ee29d7db9b59757dfff729ef55cf89661c | 27 | # [1] git ls-remote https://go.googlesource.com/tools 3057be8f634fdb03e1da1cad9fff3415299ad3ad |
23 | SRCREV_tools="3f4194ee29d7db9b59757dfff729ef55cf89661c" | 28 | SRCREV_tools="3057be8f634fdb03e1da1cad9fff3415299ad3ad" |
24 | SRC_URI += "git://go.googlesource.com/tools;name=tools;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/golang.org/x/tools" | 29 | SRC_URI += "git://go.googlesource.com/tools;name=tools;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/golang.org/x/tools" |
25 | 30 | ||
26 | # github.com/onsi/gomega v1.30.0 | 31 | # github.com/onsi/gomega v1.34.1 |
27 | # [1] git ls-remote https://github.com/onsi/gomega f804ac6ada8d36164ecae0513295de8affce1245 | 32 | # [1] git ls-remote https://github.com/onsi/gomega fa057b845528c9336265d6df77e21d827f268c7d |
28 | SRCREV_gomega="f804ac6ada8d36164ecae0513295de8affce1245" | 33 | SRCREV_gomega="fa057b845528c9336265d6df77e21d827f268c7d" |
29 | SRC_URI += "git://github.com/onsi/gomega;name=gomega;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/github.com/onsi/gomega" | 34 | SRC_URI += "git://github.com/onsi/gomega;name=gomega;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/github.com/onsi/gomega" |
30 | 35 | ||
31 | # github.com/go-logr/logr v1.3.0 | 36 | # github.com/go-logr/logr v1.4.2 |
32 | # [1] git ls-remote https://github.com/go-logr/logr 8adefbede0fe82bdee4fb8c9c9bdc7bc5d91388f | 37 | # [1] git ls-remote https://github.com/go-logr/logr 1205f429d540b8b81c2b75a38943afb738dac223 |
33 | SRCREV_logr="8adefbede0fe82bdee4fb8c9c9bdc7bc5d91388f" | 38 | SRCREV_logr="1205f429d540b8b81c2b75a38943afb738dac223" |
34 | SRC_URI += "git://github.com/go-logr/logr;name=logr;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/github.com/go-logr/logr" | 39 | SRC_URI += "git://github.com/go-logr/logr;name=logr;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/github.com/go-logr/logr" |
35 | 40 | ||
36 | # github.com/google/pprof v0.0.0-20210407192527-94a9f03dee38 | 41 | # github.com/google/pprof v0.0.0-20240727154555-813a5fbdbec8 |
37 | # [1] git ls-remote https://github.com/google/pprof 94a9f03dee38882adc8bdfc42cdd6a04f8e7056e | 42 | # [1] git ls-remote https://github.com/google/pprof 813a5fbdbec8a66f7a5aedb876e1b2c3ee0f99ac |
38 | SRCREV_pprof="94a9f03dee38882adc8bdfc42cdd6a04f8e7056e" | 43 | SRCREV_pprof="813a5fbdbec8a66f7a5aedb876e1b2c3ee0f99ac" |
39 | SRC_URI += "git://github.com/google/pprof;name=pprof;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/github.com/google/pprof" | 44 | SRC_URI += "git://github.com/google/pprof;name=pprof;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/github.com/google/pprof" |
40 | 45 | ||
41 | # github.com/google/go-cmp v0.6.0 | 46 | # github.com/google/go-cmp v0.6.0 |
@@ -43,9 +48,9 @@ SRC_URI += "git://github.com/google/pprof;name=pprof;protocol=https;nobranch=1;d | |||
43 | SRCREV_go-cmp="c3ad8435e7bef96af35732bc0789e5a2278c6d5f" | 48 | SRCREV_go-cmp="c3ad8435e7bef96af35732bc0789e5a2278c6d5f" |
44 | SRC_URI += "git://github.com/google/go-cmp;name=go-cmp;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/github.com/google/go-cmp" | 49 | SRC_URI += "git://github.com/google/go-cmp;name=go-cmp;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/github.com/google/go-cmp" |
45 | 50 | ||
46 | # github.com/onsi/ginkgo/v2 v2.13.2 | 51 | # github.com/onsi/ginkgo/v2 v2.20.1 |
47 | # [1] git ls-remote https://github.com/onsi/ginkgo 931dc0b144749710bd085d4eb7cd4192a22972d7 | 52 | # [1] git ls-remote https://github.com/onsi/ginkgo 4ef0afb9f28f241c352cad6ca9dae8b149e57bc4 |
48 | SRCREV_v2="931dc0b144749710bd085d4eb7cd4192a22972d7" | 53 | SRCREV_v2="4ef0afb9f28f241c352cad6ca9dae8b149e57bc4" |
49 | SRC_URI += "git://github.com/onsi/ginkgo;name=v2;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/github.com/onsi/ginkgo/v2" | 54 | SRC_URI += "git://github.com/onsi/ginkgo;name=v2;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/github.com/onsi/ginkgo/v2" |
50 | 55 | ||
51 | # github.com/vishvananda/netns v0.0.4 | 56 | # github.com/vishvananda/netns v0.0.4 |
@@ -53,13 +58,8 @@ SRC_URI += "git://github.com/onsi/ginkgo;name=v2;protocol=https;nobranch=1;dests | |||
53 | SRCREV_netns="7a452d2d15292b2bfb2a2d88e6bdeac156a761b9" | 58 | SRCREV_netns="7a452d2d15292b2bfb2a2d88e6bdeac156a761b9" |
54 | SRC_URI += "git://github.com/vishvananda/netns;name=netns;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/github.com/vishvananda/netns" | 59 | SRC_URI += "git://github.com/vishvananda/netns;name=netns;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/github.com/vishvananda/netns" |
55 | 60 | ||
56 | # github.com/go-task/slim-sprig v0.0.0-20230315185526-52ccab3ef572 | 61 | # github.com/go-task/slim-sprig/v3 v3.0.0 |
57 | # [1] git ls-remote https://github.com/go-task/slim-sprig 52ccab3ef572c7e1a2c258be183f9a9296d60152 | 62 | # [1] git ls-remote https://github.com/go-task/slim-sprig b05cce61fffa5c6dea6ac8b9a1f12b6e3fb7c894 |
58 | SRCREV_slim-sprig="52ccab3ef572c7e1a2c258be183f9a9296d60152" | 63 | SRCREV_v3="b05cce61fffa5c6dea6ac8b9a1f12b6e3fb7c894" |
59 | SRC_URI += "git://github.com/go-task/slim-sprig;name=slim-sprig;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/github.com/go-task/slim-sprig" | 64 | SRC_URI += "git://github.com/go-task/slim-sprig;name=v3;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/github.com/go-task/slim-sprig/v3" |
60 | |||
61 | # github.com/Masterminds/semver/v3 v3.2.1 | ||
62 | # [1] git ls-remote https://github.com/Masterminds/semver e06051f8fcc4c8b4a4990c337b9862a2448722e5 | ||
63 | SRCREV_v3="e06051f8fcc4c8b4a4990c337b9862a2448722e5" | ||
64 | SRC_URI += "git://github.com/Masterminds/semver;name=v3;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor.fetch/github.com/Masterminds/semver/v3" | ||
65 | 65 | ||