summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/images/xen-guest-image-minimal.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-extended/images/xen-guest-image-minimal.bb b/recipes-extended/images/xen-guest-image-minimal.bb
new file mode 100644
index 00000000..bcac4d79
--- /dev/null
+++ b/recipes-extended/images/xen-guest-image-minimal.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "A Xen guest image."
2
3inherit core-image
4
5IMAGE_INSTALL += " \
6 packagegroup-core-boot \
7 kernel-module-xen-acpi-processor \
8 "
9
10IMAGE_INSTALL += "${@base_contains('DISTRO_FEATURES', 'x11', ' xf86-video-fbdev', '', d)}"
11IMAGE_INSTALL += "${@base_contains('DISTRO_FEATURES', 'x11', ' xf86-video-vesa', '', d)}"
12
13LICENSE = "MIT"
14
15# Send console messages to xen console
16APPEND += "console=hvc0"