summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/virt-manager/virt-manager/0001-build-drop-man-directory.patch31
-rw-r--r--recipes-extended/virt-manager/virt-manager/0001-setup.py-move-global-args-to-install-args.patch78
-rw-r--r--recipes-extended/virt-manager/virt-manager_git.bb (renamed from recipes-extended/virt-manager/virt-manager_4.1.0.bb)17
3 files changed, 45 insertions, 81 deletions
diff --git a/recipes-extended/virt-manager/virt-manager/0001-build-drop-man-directory.patch b/recipes-extended/virt-manager/virt-manager/0001-build-drop-man-directory.patch
new file mode 100644
index 00000000..043428b9
--- /dev/null
+++ b/recipes-extended/virt-manager/virt-manager/0001-build-drop-man-directory.patch
@@ -0,0 +1,31 @@
1From f86dfffa8d443ec640b1c76d2eeccd6a4913305d Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Fri, 17 Jan 2025 15:32:51 +0000
4Subject: [PATCH] build: drop man directory
5
6The man pages require rst2man, which isn't available (or at least
7not trivial to provide), so we drop the man directory to avoid
8building the pages.
9
10Upstream-Status: Inappropriate [oe specific]
11
12Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
13---
14 meson.build | 1 -
15 1 file changed, 1 deletion(-)
16
17diff --git a/meson.build b/meson.build
18index 8862ada8f..22a14d53f 100644
19--- a/meson.build
20+++ b/meson.build
21@@ -15,7 +15,6 @@ pkgdir = datadir / 'virt-manager'
22 git = run_command('test', '-e', '.git', check: false).returncode() == 0
23
24 subdir('scripts')
25-subdir('man')
26 subdir('data')
27 subdir('ui')
28 subdir('virtinst')
29--
302.39.2
31
diff --git a/recipes-extended/virt-manager/virt-manager/0001-setup.py-move-global-args-to-install-args.patch b/recipes-extended/virt-manager/virt-manager/0001-setup.py-move-global-args-to-install-args.patch
deleted file mode 100644
index f0bbf73b..00000000
--- a/recipes-extended/virt-manager/virt-manager/0001-setup.py-move-global-args-to-install-args.patch
+++ /dev/null
@@ -1,78 +0,0 @@
1From bcdb3555b924573e85039b54d63d6173ad99b846 Mon Sep 17 00:00:00 2001
2From: Paul Le Guen de Kerneizon <paul.leguendekerneizon@savoirfairelinux.com>
3Date: Wed, 28 Feb 2024 10:24:00 +0100
4Subject: [PATCH] setup.py: move global args to install args
5
6Presently, during the installation process, global arguments such as
7`no-update-icon-cache` and `no-compile-schemas` are utilized to
8prevent the installation of specific graphical components. These
9arguments are essential, for instance, when installing virt-manager
10without any GUI dependencies on the target system. However, these
11global arguments must be set before the install command, yet they only
12take effect during the execution of the command.
13
14Since the Yocto `setuptools3_legacy` class parses arguments after the
15command, this commit aims to make these arguments applicable locally to
16the install command.
17
18Upstream-Status: Inappropriate [oe specific]
19
20Signed-off-by: Paul Le Guen de Kerneizon <paul.leguendekerneizon@savoirfairelinux.com>
21---
22 setup.py | 20 ++++++++++++--------
23 1 file changed, 12 insertions(+), 8 deletions(-)
24
25diff --git a/setup.py b/setup.py
26index cd6cd83e..faca546a 100755
27--- a/setup.py
28+++ b/setup.py
29@@ -242,6 +242,16 @@ class my_egg_info(setuptools.command.install_egg_info.install_egg_info):
30
31
32 class my_install(setuptools.command.install.install):
33+ setuptools.command.install.install.user_options += [
34+ ("no-update-icon-cache", None, "Don't run gtk-update-icon-cache"),
35+ ("no-compile-schemas", None, "Don't compile gsettings schemas"),
36+ ]
37+
38+ def initialize_options(self):
39+ setuptools.command.install.install.initialize_options(self)
40+ self.no_update_icon_cache = None
41+ self.no_compile_schemas = None
42+
43 """
44 Error if we weren't 'configure'd with the correct install prefix
45 """
46@@ -266,12 +276,12 @@ class my_install(setuptools.command.install.install):
47 def run(self):
48 setuptools.command.install.install.run(self)
49
50- if not self.distribution.no_update_icon_cache:
51+ if not self.no_update_icon_cache:
52 print("running gtk-update-icon-cache")
53 icon_path = os.path.join(self.install_data, "share/icons/hicolor")
54 self.spawn(["gtk-update-icon-cache", "-q", "-t", icon_path])
55
56- if not self.distribution.no_compile_schemas:
57+ if not self.no_compile_schemas:
58 print("compiling gsettings schemas")
59 gschema_install = os.path.join(self.install_data,
60 "share/glib-2.0/schemas")
61@@ -421,14 +431,8 @@ class CheckPylint(setuptools.Command):
62
63
64 class VMMDistribution(setuptools.dist.Distribution):
65- global_options = setuptools.dist.Distribution.global_options + [
66- ("no-update-icon-cache", None, "Don't run gtk-update-icon-cache"),
67- ("no-compile-schemas", None, "Don't compile gsettings schemas"),
68- ]
69
70 def __init__(self, *args, **kwargs):
71- self.no_update_icon_cache = False
72- self.no_compile_schemas = False
73 setuptools.dist.Distribution.__init__(self, *args, **kwargs)
74
75
76--
772.34.1
78
diff --git a/recipes-extended/virt-manager/virt-manager_4.1.0.bb b/recipes-extended/virt-manager/virt-manager_git.bb
index d752fd2b..71806077 100644
--- a/recipes-extended/virt-manager/virt-manager_4.1.0.bb
+++ b/recipes-extended/virt-manager/virt-manager_git.bb
@@ -3,26 +3,34 @@ HOMEPAGE = "https://virt-manager.org/"
3LICENSE = "GPL-2.0-only" 3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5DEPENDS += "python3-docutils-native" 5DEPENDS += "python3-docutils-native"
6SRCREV = "6710ca6969b7d9c4e8344acd0fe3d50b24adc8ec" 6SRCREV = "da2f65f9262fc18e2b05f527cf8886b1c6b9cde1"
7 7
8SRC_URI = " \ 8SRC_URI = " \
9 git://github.com/virt-manager/virt-manager;branch=main;protocol=https \ 9 git://github.com/virt-manager/virt-manager;branch=main;protocol=https \
10 file://0001-setup.py-move-global-args-to-install-args.patch \ 10 file://0001-build-drop-man-directory.patch \
11" 11"
12 12
13PV = "v5.0.0+git"
14
13S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
14 16
15PACKAGECONFIG ??= "gui" 17PACKAGECONFIG ??= "gui"
16PACKAGECONFIG[gui] = ",--no-update-icon-cache --no-compile-schemas,python3-pygobject" 18PACKAGECONFIG[gui] = ",--no-update-icon-cache --no-compile-schemas,python3-pygobject"
17 19
18inherit ${@bb.utils.contains('PACKAGECONFIG', 'gui', 'gtk-icon-cache', '', d)} 20inherit ${@bb.utils.contains('PACKAGECONFIG', 'gui', 'gtk-icon-cache', '', d)}
19inherit bash-completion gettext pkgconfig setuptools3_legacy 21inherit bash-completion gettext pkgconfig meson
22
23EXTRA_OEMESON += "-Dupdate-icon-cache=false \
24 -Dtests=disabled \
25 "
20 26
21PACKAGES += " \ 27PACKAGES += " \
22 ${PN}-common \ 28 ${PN}-common \
23 ${PN}-install \ 29 ${PN}-install \
24" 30"
25 31
32DEPENDS = "python3-pylint"
33
26RDEPENDS:${PN}-common += " \ 34RDEPENDS:${PN}-common += " \
27 libvirt-python \ 35 libvirt-python \
28 libosinfo \ 36 libosinfo \
@@ -32,6 +40,9 @@ RDEPENDS:${PN} = " \
32 ${PN}-common \ 40 ${PN}-common \
33 libvirt-glib \ 41 libvirt-glib \
34 libxml2-python \ 42 libxml2-python \
43 gdk-pixbuf \
44 gtk+3 \
45 hicolor-icon-theme \
35 python3-pygobject \ 46 python3-pygobject \
36 python3-requests \ 47 python3-requests \
37" 48"