summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/libvirt/libvirt_6.3.0.bb19
1 files changed, 10 insertions, 9 deletions
diff --git a/recipes-extended/libvirt/libvirt_6.3.0.bb b/recipes-extended/libvirt/libvirt_6.3.0.bb
index 08e2961c..eeb1bf8a 100644
--- a/recipes-extended/libvirt/libvirt_6.3.0.bb
+++ b/recipes-extended/libvirt/libvirt_6.3.0.bb
@@ -283,23 +283,23 @@ do_install_append() {
283 283
284 # We can't use 'notify' when we don't support 'sd_notify' dbus capabilities. 284 # We can't use 'notify' when we don't support 'sd_notify' dbus capabilities.
285 sed -i -e 's/Type=notify/Type=forking/' \ 285 sed -i -e 's/Type=notify/Type=forking/' \
286 -e '/Type=forking/a PIDFile=${localstatedir}/run/libvirtd.pid' \ 286 -e '/Type=forking/a PIDFile=/run/libvirtd.pid' \
287 ${D}/${systemd_unitdir}/system/libvirtd.service 287 ${D}/${systemd_unitdir}/system/libvirtd.service
288 fi 288 fi
289 289
290 # The /var/run/libvirt directories created by the Makefile 290 # The /run/libvirt directories created by the Makefile are
291 # are wiped out in volatile, we need to create these at boot. 291 # wiped out in volatile, we need to create these at boot.
292 rm -rf ${D}${localstatedir}/run 292 rm -rf ${D}/run
293 install -d ${D}${sysconfdir}/default/volatiles 293 install -d ${D}${sysconfdir}/default/volatiles
294 echo "d root root 0755 ${localstatedir}/run/libvirt none" \ 294 echo "d root root 0755 /run/libvirt none" \
295 > ${D}${sysconfdir}/default/volatiles/99_libvirt 295 > ${D}${sysconfdir}/default/volatiles/99_libvirt
296 echo "d root root 0755 ${localstatedir}/run/libvirt/lockd none" \ 296 echo "d root root 0755 /run/libvirt/lockd none" \
297 >> ${D}${sysconfdir}/default/volatiles/99_libvirt 297 >> ${D}${sysconfdir}/default/volatiles/99_libvirt
298 echo "d root root 0755 ${localstatedir}/run/libvirt/lxc none" \ 298 echo "d root root 0755 /run/libvirt/lxc none" \
299 >> ${D}${sysconfdir}/default/volatiles/99_libvirt 299 >> ${D}${sysconfdir}/default/volatiles/99_libvirt
300 echo "d root root 0755 ${localstatedir}/run/libvirt/network none" \ 300 echo "d root root 0755 /run/libvirt/network none" \
301 >> ${D}${sysconfdir}/default/volatiles/99_libvirt 301 >> ${D}${sysconfdir}/default/volatiles/99_libvirt
302 echo "d root root 0755 ${localstatedir}/run/libvirt/qemu none" \ 302 echo "d root root 0755 /run/libvirt/qemu none" \
303 >> ${D}${sysconfdir}/default/volatiles/99_libvirt 303 >> ${D}${sysconfdir}/default/volatiles/99_libvirt
304 304
305 # Manually set permissions and ownership to match polkit recipe 305 # Manually set permissions and ownership to match polkit recipe
@@ -379,6 +379,7 @@ do_install_append() {
379EXTRA_OECONF += " \ 379EXTRA_OECONF += " \
380 --with-init-script=systemd \ 380 --with-init-script=systemd \
381 --with-test-suite \ 381 --with-test-suite \
382 --with-runstatedir=/run \
382 " 383 "
383 384
384# gcc9 end up mis-compiling qemuxml2argvtest.o with Og which then 385# gcc9 end up mis-compiling qemuxml2argvtest.o with Og which then