diff options
-rw-r--r-- | recipes-devtools/protobuf/protobuf-native_3.0.0.bb (renamed from recipes-devtools/protobuf/protobuf-native_2.5.0.bb) | 11 | ||||
-rw-r--r-- | recipes-devtools/protobuf/protobuf_3.0.0.bb (renamed from recipes-devtools/protobuf/protobuf_2.5.0.bb) | 22 |
2 files changed, 18 insertions, 15 deletions
diff --git a/recipes-devtools/protobuf/protobuf-native_2.5.0.bb b/recipes-devtools/protobuf/protobuf-native_3.0.0.bb index 47acdae3..33467b36 100644 --- a/recipes-devtools/protobuf/protobuf-native_2.5.0.bb +++ b/recipes-devtools/protobuf/protobuf-native_3.0.0.bb | |||
@@ -6,15 +6,16 @@ HOMEPAGE = "http://code.google.com/p/protobuf/" | |||
6 | SECTION = "console/tools" | 6 | SECTION = "console/tools" |
7 | LICENSE = "BSD-3-Clause" | 7 | LICENSE = "BSD-3-Clause" |
8 | 8 | ||
9 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=af6809583bfde9a31595a58bb4a24514" | 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=35953c752efc9299b184f91bef540095" |
10 | 10 | ||
11 | PR = "r1" | 11 | PR = "r0" |
12 | 12 | ||
13 | SRC_URI[md5sum] = "9c21577a03adc1879aba5b52d06e25cf" | 13 | SRC_URI[md5sum] = "d4f6ca65aadc6310b3872ee421e79fa6" |
14 | SRC_URI[sha256sum] = "c2665a7aa2ac1a206e61b28e014486e3de59009ea2be2bde9182e0847f38b62f" | 14 | SRC_URI[sha256sum] = "f5b3563f118f1d3d6e001705fa7082e8fc3bda50038ac3dff787650795734146" |
15 | SRC_URI = "https://github.com/google/protobuf/archive/v${PV}.tar.gz \ | 15 | SRC_URI = "https://github.com/google/protobuf/archive/v3.0.0.tar.gz;downloadfilename=protobuf-3.0.0.tar.gz \ |
16 | " | 16 | " |
17 | 17 | ||
18 | EXTRA_OECONF += " --with-protoc=echo --disable-shared" | 18 | EXTRA_OECONF += " --with-protoc=echo --disable-shared" |
19 | 19 | ||
20 | inherit native autotools | 20 | inherit native autotools |
21 | |||
diff --git a/recipes-devtools/protobuf/protobuf_2.5.0.bb b/recipes-devtools/protobuf/protobuf_3.0.0.bb index b503a352..e1deeac8 100644 --- a/recipes-devtools/protobuf/protobuf_2.5.0.bb +++ b/recipes-devtools/protobuf/protobuf_3.0.0.bb | |||
@@ -6,26 +6,28 @@ HOMEPAGE = "http://code.google.com/p/protobuf/" | |||
6 | SECTION = "console/tools" | 6 | SECTION = "console/tools" |
7 | LICENSE = "BSD-3-Clause" | 7 | LICENSE = "BSD-3-Clause" |
8 | 8 | ||
9 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=af6809583bfde9a31595a58bb4a24514" | 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=35953c752efc9299b184f91bef540095" |
10 | 10 | ||
11 | PR = "r1" | 11 | PR = "r0" |
12 | EXCLUDE_FROM_WORLD = "1" | 12 | EXCLUDE_FROM_WORLD = "1" |
13 | 13 | ||
14 | SRC_URI[md5sum] = "9c21577a03adc1879aba5b52d06e25cf" | 14 | SRC_URI[md5sum] = "d4f6ca65aadc6310b3872ee421e79fa6" |
15 | SRC_URI[sha256sum] = "c2665a7aa2ac1a206e61b28e014486e3de59009ea2be2bde9182e0847f38b62f" | 15 | SRC_URI[sha256sum] = "f5b3563f118f1d3d6e001705fa7082e8fc3bda50038ac3dff787650795734146" |
16 | SRC_URI = "https://github.com/google/protobuf/archive/v${PV}.tar.gz \ | 16 | SRC_URI = "https://github.com/google/protobuf/archive/v3.0.0.tar.gz;downloadfilename=protobuf-3.0.0.tar.gz\ |
17 | file://protobuf-allow-running-python-scripts-from-anywhere.patch \ | 17 | file://protobuf-allow-running-python-scripts-from-anywhere.patch \ |
18 | file://run-ptest" | 18 | file://run-ptest \ |
19 | " | ||
20 | |||
21 | COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux" | ||
19 | 22 | ||
20 | EXTRA_OECONF += " --with-protoc=${STAGING_BINDIR_NATIVE}/protoc" | 23 | EXTRA_OECONF += " --with-protoc=${STAGING_BINDIR_NATIVE}/protoc" |
21 | inherit autotools setuptools ptest | 24 | inherit autotools setuptools ptest |
22 | 25 | ||
23 | DEPENDS += "protobuf-native" | 26 | DEPENDS += "protobuf-native" |
24 | RDEPENDS_${PN}-ptest = "bash python" | ||
25 | 27 | ||
26 | PYTHON_SRC_DIR="python" | 28 | PYTHON_SRC_DIR="python" |
27 | TEST_SRC_DIR="examples" | 29 | TEST_SRC_DIR="examples" |
28 | LANG_SUPPORT="python" | 30 | LANG_SUPPORT="cpp python" |
29 | 31 | ||
30 | do_compile() { | 32 | do_compile() { |
31 | # Compile protoc compiler | 33 | # Compile protoc compiler |
@@ -87,7 +89,7 @@ do_install_ptest() { | |||
87 | fi | 89 | fi |
88 | done | 90 | done |
89 | cp "${S}/${TEST_SRC_DIR}/addressbook_pb2.py" "${D}/${PTEST_PATH}" | 91 | cp "${S}/${TEST_SRC_DIR}/addressbook_pb2.py" "${D}/${PTEST_PATH}" |
90 | 92 | ||
91 | cd "$olddir" | 93 | cd "$olddir" |
92 | } | 94 | } |
93 | 95 | ||