summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/protobuf/protobuf-native_3.0.0.bb (renamed from recipes-devtools/protobuf/protobuf-native_2.5.0.bb)11
-rw-r--r--recipes-devtools/protobuf/protobuf_3.0.0.bb (renamed from recipes-devtools/protobuf/protobuf_2.5.0.bb)22
2 files changed, 18 insertions, 15 deletions
diff --git a/recipes-devtools/protobuf/protobuf-native_2.5.0.bb b/recipes-devtools/protobuf/protobuf-native_3.0.0.bb
index 47acdae3..33467b36 100644
--- a/recipes-devtools/protobuf/protobuf-native_2.5.0.bb
+++ b/recipes-devtools/protobuf/protobuf-native_3.0.0.bb
@@ -6,15 +6,16 @@ HOMEPAGE = "http://code.google.com/p/protobuf/"
6SECTION = "console/tools" 6SECTION = "console/tools"
7LICENSE = "BSD-3-Clause" 7LICENSE = "BSD-3-Clause"
8 8
9LIC_FILES_CHKSUM = "file://COPYING.txt;md5=af6809583bfde9a31595a58bb4a24514" 9LIC_FILES_CHKSUM = "file://LICENSE;md5=35953c752efc9299b184f91bef540095"
10 10
11PR = "r1" 11PR = "r0"
12 12
13SRC_URI[md5sum] = "9c21577a03adc1879aba5b52d06e25cf" 13SRC_URI[md5sum] = "d4f6ca65aadc6310b3872ee421e79fa6"
14SRC_URI[sha256sum] = "c2665a7aa2ac1a206e61b28e014486e3de59009ea2be2bde9182e0847f38b62f" 14SRC_URI[sha256sum] = "f5b3563f118f1d3d6e001705fa7082e8fc3bda50038ac3dff787650795734146"
15SRC_URI = "https://github.com/google/protobuf/archive/v${PV}.tar.gz \ 15SRC_URI = "https://github.com/google/protobuf/archive/v3.0.0.tar.gz;downloadfilename=protobuf-3.0.0.tar.gz \
16 " 16 "
17 17
18EXTRA_OECONF += " --with-protoc=echo --disable-shared" 18EXTRA_OECONF += " --with-protoc=echo --disable-shared"
19 19
20inherit native autotools 20inherit native autotools
21
diff --git a/recipes-devtools/protobuf/protobuf_2.5.0.bb b/recipes-devtools/protobuf/protobuf_3.0.0.bb
index b503a352..e1deeac8 100644
--- a/recipes-devtools/protobuf/protobuf_2.5.0.bb
+++ b/recipes-devtools/protobuf/protobuf_3.0.0.bb
@@ -6,26 +6,28 @@ HOMEPAGE = "http://code.google.com/p/protobuf/"
6SECTION = "console/tools" 6SECTION = "console/tools"
7LICENSE = "BSD-3-Clause" 7LICENSE = "BSD-3-Clause"
8 8
9LIC_FILES_CHKSUM = "file://COPYING.txt;md5=af6809583bfde9a31595a58bb4a24514" 9LIC_FILES_CHKSUM = "file://LICENSE;md5=35953c752efc9299b184f91bef540095"
10 10
11PR = "r1" 11PR = "r0"
12EXCLUDE_FROM_WORLD = "1" 12EXCLUDE_FROM_WORLD = "1"
13 13
14SRC_URI[md5sum] = "9c21577a03adc1879aba5b52d06e25cf" 14SRC_URI[md5sum] = "d4f6ca65aadc6310b3872ee421e79fa6"
15SRC_URI[sha256sum] = "c2665a7aa2ac1a206e61b28e014486e3de59009ea2be2bde9182e0847f38b62f" 15SRC_URI[sha256sum] = "f5b3563f118f1d3d6e001705fa7082e8fc3bda50038ac3dff787650795734146"
16SRC_URI = "https://github.com/google/protobuf/archive/v${PV}.tar.gz \ 16SRC_URI = "https://github.com/google/protobuf/archive/v3.0.0.tar.gz;downloadfilename=protobuf-3.0.0.tar.gz\
17 file://protobuf-allow-running-python-scripts-from-anywhere.patch \ 17 file://protobuf-allow-running-python-scripts-from-anywhere.patch \
18 file://run-ptest" 18 file://run-ptest \
19 "
20
21COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux"
19 22
20EXTRA_OECONF += " --with-protoc=${STAGING_BINDIR_NATIVE}/protoc" 23EXTRA_OECONF += " --with-protoc=${STAGING_BINDIR_NATIVE}/protoc"
21inherit autotools setuptools ptest 24inherit autotools setuptools ptest
22 25
23DEPENDS += "protobuf-native" 26DEPENDS += "protobuf-native"
24RDEPENDS_${PN}-ptest = "bash python"
25 27
26PYTHON_SRC_DIR="python" 28PYTHON_SRC_DIR="python"
27TEST_SRC_DIR="examples" 29TEST_SRC_DIR="examples"
28LANG_SUPPORT="python" 30LANG_SUPPORT="cpp python"
29 31
30do_compile() { 32do_compile() {
31 # Compile protoc compiler 33 # Compile protoc compiler
@@ -87,7 +89,7 @@ do_install_ptest() {
87 fi 89 fi
88 done 90 done
89 cp "${S}/${TEST_SRC_DIR}/addressbook_pb2.py" "${D}/${PTEST_PATH}" 91 cp "${S}/${TEST_SRC_DIR}/addressbook_pb2.py" "${D}/${PTEST_PATH}"
90 92
91 cd "$olddir" 93 cd "$olddir"
92} 94}
93 95