summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-networking/netcat/openbsd-netcat_1.6.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-networking/netcat/openbsd-netcat_1.6.bb b/recipes-networking/netcat/openbsd-netcat_1.6.bb
new file mode 100644
index 00000000..1ae3f371
--- /dev/null
+++ b/recipes-networking/netcat/openbsd-netcat_1.6.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "OpenBSD Netcat"
2HOMEPAGE = "http://code.google.com/p/openbsd-netcat/"
3SECTION = "console/network"
4LICENSE = "BSD-3-Clause"
5PR = "r0"
6
7SRCREV = "5"
8
9SRC_URI = "svn://openbsd-netcat.googlecode.com/svn;module=trunk;protocol=http"
10S = "${WORKDIR}/trunk"
11
12inherit update-alternatives gettext
13
14do_configure[noexec] = "1"
15
16do_compile() {
17 cd ${S}
18 oe_runmake
19}
20
21do_install() {
22 install -d ${D}${bindir}
23 install -m 755 ${S}/nc ${D}${bindir}/nc.${BPN}
24}
25
26ALTERNATIVE_${PN} = "nc"
27ALTERNATIVE_PRIORITY = "101"
28
29BBCLASSEXTEND = "nativesdk"