diff options
-rw-r--r-- | recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch | 12 | ||||
-rw-r--r-- | recipes-containers/runc/runc-opencontainers_git.bb | 2 |
2 files changed, 7 insertions, 7 deletions
diff --git a/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch b/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch index 527f3c26..163501ae 100644 --- a/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch +++ b/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch | |||
@@ -13,16 +13,16 @@ Index: git/src/import/Makefile | |||
13 | =================================================================== | 13 | =================================================================== |
14 | --- git.orig/src/import/Makefile | 14 | --- git.orig/src/import/Makefile |
15 | +++ git/src/import/Makefile | 15 | +++ git/src/import/Makefile |
16 | @@ -23,7 +23,7 @@ | 16 | @@ -21,7 +21,7 @@ |
17 | GO_BUILDMODE := "-buildmode=pie" | 17 | endif |
18 | endif | 18 | endif |
19 | endif | 19 | endif |
20 | -GO_BUILD := $(GO) build -trimpath $(MOD_VENDOR) $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ | 20 | -GO_BUILD := $(GO) build -trimpath $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ |
21 | +GO_BUILD := $(GO) build -trimpath $(GOBUILDFLAGS) $(MOD_VENDOR) $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ | 21 | +GO_BUILD := $(GO) build $(GOBUILDFLAGS) -trimpath $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ |
22 | -ldflags "-X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" | 22 | -ldflags "-X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" |
23 | GO_BUILD_STATIC := CGO_ENABLED=1 $(GO) build -trimpath $(MOD_VENDOR) $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo" \ | 23 | GO_BUILD_STATIC := CGO_ENABLED=1 $(GO) build -trimpath $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo" \ |
24 | -ldflags "-w -extldflags -static -X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" | 24 | -ldflags "-w -extldflags -static -X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" |
25 | @@ -40,7 +40,6 @@ | 25 | @@ -38,7 +38,6 @@ |
26 | 26 | ||
27 | static: | 27 | static: |
28 | $(GO_BUILD_STATIC) -o runc . | 28 | $(GO_BUILD_STATIC) -o runc . |
diff --git a/recipes-containers/runc/runc-opencontainers_git.bb b/recipes-containers/runc/runc-opencontainers_git.bb index 14780184..81488872 100644 --- a/recipes-containers/runc/runc-opencontainers_git.bb +++ b/recipes-containers/runc/runc-opencontainers_git.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | include runc.inc | 1 | include runc.inc |
2 | 2 | ||
3 | SRCREV = "b4cb54c2ea78b90f9d8284316aeaeff876f61dfc" | 3 | SRCREV = "249bca0a1316129dcd5bd38b5d75572274181cb5" |
4 | SRC_URI = " \ | 4 | SRC_URI = " \ |
5 | git://github.com/opencontainers/runc;branch=master \ | 5 | git://github.com/opencontainers/runc;branch=master \ |
6 | file://0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch \ | 6 | file://0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch \ |