summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen-4.14.patch66
-rw-r--r--recipes-extended/xen/files/0001-xen-build-temporarily-inhibit-Werror-4.14.patch26
-rw-r--r--recipes-extended/xen/xen-tools_4.14.bb21
-rw-r--r--recipes-extended/xen/xen_4.14.bb20
4 files changed, 133 insertions, 0 deletions
diff --git a/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen-4.14.patch b/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen-4.14.patch
new file mode 100644
index 00000000..f0688fd9
--- /dev/null
+++ b/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen-4.14.patch
@@ -0,0 +1,66 @@
1From d79dcc2002008c58683de82f06c168d6eea57991 Mon Sep 17 00:00:00 2001
2From: Maciej Pijanowski <maciej.pijanowski@3mdeb.com>
3Date: Fri, 19 Oct 2018 11:01:37 +0200
4Subject: [PATCH] python,pygrub: pass DISTUTILS env vars as setup.py args
5
6Allow to respect the target install dir (PYTHON_SITEPACKAGES_DIR)
7as well as other parameters set by the OpenEmbedded build system.
8This is especially useful when the target libdir is not the default one
9(/usr/lib), but for example /usr/lib64.
10
11Signed-off-by: Maciej Pijanowski <maciej.pijanowski@3mdeb.com>
12
13Forward-ported to Xen 4.12.0
14Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com>
15
16Modified to support pygrub installation with python 3
17Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com>
18
19Forward-ported to Xen 4.14.0
20Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com>
21diff --git a/tools/pygrub/Makefile b/tools/pygrub/Makefile
22index 3063c49..513314b 100644
23--- a/tools/pygrub/Makefile
24+++ b/tools/pygrub/Makefile
25@@ -10,14 +10,17 @@ INSTALL_LOG = build/installed_files.txt
26 all: build
27 .PHONY: build
28 build:
29- CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) setup.py build
30+ CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) setup.py build $(DISTUTILS_BUILD_ARGS)
31
32 .PHONY: install
33 install: all
34 $(INSTALL_DIR) $(DESTDIR)/$(bindir)
35 CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) \
36 setup.py install --record $(INSTALL_LOG) $(PYTHON_PREFIX_ARG) \
37- --root="$(DESTDIR)" --install-scripts=$(LIBEXEC_BIN) --force
38+ --root="$(DESTDIR)" --install-scripts=$(LIBEXEC_BIN) --force \
39+ $(DISTUTILS_INSTALL_ARGS)
40+ rm -f $(DESTDIR)/$(LIBEXEC_BIN)/pygrub
41+ $(INSTALL_PYTHON_PROG) src/pygrub $(DESTDIR)/$(LIBEXEC_BIN)/pygrub
42 set -e; if [ $(bindir) != $(LIBEXEC_BIN) -a \
43 "`readlink -f $(DESTDIR)/$(bindir)`" != \
44 "`readlink -f $(LIBEXEC_BIN)`" ]; then \
45diff --git a/tools/python/Makefile b/tools/python/Makefile
46index 541858e..4d4a344 100644
47--- a/tools/python/Makefile
48+++ b/tools/python/Makefile
49@@ -10,7 +10,7 @@ INSTALL_LOG = build/installed_files.txt
50
51 .PHONY: build
52 build:
53- CC="$(CC)" CFLAGS="$(PY_CFLAGS)" $(PYTHON) setup.py build
54+ CC="$(CC)" CFLAGS="$(PY_CFLAGS)" $(PYTHON) setup.py build $(DISTUTILS_BUILD_ARGS)
55
56 .PHONY: install
57 install:
58@@ -18,7 +18,7 @@ install:
59
60 CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) \
61 setup.py install --record $(INSTALL_LOG) $(PYTHON_PREFIX_ARG) \
62- --root="$(DESTDIR)" --force
63+ --root="$(DESTDIR)" --force $(DISTUTILS_INSTALL_ARGS)
64
65 $(INSTALL_PYTHON_PROG) scripts/convert-legacy-stream $(DESTDIR)$(LIBEXEC_BIN)
66 $(INSTALL_PYTHON_PROG) scripts/verify-stream-v2 $(DESTDIR)$(LIBEXEC_BIN)
diff --git a/recipes-extended/xen/files/0001-xen-build-temporarily-inhibit-Werror-4.14.patch b/recipes-extended/xen/files/0001-xen-build-temporarily-inhibit-Werror-4.14.patch
new file mode 100644
index 00000000..0e0a3dc4
--- /dev/null
+++ b/recipes-extended/xen/files/0001-xen-build-temporarily-inhibit-Werror-4.14.patch
@@ -0,0 +1,26 @@
1From 9cff3bf8425ccc593825fcde8ca5eaa32a43d04d Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Thu, 18 Jun 2020 09:05:22 -0400
4Subject: [PATCH] xen/build: temporarily inhibit Werror
5
6Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
7Rebased on Xen 4.14:
8Signed-off-by: Christopher Clark <christopher.w.clark@gmail.com>
9---
10 tools/libxl/Makefile | 2 +-
11 xen/Rules.mk | 2 +-
12 2 files changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/tools/libxl/Makefile b/tools/libxl/Makefile
15index 6da342ed61..c67560e269 100644
16--- a/tools/libxl/Makefile
17+++ b/tools/libxl/Makefile
18@@ -11,7 +11,7 @@ MINOR = 0
19 XLUMAJOR = 4.14
20 XLUMINOR = 0
21
22-CFLAGS += -Werror -Wno-format-zero-length -Wmissing-declarations \
23+CFLAGS += -Wno-format-zero-length -Wmissing-declarations \
24 -Wno-declaration-after-statement -Wformat-nonliteral
25 CFLAGS += -I. -fPIC
26
diff --git a/recipes-extended/xen/xen-tools_4.14.bb b/recipes-extended/xen/xen-tools_4.14.bb
new file mode 100644
index 00000000..ef40c850
--- /dev/null
+++ b/recipes-extended/xen/xen-tools_4.14.bb
@@ -0,0 +1,21 @@
1SRCREV ?= "02d69864b51a4302a148c28d6d391238a6778b4b"
2
3XEN_REL ?= "4.14"
4XEN_BRANCH ?= "stable-${XEN_REL}"
5
6SRC_URI = " \
7 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \
8 file://0001-python-pygrub-pass-DISTUTILS-xen-4.14.patch \
9 file://0001-xen-build-temporarily-inhibit-Werror-4.14.patch \
10 "
11
12LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5"
13
14PV = "${XEN_REL}+stable${SRCPV}"
15
16S = "${WORKDIR}/git"
17
18DEFAULT_PREFERENCE ??= "-1"
19
20require xen.inc
21require xen-tools.inc
diff --git a/recipes-extended/xen/xen_4.14.bb b/recipes-extended/xen/xen_4.14.bb
new file mode 100644
index 00000000..02af2a7f
--- /dev/null
+++ b/recipes-extended/xen/xen_4.14.bb
@@ -0,0 +1,20 @@
1SRCREV ?= "02d69864b51a4302a148c28d6d391238a6778b4b"
2
3XEN_REL ?= "4.14"
4XEN_BRANCH ?= "stable-${XEN_REL}"
5
6SRC_URI = " \
7 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \
8 file://xen-arm64-implement-atomic-fetch-add.patch \
9 "
10
11LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5"
12
13PV = "${XEN_REL}+stable${SRCPV}"
14
15S = "${WORKDIR}/git"
16
17DEFAULT_PREFERENCE ??= "-1"
18
19require xen.inc
20require xen-hypervisor.inc