diff options
-rw-r--r-- | recipes-containers/lxc/lxc_1.1.4.bb | 21 |
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-containers/lxc/lxc_1.1.4.bb b/recipes-containers/lxc/lxc_1.1.4.bb index e017dcf4..a4c44d22 100644 --- a/recipes-containers/lxc/lxc_1.1.4.bb +++ b/recipes-containers/lxc/lxc_1.1.4.bb | |||
@@ -64,6 +64,13 @@ PACKAGECONFIG[apparmour] = "--enable-apparmor,--disable-apparmor,apparmor,apparm | |||
64 | PACKAGECONFIG[templates] = ",,, ${PN}-templates" | 64 | PACKAGECONFIG[templates] = ",,, ${PN}-templates" |
65 | PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux" | 65 | PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux" |
66 | PACKAGECONFIG[seccomp] ="--enable-seccomp,--disable-seccomp,libseccomp,libseccomp" | 66 | PACKAGECONFIG[seccomp] ="--enable-seccomp,--disable-seccomp,libseccomp,libseccomp" |
67 | PACKAGECONFIG[python] = "--enable-python,--disable-python,python3,python3-core" | ||
68 | |||
69 | # required by python3 to run setup.py | ||
70 | export BUILD_SYS | ||
71 | export HOST_SYS | ||
72 | export STAGING_INCDIR | ||
73 | export STAGING_LIBDIR | ||
67 | 74 | ||
68 | inherit autotools pkgconfig ptest update-rc.d systemd | 75 | inherit autotools pkgconfig ptest update-rc.d systemd |
69 | 76 | ||
@@ -78,6 +85,7 @@ INITSCRIPT_PARAMS_${PN}-setup = "${OS_DEFAULT_INITSCRIPT_PARAMS}" | |||
78 | FILES_${PN}-doc = "${mandir} ${infodir}" | 85 | FILES_${PN}-doc = "${mandir} ${infodir}" |
79 | # For LXC the docdir only contains example configuration files and should be included in the lxc package | 86 | # For LXC the docdir only contains example configuration files and should be included in the lxc package |
80 | FILES_${PN} += "${docdir}" | 87 | FILES_${PN} += "${docdir}" |
88 | FILES_${PN} += "${libdir}/python3*" | ||
81 | FILES_${PN}-dbg += "${libexecdir}/lxc/.debug" | 89 | FILES_${PN}-dbg += "${libexecdir}/lxc/.debug" |
82 | PACKAGES =+ "${PN}-templates ${PN}-setup ${PN}-networking" | 90 | PACKAGES =+ "${PN}-templates ${PN}-setup ${PN}-networking" |
83 | FILES_${PN}-templates += "${datadir}/lxc/templates" | 91 | FILES_${PN}-templates += "${datadir}/lxc/templates" |
@@ -92,6 +100,12 @@ FILES_${PN}-setup += "/etc/init.d" | |||
92 | 100 | ||
93 | PRIVATE_LIBS_${PN}-ptest = "liblxc.so.1" | 101 | PRIVATE_LIBS_${PN}-ptest = "liblxc.so.1" |
94 | 102 | ||
103 | CACHED_CONFIGUREVARS += " \ | ||
104 | ac_cv_path_PYTHON='${STAGING_BINDIR_NATIVE}/python3-native/python3' \ | ||
105 | am_cv_python_pyexecdir='${exec_prefix}/${libdir}/python3.5/site-packages' \ | ||
106 | am_cv_python_pythondir='${prefix}/${libdir}/python3.5/site-packages' \ | ||
107 | " | ||
108 | |||
95 | do_install_append() { | 109 | do_install_append() { |
96 | # The /var/cache/lxc directory created by the Makefile | 110 | # The /var/cache/lxc directory created by the Makefile |
97 | # is wiped out in volatile, we need to create this at boot. | 111 | # is wiped out in volatile, we need to create this at boot. |
@@ -107,6 +121,13 @@ do_install_append() { | |||
107 | install -d ${D}${sysconfdir}/init.d | 121 | install -d ${D}${sysconfdir}/init.d |
108 | install -m 755 config/init/sysvinit/lxc* ${D}${sysconfdir}/init.d | 122 | install -m 755 config/init/sysvinit/lxc* ${D}${sysconfdir}/init.d |
109 | fi | 123 | fi |
124 | |||
125 | # since python3-native is used for install location this will not be | ||
126 | # suitable for the target and we will have to correct the package install | ||
127 | if ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then | ||
128 | if [ -d ${D}${exec_prefix}/lib/python* ]; then mv ${D}${exec_prefix}/lib/python* ${D}${libdir}/; fi | ||
129 | rmdir --ignore-fail-on-non-empty ${D}${exec_prefix}/lib | ||
130 | fi | ||
110 | } | 131 | } |
111 | 132 | ||
112 | EXTRA_OEMAKE += "TEST_DIR=${D}${PTEST_PATH}/src/tests" | 133 | EXTRA_OEMAKE += "TEST_DIR=${D}${PTEST_PATH}/src/tests" |