diff options
3 files changed, 0 insertions, 47 deletions
diff --git a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto_6.6.bbappend b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto_6.6.bbappend deleted file mode 100644 index 2e2f92b6..00000000 --- a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto_6.6.bbappend +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | # Enable use of the linux-yocto kernel for the Raspberry Pi 4 | ||
2 | KBRANCH:raspberrypi4-64 ?= "v6.6/standard/bcm-2xxx-rpi" | ||
3 | KMACHINE:raspberrypi4-64 ?= "bcm-2xxx-rpi4" | ||
4 | COMPATIBLE_MACHINE:raspberrypi4-64 = "(raspberrypi4-64)" | ||
5 | |||
6 | require linux-yocto_xen-rpi.inc | ||
diff --git a/recipes-kernel/linux/linux-yocto_6.6_virtualization.inc b/recipes-kernel/linux/linux-yocto_6.6_virtualization.inc deleted file mode 100644 index 59311487..00000000 --- a/recipes-kernel/linux/linux-yocto_6.6_virtualization.inc +++ /dev/null | |||
@@ -1,4 +0,0 @@ | |||
1 | # include the baseline meta virtualization configuration options | ||
2 | # after this include, we can do version specific things | ||
3 | |||
4 | include linux-yocto_virtualization.inc | ||
diff --git a/recipes-kernel/linux/yocto-cfg-fragments-6.6.bb b/recipes-kernel/linux/yocto-cfg-fragments-6.6.bb deleted file mode 100644 index 6bdc0d03..00000000 --- a/recipes-kernel/linux/yocto-cfg-fragments-6.6.bb +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | HOMEPAGE = "https://git.yoctoproject.org/cgit/cgit.cgi/yocto-kernel-cache/" | ||
2 | SUMMARY = "Kernel configuration fragments" | ||
3 | DESCRIPTION = "Typically used as part of a kernel clone, this is the standalone \ | ||
4 | fragment repository. Making it available to other fragment management schemes \ | ||
5 | " | ||
6 | SECTION = "devel" | ||
7 | |||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | ||
10 | |||
11 | do_configure[noexec] = "1" | ||
12 | do_compile[noexec] = "1" | ||
13 | INHIBIT_DEFAULT_DEPS = "1" | ||
14 | |||
15 | LINUX_VERSION ?= "6.6" | ||
16 | PV = "v${LINUX_VERSION}+git${SRCREV}" | ||
17 | |||
18 | SRCREV = "4a494b202029e94a72ebb3c3966d9f1d249900f3" | ||
19 | SRC_URI = "\ | ||
20 | git://git.yoctoproject.org/yocto-kernel-cache;branch=yocto-${LINUX_VERSION} \ | ||
21 | " | ||
22 | |||
23 | S = "${WORKDIR}/git" | ||
24 | |||
25 | do_install() { | ||
26 | install -d ${D}${base_prefix}/kcfg | ||
27 | |||
28 | # copy the configuration fragments over to the native deploy | ||
29 | cp -r ${S}/* ${D}${base_prefix}/kcfg | ||
30 | # scripts bring in a bash dependency we don't want | ||
31 | rm -rf ${D}${base_prefix}/kcfg/scripts | ||
32 | } | ||
33 | |||
34 | FILES:${PN} += "kcfg/" | ||
35 | SYSROOT_DIRS += "${base_prefix}/kcfg" | ||
36 | BBCLASSEXTEND = "native nativesdk" | ||
37 | |||