summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-demo/helloworld-flask/helloworld-flask_0.1.bb18
1 files changed, 9 insertions, 9 deletions
diff --git a/recipes-demo/helloworld-flask/helloworld-flask_0.1.bb b/recipes-demo/helloworld-flask/helloworld-flask_0.1.bb
index 896e45fd..3f5507b3 100644
--- a/recipes-demo/helloworld-flask/helloworld-flask_0.1.bb
+++ b/recipes-demo/helloworld-flask/helloworld-flask_0.1.bb
@@ -19,20 +19,20 @@ EXTERNALPORT ?= "10000"
19do_install() { 19do_install() {
20 20
21 for tgt in flask-app.yaml flask-app-service.yaml; do 21 for tgt in flask-app.yaml flask-app-service.yaml; do
22 sed -i 's%\@NAME\@%${NAME}%g' ${WORKDIR}/$tgt 22 sed -i 's%\@NAME\@%${NAME}%g' ${UNPACKDIR}/$tgt
23 sed -i 's%\@APPNAME\@%${APPNAME}%g' ${WORKDIR}/$tgt 23 sed -i 's%\@APPNAME\@%${APPNAME}%g' ${UNPACKDIR}/$tgt
24 sed -i 's%\@CONTAINERNAME\@%${CONTAINERNAME}%g' ${WORKDIR}/$tgt 24 sed -i 's%\@CONTAINERNAME\@%${CONTAINERNAME}%g' ${UNPACKDIR}/$tgt
25 sed -i 's%\@CONTAINERIMAGE\@%${CONTAINERIMAGE}%g' ${WORKDIR}/$tgt 25 sed -i 's%\@CONTAINERIMAGE\@%${CONTAINERIMAGE}%g' ${UNPACKDIR}/$tgt
26 sed -i 's%\@CONTAINERPORT\@%${CONTAINERPORT}%g' ${WORKDIR}/$tgt 26 sed -i 's%\@CONTAINERPORT\@%${CONTAINERPORT}%g' ${UNPACKDIR}/$tgt
27 sed -i 's%\@EXTERNALPORT\@%${EXTERNALPORT}%g' ${WORKDIR}/$tgt 27 sed -i 's%\@EXTERNALPORT\@%${EXTERNALPORT}%g' ${UNPACKDIR}/$tgt
28 done 28 done
29 29
30 install -d ${D}${bindir}/ 30 install -d ${D}${bindir}/
31 install -m 755 ${WORKDIR}/flask-app ${D}${bindir}/ 31 install -m 755 ${UNPACKDIR}/flask-app ${D}${bindir}/
32 32
33 install -d ${D}${sysconfdir}/deploy 33 install -d ${D}${sysconfdir}/deploy
34 install -m 644 ${WORKDIR}/flask-app.yaml ${D}${sysconfdir}/ 34 install -m 644 ${UNPACKDIR}/flask-app.yaml ${D}${sysconfdir}/
35 install -m 644 ${WORKDIR}/flask-app-service.yaml ${D}${sysconfdir}/ 35 install -m 644 ${UNPACKDIR}/flask-app-service.yaml ${D}${sysconfdir}/
36} 36}
37 37
38RDEPENDS:${PN} += "python3-core python3-flask" 38RDEPENDS:${PN} += "python3-core python3-flask"