summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/criu/protobuf_2.5.0.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/recipes-containers/criu/protobuf_2.5.0.bb b/recipes-containers/criu/protobuf_2.5.0.bb
index 4a90b2c6..a9a26d88 100644
--- a/recipes-containers/criu/protobuf_2.5.0.bb
+++ b/recipes-containers/criu/protobuf_2.5.0.bb
@@ -13,8 +13,22 @@ PR = "r0"
13SRC_URI[md5sum] = "b751f772bdeb2812a2a8e7202bf1dae8" 13SRC_URI[md5sum] = "b751f772bdeb2812a2a8e7202bf1dae8"
14SRC_URI[sha256sum] = "c55aa3dc538e6fd5eaf732f4eb6b98bdcb7cedb5b91d3b5bdcf29c98c293f58e" 14SRC_URI[sha256sum] = "c55aa3dc538e6fd5eaf732f4eb6b98bdcb7cedb5b91d3b5bdcf29c98c293f58e"
15SRC_URI = "http://protobuf.googlecode.com/files/protobuf-${PV}.tar.gz" 15SRC_URI = "http://protobuf.googlecode.com/files/protobuf-${PV}.tar.gz"
16PYTHON_SRC_DIR="python"
16 17
17EXTRA_OECONF += " --with-protoc=echo" 18EXTRA_OECONF += " --with-protoc=echo"
18inherit autotools 19inherit autotools setuptools
20
21do_compile() {
22 # Compile protoc compiler
23 base_do_compile
24}
25
26do_install() {
27 # Install protoc compiler
28 autotools_do_install
29 # Install header files
30 cd "${PYTHON_SRC_DIR}"
31 distutils_do_install
32}
19 33
20BBCLASSEXTEND = "native nativesdk" 34BBCLASSEXTEND = "native nativesdk"