summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/docker-distribution/docker-distribution_git.bb5
-rw-r--r--recipes-containers/oci-image-tools/oci-image-tools_git.bb3
-rw-r--r--recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb2
-rw-r--r--recipes-containers/riddler/riddler_git.bb2
4 files changed, 6 insertions, 6 deletions
diff --git a/recipes-containers/docker-distribution/docker-distribution_git.bb b/recipes-containers/docker-distribution/docker-distribution_git.bb
index e86d4ff9..b8181c7a 100644
--- a/recipes-containers/docker-distribution/docker-distribution_git.bb
+++ b/recipes-containers/docker-distribution/docker-distribution_git.bb
@@ -3,9 +3,6 @@ SUMMARY = "The Docker toolset to pack, ship, store, and deliver content"
3LICENSE = "Apache-2.0" 3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
5 5
6DEPENDS = "go-cross-${TARGET_ARCH} \
7 "
8
9SRCREV_distribution="0810eba2adf048b77621472991211924d9ec31c5" 6SRCREV_distribution="0810eba2adf048b77621472991211924d9ec31c5"
10SRC_URI = "git://github.com/docker/distribution.git;branch=master;name=distribution;destsuffix=git/src/github.com/docker/distribution \ 7SRC_URI = "git://github.com/docker/distribution.git;branch=master;name=distribution;destsuffix=git/src/github.com/docker/distribution \
11 file://docker-registry.service \ 8 file://docker-registry.service \
@@ -17,6 +14,7 @@ PV = "v2.6.0-rc+git${SRCPV}"
17S = "${WORKDIR}/git/src/github.com/docker/distribution" 14S = "${WORKDIR}/git/src/github.com/docker/distribution"
18 15
19inherit go-osarchmap 16inherit go-osarchmap
17inherit go
20 18
21# This disables seccomp and apparmor, which are on by default in the 19# This disables seccomp and apparmor, which are on by default in the
22# go package. 20# go package.
@@ -32,6 +30,7 @@ do_compile() {
32 export CFLAGS="" 30 export CFLAGS=""
33 export LDFLAGS="" 31 export LDFLAGS=""
34 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}" 32 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
33 export GO_GCFLAGS=""
35 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 34 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
36 35
37 oe_runmake binaries 36 oe_runmake binaries
diff --git a/recipes-containers/oci-image-tools/oci-image-tools_git.bb b/recipes-containers/oci-image-tools/oci-image-tools_git.bb
index 090020ae..49375b7f 100644
--- a/recipes-containers/oci-image-tools/oci-image-tools_git.bb
+++ b/recipes-containers/oci-image-tools/oci-image-tools_git.bb
@@ -3,7 +3,7 @@ SUMMARY = "A collection of tools for working with the OCI image format specifica
3LICENSE = "Apache-2" 3LICENSE = "Apache-2"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
5 5
6DEPENDS = "go-cross-${TARGET_ARCH} \ 6DEPENDS = "\
7 oci-image-spec \ 7 oci-image-spec \
8 oci-runtime-spec \ 8 oci-runtime-spec \
9 go-digest \ 9 go-digest \
@@ -19,6 +19,7 @@ PV = "0.1.0+git${SRCPV}"
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20 20
21inherit go-osarchmap 21inherit go-osarchmap
22inherit go
22 23
23# This disables seccomp and apparmor, which are on by default in the 24# This disables seccomp and apparmor, which are on by default in the
24# go package. 25# go package.
diff --git a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
index 7e5af380..a4c544d5 100644
--- a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
+++ b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
@@ -2,7 +2,6 @@ HOMEPAGE = "https://github.com/opencontainers/runtime-tools"
2SUMMARY = "oci-runtime-tool is a collection of tools for working with the OCI runtime specification" 2SUMMARY = "oci-runtime-tool is a collection of tools for working with the OCI runtime specification"
3LICENSE = "GPLv2" 3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b355a61a394a504dacde901c958f662c" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=b355a61a394a504dacde901c958f662c"
5DEPENDS = "go-cross-${TARGET_ARCH}"
6 5
7SRC_URI = "git://github.com/opencontainers/runtime-tools.git" 6SRC_URI = "git://github.com/opencontainers/runtime-tools.git"
8 7
@@ -12,6 +11,7 @@ PV = "0.0.1+git${SRCPV}"
12S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
13 12
14inherit go-osarchmap 13inherit go-osarchmap
14inherit go
15 15
16do_compile() { 16do_compile() {
17 export GOARCH="${TARGET_GOARCH}" 17 export GOARCH="${TARGET_GOARCH}"
diff --git a/recipes-containers/riddler/riddler_git.bb b/recipes-containers/riddler/riddler_git.bb
index 49e8aa01..a04cc3e2 100644
--- a/recipes-containers/riddler/riddler_git.bb
+++ b/recipes-containers/riddler/riddler_git.bb
@@ -2,7 +2,6 @@ HOMEPAGE = "https://github.com/jfrazelle/riddler"
2SUMMARY = "Convert `docker inspect` to opencontainers (OCI compatible) runc spec." 2SUMMARY = "Convert `docker inspect` to opencontainers (OCI compatible) runc spec."
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1"
5DEPENDS = "go-cross-${TARGET_ARCH}"
6 5
7SRC_URI = "git://github.com/jfrazelle/riddler;branch=master" 6SRC_URI = "git://github.com/jfrazelle/riddler;branch=master"
8SRCREV = "23befa0b232877b5b502b828e24161d801bd67f6" 7SRCREV = "23befa0b232877b5b502b828e24161d801bd67f6"
@@ -11,6 +10,7 @@ PV = "0.1.0+git${SRCPV}"
11S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
12 11
13inherit go-osarchmap 12inherit go-osarchmap
13inherit go
14 14
15# This disables seccomp and apparmor, which are on by default in the 15# This disables seccomp and apparmor, which are on by default in the
16# go package. 16# go package.