diff options
-rw-r--r-- | recipes-containers/docker/docker-moby_git.bb | 10 | ||||
-rw-r--r-- | recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch | 6 |
2 files changed, 8 insertions, 8 deletions
diff --git a/recipes-containers/docker/docker-moby_git.bb b/recipes-containers/docker/docker-moby_git.bb index 4682ab4e..f8c4c9e5 100644 --- a/recipes-containers/docker/docker-moby_git.bb +++ b/recipes-containers/docker/docker-moby_git.bb | |||
@@ -44,14 +44,14 @@ DESCRIPTION = "Linux container runtime \ | |||
44 | # so we get that tag, and make it our SRCREVS: | 44 | # so we get that tag, and make it our SRCREVS: |
45 | # | 45 | # |
46 | 46 | ||
47 | SRCREV_moby = "afcd2cde957e5d3c33b79652645163dcb277b95d" | 47 | SRCREV_moby = "615dfdf67264ed5b08dd5e86657bf0e580731cea" |
48 | SRCREV_libnetwork = "67e0588f1ddfaf2faf4c8cae8b7ea2876434d91c" | 48 | SRCREV_libnetwork = "67e0588f1ddfaf2faf4c8cae8b7ea2876434d91c" |
49 | SRCREV_cli = "ed223bc820ee9bb7005a333013b86203a9e1bc23" | 49 | SRCREV_cli = "01f933261885c0126edb3f47fd56d048ae31265a" |
50 | SRCREV_FORMAT = "moby_libnetwork" | 50 | SRCREV_FORMAT = "moby_libnetwork" |
51 | SRC_URI = "\ | 51 | SRC_URI = "\ |
52 | git://github.com/moby/moby.git;branch=24.0;name=moby;protocol=https \ | 52 | git://github.com/moby/moby.git;branch=25.0;name=moby;protocol=https \ |
53 | git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork;protocol=https \ | 53 | git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork;protocol=https \ |
54 | git://github.com/docker/cli;branch=24.0;name=cli;destsuffix=git/cli;protocol=https \ | 54 | git://github.com/docker/cli;branch=25.0;name=cli;destsuffix=git/cli;protocol=https \ |
55 | file://docker.init \ | 55 | file://docker.init \ |
56 | file://0001-libnetwork-use-GO-instead-of-go.patch \ | 56 | file://0001-libnetwork-use-GO-instead-of-go.patch \ |
57 | file://0001-cli-use-external-GO111MODULE-and-cross-compiler.patch \ | 57 | file://0001-cli-use-external-GO111MODULE-and-cross-compiler.patch \ |
@@ -66,7 +66,7 @@ require docker.inc | |||
66 | LICENSE = "Apache-2.0" | 66 | LICENSE = "Apache-2.0" |
67 | LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28" | 67 | LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28" |
68 | 68 | ||
69 | DOCKER_VERSION = "24.0.7" | 69 | DOCKER_VERSION = "25.0.0" |
70 | PV = "${DOCKER_VERSION}+git${SRCREV_moby}" | 70 | PV = "${DOCKER_VERSION}+git${SRCREV_moby}" |
71 | 71 | ||
72 | CVE_PRODUCT = "docker mobyproject:moby" | 72 | CVE_PRODUCT = "docker mobyproject:moby" |
diff --git a/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch b/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch index 696eeaa7..160a3bca 100644 --- a/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch +++ b/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch | |||
@@ -100,12 +100,12 @@ Index: import/hack/make/.binary | |||
100 | fi | 100 | fi |
101 | fi | 101 | fi |
102 | 102 | ||
103 | @@ -78,7 +57,7 @@ | 103 | @@ -82,7 +61,7 @@ |
104 | if [ -n "$DOCKER_DEBUG" ]; then | 104 | if [ -n "$DOCKER_DEBUG" ]; then |
105 | set -x | 105 | set -x |
106 | fi | 106 | fi |
107 | - ./hack/with-go-mod.sh go build -mod=vendor -modfile=vendor.mod -o "$DEST/$BINARY_FULLNAME" "${BUILDFLAGS[@]}" -ldflags "$LDFLAGS $LDFLAGS_STATIC $DOCKER_LDFLAGS" "$GO_PACKAGE" | 107 | - ./hack/with-go-mod.sh go build -mod=vendor -modfile=vendor.mod -o "$DEST/$BINARY_FULLNAME" "${BUILDFLAGS[@]}" -ldflags "$LDFLAGS $LDFLAGS_STATIC $DOCKER_LDFLAGS" -gcflags="${GCFLAGS}" "$GO_PACKAGE" |
108 | + ./hack/with-go-mod.sh ${GO} build -trimpath -mod=vendor -modfile=vendor.mod -o "$DEST/$BINARY_FULLNAME" "${BUILDFLAGS[@]}" -ldflags "$LDFLAGS $LDFLAGS_STATIC $DOCKER_LDFLAGS" "$GO_PACKAGE" | 108 | + ./hack/with-go-mod.sh ${GO} build -trimpath -mod=vendor -modfile=vendor.mod -o "$DEST/$BINARY_FULLNAME" "${BUILDFLAGS[@]}" -ldflags "$LDFLAGS $LDFLAGS_STATIC $DOCKER_LDFLAGS" -gcflags="${GCFLAGS}" "$GO_PACKAGE" |
109 | ) | 109 | ) |
110 | 110 | ||
111 | echo "Created binary: $DEST/$BINARY_FULLNAME" | 111 | echo "Created binary: $DEST/$BINARY_FULLNAME" |