diff options
-rw-r--r-- | recipes-containers/docker-distribution/docker-distribution_git.bb | 1 | ||||
-rw-r--r-- | recipes-containers/docker-distribution/files/0001-panicwrap-Use-dup3-on-riscv64-linux.patch | 42 |
2 files changed, 43 insertions, 0 deletions
diff --git a/recipes-containers/docker-distribution/docker-distribution_git.bb b/recipes-containers/docker-distribution/docker-distribution_git.bb index f8981a88..50b6b302 100644 --- a/recipes-containers/docker-distribution/docker-distribution_git.bb +++ b/recipes-containers/docker-distribution/docker-distribution_git.bb | |||
@@ -8,6 +8,7 @@ SRC_URI = "git://github.com/docker/distribution.git;branch=release/2.8;name=dist | |||
8 | file://docker-registry.service \ | 8 | file://docker-registry.service \ |
9 | file://0001-build-use-to-use-cross-go-compiler.patch \ | 9 | file://0001-build-use-to-use-cross-go-compiler.patch \ |
10 | file://0001-Fix-runaway-allocation-on-v2-_catalog.patch \ | 10 | file://0001-Fix-runaway-allocation-on-v2-_catalog.patch \ |
11 | file://0001-panicwrap-Use-dup3-on-riscv64-linux.patch \ | ||
11 | " | 12 | " |
12 | 13 | ||
13 | PACKAGES =+ "docker-registry" | 14 | PACKAGES =+ "docker-registry" |
diff --git a/recipes-containers/docker-distribution/files/0001-panicwrap-Use-dup3-on-riscv64-linux.patch b/recipes-containers/docker-distribution/files/0001-panicwrap-Use-dup3-on-riscv64-linux.patch new file mode 100644 index 00000000..ad091f1c --- /dev/null +++ b/recipes-containers/docker-distribution/files/0001-panicwrap-Use-dup3-on-riscv64-linux.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | From 21d54c68751760b1f8915807794a432cf01fb733 Mon Sep 17 00:00:00 2001 | ||
2 | From: Mingli Yu <mingli.yu@windriver.com> | ||
3 | Date: Tue, 9 Jul 2024 16:28:14 +0800 | ||
4 | Subject: [PATCH] panicwrap: Use dup3 on riscv64 linux | ||
5 | |||
6 | Use dup3 instead for riscv64 as there is no dup2 on riscv64 linux | ||
7 | to fix the below failure: | ||
8 | vendor/github.com/bugsnag/panicwrap/dup2.go:10:9: undefined: syscall.Dup2 | ||
9 | |||
10 | Upstream-Status: Inappropriate[The upstream has removed the panicwrap as [1]] | ||
11 | |||
12 | [1] https://github.com/distribution/distribution/commit/3e4c4ead4c3aa07c27f95f2a5c92c6d5c2f9dcdb | ||
13 | |||
14 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> | ||
15 | --- | ||
16 | vendor/github.com/bugsnag/panicwrap/dup2.go | 2 +- | ||
17 | vendor/github.com/bugsnag/panicwrap/dup3.go | 2 +- | ||
18 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
19 | |||
20 | diff --git a/vendor/github.com/bugsnag/panicwrap/dup2.go b/vendor/github.com/bugsnag/panicwrap/dup2.go | ||
21 | index de523c83..c68ce5ff 100644 | ||
22 | --- a/vendor/github.com/bugsnag/panicwrap/dup2.go | ||
23 | +++ b/vendor/github.com/bugsnag/panicwrap/dup2.go | ||
24 | @@ -1,4 +1,4 @@ | ||
25 | -// +build darwin dragonfly freebsd linux,!arm64 netbsd openbsd | ||
26 | +// +build darwin dragonfly freebsd linux,!arm64,!riscv64 netbsd openbsd | ||
27 | |||
28 | package panicwrap | ||
29 | |||
30 | diff --git a/vendor/github.com/bugsnag/panicwrap/dup3.go b/vendor/github.com/bugsnag/panicwrap/dup3.go | ||
31 | index 9721b36c..c664da85 100644 | ||
32 | --- a/vendor/github.com/bugsnag/panicwrap/dup3.go | ||
33 | +++ b/vendor/github.com/bugsnag/panicwrap/dup3.go | ||
34 | @@ -1,4 +1,4 @@ | ||
35 | -// +build linux,arm64 | ||
36 | +// +build linux,arm64 linux,riscv64 | ||
37 | |||
38 | package panicwrap | ||
39 | |||
40 | -- | ||
41 | 2.34.1 | ||
42 | |||