diff options
-rw-r--r-- | recipes-containers/criu/criu_1.2.bb | 39 | ||||
-rw-r--r-- | recipes-containers/criu/criu_git.bb | 46 | ||||
-rw-r--r-- | recipes-containers/criu/files/0001-Fixed-hardcoding.patch | 47 | ||||
-rw-r--r-- | recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch (renamed from recipes-containers/criu/criu-1.2/0001-Makefile-Fix-hardcoding.patch) | 18 | ||||
-rw-r--r-- | recipes-containers/criu/files/0002-criu-Skip-documentation-install.patch | 29 | ||||
-rw-r--r-- | recipes-containers/criu/protobuf-c_0.15.bb | 4 | ||||
-rw-r--r-- | recipes-containers/criu/protobuf_2.5.0.bb | 3 |
7 files changed, 82 insertions, 104 deletions
diff --git a/recipes-containers/criu/criu_1.2.bb b/recipes-containers/criu/criu_1.2.bb deleted file mode 100644 index de07842c..00000000 --- a/recipes-containers/criu/criu_1.2.bb +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | SUMMARY = "CRIU" | ||
2 | DESCRIPTION = "Checkpoint/Restore In Userspace, or CRIU, is a software \ | ||
3 | tool for Linux operating system. Using this tool, you can freeze a running \ | ||
4 | application (or part of it) and checkpoint it to a hard drive \ | ||
5 | as a collection of files. You can then use the files to restore and run \ | ||
6 | the application from the point it was frozen at. The distinctive feature \ | ||
7 | of the CRIU project is that it is mainly implemented in user space" | ||
8 | HOMEPAGE = "http://criu.org" | ||
9 | SECTION = "console/tools" | ||
10 | LICENSE = "GPLv2" | ||
11 | |||
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=5cc804625b8b491b6b4312f0c9cb5efa" | ||
13 | |||
14 | SRCREV = "v1.2" | ||
15 | PR = "r0" | ||
16 | PV = "1.2" | ||
17 | |||
18 | SRC_URI = "git://git.criu.org/crtools.git;protocol=git \ | ||
19 | file://0001-Makefile-Fix-hardcoding.patch" | ||
20 | |||
21 | DEPENDS += "protobuf-c-native protobuf-c" | ||
22 | |||
23 | S = "${WORKDIR}/git" | ||
24 | |||
25 | ARMV_armv7a = "ARMV=7" | ||
26 | ARMV_armv6 = "ARMV=6" | ||
27 | ARMV ?= "" | ||
28 | EXTRA_OEMAKE += "ARCH=${TARGET_ARCH} WERROR=0 ${ARMV}" | ||
29 | |||
30 | do_compile () { | ||
31 | unset CFLAGS | ||
32 | unset LDFLAGS | ||
33 | oe_runmake | ||
34 | } | ||
35 | |||
36 | do_install () { | ||
37 | mkdir -p ${D}/${bindir} | ||
38 | install -m 755 ${S}/criu ${D}/${bindir}/criu | ||
39 | } | ||
diff --git a/recipes-containers/criu/criu_git.bb b/recipes-containers/criu/criu_git.bb index 878827f8..2b8921fa 100644 --- a/recipes-containers/criu/criu_git.bb +++ b/recipes-containers/criu/criu_git.bb | |||
@@ -1,29 +1,55 @@ | |||
1 | SUMMARY = "CRIU" | 1 | SUMMARY = "CRIU" |
2 | DESCRIPTION = "Checkpoint/Restore In Userspace, or CRIU, is a software tool for Linux operating system. Using this tool, you can freeze a running application (or part of it) and checkpoint it to a hard drive as a collection of files. You can then use the files to restore and run the application from the point it was frozen at. The distinctive feature of the CRIU project is that it is mainly implemented in user space" | 2 | DESCRIPTION = "Checkpoint/Restore In Userspace, or CRIU, is a software tool for \ |
3 | Linux operating system. Using this tool, you can freeze a running application \ | ||
4 | (or part of it) and checkpoint it to a hard drive as a collection of files. \ | ||
5 | You can then use the files to restore and run the application from the point \ | ||
6 | it was frozen at. The distinctive feature of the CRIU project is that it is \ | ||
7 | mainly implemented in user space" | ||
3 | HOMEPAGE = "http://criu.org" | 8 | HOMEPAGE = "http://criu.org" |
4 | SECTION = "console/tools" | 9 | SECTION = "console/tools" |
5 | LICENSE = "GPLv2" | 10 | LICENSE = "GPLv2" |
6 | 11 | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=12920dfe6b35a0758155f0e62878b366" | 12 | EXCLUDE_FROM_WORLD = "1" |
8 | 13 | ||
9 | SRCREV = "d81c9a4618db2f618bdb8e207b7f0fec631c7142" | 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=5cc804625b8b491b6b4312f0c9cb5efa" |
15 | |||
16 | SRCREV = "bda033e1e91ac5b86afd0a9fdb9fcdd581da6185" | ||
10 | PR = "r0" | 17 | PR = "r0" |
11 | PV = "0.2+git${SRCPV}" | 18 | PV = "1.4+git${SRCPV}" |
12 | 19 | ||
13 | SRC_URI = "git://git.criu.org/crtools.git;protocol=git \ | 20 | SRC_URI = "git://git.criu.org/crtools.git;protocol=git \ |
14 | file://0001-Fixed-hardcoding.patch" | 21 | file://0001-criu-Fix-toolchain-hardcode.patch \ |
22 | file://0002-criu-Skip-documentation-install.patch \ | ||
23 | " | ||
24 | |||
25 | COMPATIBLE_HOST = "(x86_64|arm).*-linux" | ||
15 | 26 | ||
16 | DEPENDS += "protobuf-c-native protobuf-c" | 27 | DEPENDS += "protobuf-c-native protobuf-c" |
17 | 28 | ||
18 | S = "${WORKDIR}/git" | 29 | S = "${WORKDIR}/git" |
19 | 30 | ||
20 | EXTRA_OEMAKE += "ARCH=${TARGET_ARCH} WERROR=0" | 31 | # |
32 | # CRIU just can be built on ARMv7 and ARMv6, so the Makefile check | ||
33 | # if the ARCH is ARMv7 or ARMv6. | ||
34 | # ARM BSPs need set CRIU_BUILD_ARCH variable for building CRIU. | ||
35 | # | ||
36 | EXTRA_OEMAKE_arm += "ARCH=${CRIU_BUILD_ARCH} WERROR=0" | ||
37 | EXTRA_OEMAKE_x86-64 += "ARCH=${TARGET_ARCH} WERROR=0" | ||
38 | |||
39 | EXTRA_OEMAKE_append += "SBINDIR=${sbindir} LIBDIR=${libdir} INCLUDEDIR=${includedir}" | ||
40 | EXTRA_OEMAKE_append += "LOGROTATEDIR=${sysconfdir} SYSTEMDUNITDIR=${systemd_unitdir}" | ||
41 | |||
42 | CFLAGS += "-D__USE_GNU -D_GNU_SOURCE" | ||
43 | |||
44 | # overide LDFLAGS to allow criu to build without: "x86_64-poky-linux-ld: unrecognized option '-Wl,-O1'" | ||
45 | export LDFLAGS="" | ||
21 | 46 | ||
22 | do_compile () { | 47 | do_compile () { |
23 | oe_runmake | 48 | oe_runmake |
24 | } | 49 | } |
25 | 50 | ||
26 | do_install () { | 51 | do_install () { |
27 | mkdir -p ${D}/${bindir} | 52 | oe_runmake DESTDIR="${D}" install |
28 | install -m 755 ${S}/crtools ${D}/${bindir}/crtools | 53 | } |
29 | } \ No newline at end of file | 54 | |
55 | FILES_${PN} += "${systemd_unitdir}/" | ||
diff --git a/recipes-containers/criu/files/0001-Fixed-hardcoding.patch b/recipes-containers/criu/files/0001-Fixed-hardcoding.patch deleted file mode 100644 index 5ff0a78d..00000000 --- a/recipes-containers/criu/files/0001-Fixed-hardcoding.patch +++ /dev/null | |||
@@ -1,47 +0,0 @@ | |||
1 | From 32c6c037a6de0a0972e16949ebb64ffebb5b7bcc Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?David=20Nystr=C3=B6m?= <david.nystrom@enea.com> | ||
3 | Date: Wed, 28 Nov 2012 15:07:27 +0100 | ||
4 | Subject: [PATCH] Fixed hardcoding | ||
5 | |||
6 | --- | ||
7 | Makefile.inc | 24 ++++++++++++------------ | ||
8 | 1 file changed, 12 insertions(+), 12 deletions(-) | ||
9 | |||
10 | diff --git a/Makefile.inc b/Makefile.inc | ||
11 | index 722cbfc..3ae693e 100644 | ||
12 | --- a/Makefile.inc | ||
13 | +++ b/Makefile.inc | ||
14 | @@ -11,18 +11,18 @@ else | ||
15 | endif | ||
16 | export E Q | ||
17 | |||
18 | -FIND := find | ||
19 | -CSCOPE := cscope | ||
20 | -TAGS := ctags | ||
21 | -RM := rm | ||
22 | -LD := ld | ||
23 | -HEXDUMP := hexdump | ||
24 | -CC := gcc | ||
25 | -ECHO := echo | ||
26 | -NM := nm | ||
27 | -AWK := awk | ||
28 | -SH := sh | ||
29 | -MAKE := make | ||
30 | +FIND ?= find | ||
31 | +CSCOPE ?= cscope | ||
32 | +TAGS ?= ctags | ||
33 | +RM ?= rm | ||
34 | +LD ?= ld | ||
35 | +HEXDUMP ?= hexdump | ||
36 | +CC ?= gcc | ||
37 | +ECHO ?= echo | ||
38 | +NM ?= nm | ||
39 | +AWK ?= awk | ||
40 | +SH ?= sh | ||
41 | +MAKE ?= make | ||
42 | |||
43 | # Additional ARCH settings for x86 | ||
44 | ARCH ?= $(shell echo $(uname_M) | sed -e s/i.86/i386/ -e s/sun4u/sparc64/ \ | ||
45 | -- | ||
46 | 1.7.9.5 | ||
47 | |||
diff --git a/recipes-containers/criu/criu-1.2/0001-Makefile-Fix-hardcoding.patch b/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch index fd9ab5b1..2fabe0ad 100644 --- a/recipes-containers/criu/criu-1.2/0001-Makefile-Fix-hardcoding.patch +++ b/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch | |||
@@ -1,15 +1,19 @@ | |||
1 | From fa785bb1eb9cb0039d77836f4658c7bcccae5999 Mon Sep 17 00:00:00 2001 | 1 | From 3d4f112fdb434712eba09239a468842323f1af4c Mon Sep 17 00:00:00 2001 |
2 | From: Alexey Firago <alexey_firago@mentor.com> | 2 | From: Yang Shi <yang.shi@windriver.com> |
3 | Date: Wed, 9 Jul 2014 02:01:11 +0400 | 3 | Date: Tue, 26 Aug 2014 14:42:42 -0700 |
4 | Subject: [PATCH] Makefile: Fix hardcoding | 4 | Subject: [PATCH 1/2] criu: Fix toolchain hardcode |
5 | 5 | ||
6 | Signed-off-by: Alexey Firago <alexey_firago@mentor.com> | 6 | Replace ":=" to "?=" so that the toolchain used by bitbake build system will |
7 | be taken. | ||
8 | |||
9 | Signed-off-by: Yang Shi <yang.shi@windriver.com> | ||
10 | Signed-off-by: Nam Ninh <nam.ninh@windriver.com> | ||
7 | --- | 11 | --- |
8 | Makefile | 18 +++++++++--------- | 12 | Makefile | 18 +++++++++--------- |
9 | 1 file changed, 9 insertions(+), 9 deletions(-) | 13 | 1 file changed, 9 insertions(+), 9 deletions(-) |
10 | 14 | ||
11 | diff --git a/Makefile b/Makefile | 15 | diff --git a/Makefile b/Makefile |
12 | index bda808d..4614ae2 100644 | 16 | index f1c8784..43252ec 100644 |
13 | --- a/Makefile | 17 | --- a/Makefile |
14 | +++ b/Makefile | 18 | +++ b/Makefile |
15 | @@ -23,15 +23,15 @@ export VERSION_SO_MAJOR VERSION_SO_MINOR | 19 | @@ -23,15 +23,15 @@ export VERSION_SO_MAJOR VERSION_SO_MINOR |
@@ -38,5 +42,5 @@ index bda808d..4614ae2 100644 | |||
38 | CFLAGS += $(USERCFLAGS) | 42 | CFLAGS += $(USERCFLAGS) |
39 | 43 | ||
40 | -- | 44 | -- |
41 | 1.9.1 | 45 | 2.0.2 |
42 | 46 | ||
diff --git a/recipes-containers/criu/files/0002-criu-Skip-documentation-install.patch b/recipes-containers/criu/files/0002-criu-Skip-documentation-install.patch new file mode 100644 index 00000000..eaf81603 --- /dev/null +++ b/recipes-containers/criu/files/0002-criu-Skip-documentation-install.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From e9c2a94b9eb37ad24672b10caa398bd18282b962 Mon Sep 17 00:00:00 2001 | ||
2 | From: Yang Shi <yang.shi@windriver.com> | ||
3 | Date: Tue, 26 Aug 2014 14:44:51 -0700 | ||
4 | Subject: [PATCH 2/2] criu: Skip documentation install | ||
5 | |||
6 | asciidoc is needed to generate CRIU documentation, so skip it in install. | ||
7 | |||
8 | Signed-off-by: Yang Shi <yang.shi@windriver.com> | ||
9 | Signed-off-by: Nam Ninh <nam.ninh@windriver.com> | ||
10 | --- | ||
11 | Makefile | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/Makefile b/Makefile | ||
15 | index 43252ec..e25edcc 100644 | ||
16 | --- a/Makefile | ||
17 | +++ b/Makefile | ||
18 | @@ -265,7 +265,7 @@ install: $(PROGRAM) install-man | ||
19 | $(Q) install -m 644 scripts/logrotate.d/criu-service $(DESTDIR)$(LOGROTATEDIR) | ||
20 | |||
21 | install-man: | ||
22 | - $(Q) $(MAKE) -C Documentation install | ||
23 | +# $(Q) $(MAKE) -C Documentation install | ||
24 | |||
25 | .PHONY: install install-man | ||
26 | |||
27 | -- | ||
28 | 2.0.2 | ||
29 | |||
diff --git a/recipes-containers/criu/protobuf-c_0.15.bb b/recipes-containers/criu/protobuf-c_0.15.bb index d9d4fd97..5d65c69a 100644 --- a/recipes-containers/criu/protobuf-c_0.15.bb +++ b/recipes-containers/criu/protobuf-c_0.15.bb | |||
@@ -8,6 +8,8 @@ LIC_FILES_CHKSUM = "file://src/google/protobuf-c/protobuf-c.c;endline=33;md5=333 | |||
8 | 8 | ||
9 | PR = "r0" | 9 | PR = "r0" |
10 | 10 | ||
11 | COMPATIBLE_HOST = "(x86_64|arm).*-linux" | ||
12 | |||
11 | DEPENDS = "protobuf" | 13 | DEPENDS = "protobuf" |
12 | 14 | ||
13 | SRC_URI[md5sum] = "73ff0c8df50d2eee75269ad8f8c07dc8" | 15 | SRC_URI[md5sum] = "73ff0c8df50d2eee75269ad8f8c07dc8" |
@@ -17,4 +19,4 @@ SRC_URI = "http://protobuf-c.googlecode.com/files/protobuf-c-${PV}.tar.gz \ | |||
17 | 19 | ||
18 | inherit autotools | 20 | inherit autotools |
19 | 21 | ||
20 | BBCLASSEXTEND = "native nativesdk" \ No newline at end of file | 22 | BBCLASSEXTEND = "native nativesdk" |
diff --git a/recipes-containers/criu/protobuf_2.5.0.bb b/recipes-containers/criu/protobuf_2.5.0.bb index 0e11ff48..b19e9067 100644 --- a/recipes-containers/criu/protobuf_2.5.0.bb +++ b/recipes-containers/criu/protobuf_2.5.0.bb | |||
@@ -9,6 +9,7 @@ LICENSE = "BSD-3-Clause" | |||
9 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=af6809583bfde9a31595a58bb4a24514" | 9 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=af6809583bfde9a31595a58bb4a24514" |
10 | 10 | ||
11 | PR = "r0" | 11 | PR = "r0" |
12 | EXCLUDE_FROM_WORLD = "1" | ||
12 | 13 | ||
13 | SRC_URI[md5sum] = "b751f772bdeb2812a2a8e7202bf1dae8" | 14 | SRC_URI[md5sum] = "b751f772bdeb2812a2a8e7202bf1dae8" |
14 | SRC_URI[sha256sum] = "c55aa3dc538e6fd5eaf732f4eb6b98bdcb7cedb5b91d3b5bdcf29c98c293f58e" | 15 | SRC_URI[sha256sum] = "c55aa3dc538e6fd5eaf732f4eb6b98bdcb7cedb5b91d3b5bdcf29c98c293f58e" |
@@ -16,6 +17,8 @@ SRC_URI = "http://protobuf.googlecode.com/files/protobuf-${PV}.tar.gz \ | |||
16 | file://protobuf-allow-running-python-scripts-from-anywhere.patch \ | 17 | file://protobuf-allow-running-python-scripts-from-anywhere.patch \ |
17 | file://run-ptest" | 18 | file://run-ptest" |
18 | 19 | ||
20 | COMPATIBLE_HOST = "(x86_64|arm).*-linux" | ||
21 | |||
19 | EXTRA_OECONF += " --with-protoc=${STAGING_BINDIR_NATIVE}/protoc" | 22 | EXTRA_OECONF += " --with-protoc=${STAGING_BINDIR_NATIVE}/protoc" |
20 | inherit autotools setuptools ptest | 23 | inherit autotools setuptools ptest |
21 | 24 | ||