summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/libvirt/libvirt/CVE-2021-3667.patch32
-rw-r--r--recipes-extended/libvirt/libvirt_6.1.0.bb2
2 files changed, 33 insertions, 1 deletions
diff --git a/recipes-extended/libvirt/libvirt/CVE-2021-3667.patch b/recipes-extended/libvirt/libvirt/CVE-2021-3667.patch
new file mode 100644
index 00000000..b99c5da0
--- /dev/null
+++ b/recipes-extended/libvirt/libvirt/CVE-2021-3667.patch
@@ -0,0 +1,32 @@
1From 494fc57f60af732a72b02c984527878ea7a016dc Mon Sep 17 00:00:00 2001
2From: Hitendra Prajapati <hprajapati@mvista.com>
3Date: Mon, 20 Jun 2022 12:40:39 +0530
4Subject: [PATCH] CVE-2021-3667
5
6Upstream-Status: Backport [https://gitlab.com/libvirt/libvirt/-/commit/447f69dec47e1b0bd15ecd7cd49a9fd3b050fb87]
7CVE: CVE-2021-3667
8Signed-off-by: Hitendra Prajapati <hprajapati@mvista.com>
9
10---
11 src/storage/storage_driver.c | 4 +++-
12 1 file changed, 3 insertions(+), 1 deletion(-)
13
14diff --git a/src/storage/storage_driver.c b/src/storage/storage_driver.c
15index 7e59335..1f1225d 100644
16--- a/src/storage/storage_driver.c
17+++ b/src/storage/storage_driver.c
18@@ -1741,8 +1741,10 @@ storagePoolLookupByTargetPath(virConnectPtr conn,
19 storagePoolLookupByTargetPathCallback,
20 cleanpath))) {
21 def = virStoragePoolObjGetDef(obj);
22- if (virStoragePoolLookupByTargetPathEnsureACL(conn, def) < 0)
23+ if (virStoragePoolLookupByTargetPathEnsureACL(conn, def) < 0) {
24+ virStoragePoolObjEndAPI(&obj);
25 return NULL;
26+ }
27
28 pool = virGetStoragePool(conn, def->name, def->uuid, NULL, NULL);
29 virStoragePoolObjEndAPI(&obj);
30--
312.25.1
32
diff --git a/recipes-extended/libvirt/libvirt_6.1.0.bb b/recipes-extended/libvirt/libvirt_6.1.0.bb
index d4978b38..d0f2c315 100644
--- a/recipes-extended/libvirt/libvirt_6.1.0.bb
+++ b/recipes-extended/libvirt/libvirt_6.1.0.bb
@@ -46,8 +46,8 @@ SRC_URI = "http://libvirt.org/sources/libvirt-${PV}.tar.xz;name=libvirt \
46 file://CVE-2020-25637_3.patch \ 46 file://CVE-2020-25637_3.patch \
47 file://CVE-2020-25637_4.patch \ 47 file://CVE-2020-25637_4.patch \
48 file://CVE-2021-3631.patch \ 48 file://CVE-2021-3631.patch \
49 file://CVE-2021-3667.patch \
49 " 50 "
50
51SRC_URI[libvirt.md5sum] = "a870e63f20fac2ccf98e716d05256145" 51SRC_URI[libvirt.md5sum] = "a870e63f20fac2ccf98e716d05256145"
52SRC_URI[libvirt.sha256sum] = "167c185be45560e73dd3e14ed375778b555c01455192de2dafc4d0f74fabebc0" 52SRC_URI[libvirt.sha256sum] = "167c185be45560e73dd3e14ed375778b555c01455192de2dafc4d0f74fabebc0"
53 53