summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/docker/docker-moby_git.bb10
-rw-r--r--recipes-containers/docker/files/0001-cli-use-external-GO111MODULE-and-cross-compiler.patch13
2 files changed, 15 insertions, 8 deletions
diff --git a/recipes-containers/docker/docker-moby_git.bb b/recipes-containers/docker/docker-moby_git.bb
index f2599cf3..0aed206a 100644
--- a/recipes-containers/docker/docker-moby_git.bb
+++ b/recipes-containers/docker/docker-moby_git.bb
@@ -34,14 +34,14 @@ DESCRIPTION = "Linux container runtime \
34# - The common components of this recipe and docker-ce do need to be moved 34# - The common components of this recipe and docker-ce do need to be moved
35# to a docker.inc recipe 35# to a docker.inc recipe
36 36
37SRCREV_moby = "4ed81ac0e2504489839226ce42abc614cc4d4860" 37SRCREV_moby = "3fd34324a8abc7573fa3b06190a1338263ef1ee7"
38SRCREV_libnetwork = "dcdf8f176d1e13ad719e913e796fb698d846de98" 38SRCREV_libnetwork = "dcdf8f176d1e13ad719e913e796fb698d846de98"
39SRCREV_cli = "baeda1f82a10204ec5708d5fbba130ad76cfee49" 39SRCREV_cli = "83ca73f9aa7a1c442171ef2602af4d303d9de9c2"
40SRCREV_FORMAT = "moby_libnetwork" 40SRCREV_FORMAT = "moby_libnetwork"
41SRC_URI = "\ 41SRC_URI = "\
42 git://github.com/moby/moby.git;branch=20.10;name=moby;protocol=https \ 42 git://github.com/moby/moby.git;branch=23.0;name=moby;protocol=https \
43 git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork;protocol=https \ 43 git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork;protocol=https \
44 git://github.com/docker/cli;branch=20.10;name=cli;destsuffix=git/cli;protocol=https \ 44 git://github.com/docker/cli;branch=master;name=cli;destsuffix=git/cli;protocol=https \
45 file://docker.init \ 45 file://docker.init \
46 file://0001-libnetwork-use-GO-instead-of-go.patch \ 46 file://0001-libnetwork-use-GO-instead-of-go.patch \
47 file://0001-cli-use-external-GO111MODULE-and-cross-compiler.patch \ 47 file://0001-cli-use-external-GO111MODULE-and-cross-compiler.patch \
@@ -56,7 +56,7 @@ require docker.inc
56LICENSE = "Apache-2.0" 56LICENSE = "Apache-2.0"
57LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28" 57LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28"
58 58
59DOCKER_VERSION = "20.10.21" 59DOCKER_VERSION = "23.0-beta"
60PV = "${DOCKER_VERSION}+git${SRCREV_moby}" 60PV = "${DOCKER_VERSION}+git${SRCREV_moby}"
61 61
62CVE_PRODUCT = "docker mobyproject:moby" 62CVE_PRODUCT = "docker mobyproject:moby"
diff --git a/recipes-containers/docker/files/0001-cli-use-external-GO111MODULE-and-cross-compiler.patch b/recipes-containers/docker/files/0001-cli-use-external-GO111MODULE-and-cross-compiler.patch
index 3814a0c2..26f5aad4 100644
--- a/recipes-containers/docker/files/0001-cli-use-external-GO111MODULE-and-cross-compiler.patch
+++ b/recipes-containers/docker/files/0001-cli-use-external-GO111MODULE-and-cross-compiler.patch
@@ -14,13 +14,20 @@ Index: git/cli/scripts/build/binary
14=================================================================== 14===================================================================
15--- git.orig/cli/scripts/build/binary 15--- git.orig/cli/scripts/build/binary
16+++ git/cli/scripts/build/binary 16+++ git/cli/scripts/build/binary
17@@ -73,8 +73,7 @@ 17@@ -13,8 +13,6 @@
18 18
19 echo "Building $GO_LINKMODE $(basename "${TARGET}")" 19 echo "Building $GO_LINKMODE $(basename "${TARGET}")"
20 20
21-export GO111MODULE=auto 21-export GO111MODULE=auto
22-
23 if [ "$(go env GOOS)" = "windows" ]; then
24 if [ ! -x "$(command -v goversioninfo)" ]; then
25 >&2 echo "goversioninfo not found, skipping manifesting binary"
26@@ -24,6 +22,6 @@
27 fi
28 fi
22 29
23-go build -o "${TARGET}" -tags "${GO_BUILDTAGS}" --ldflags "${GO_LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}" 30-(set -x ; go build -o "${TARGET}" -tags "${GO_BUILDTAGS}" -ldflags "${GO_LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}")
24+${GO} build -trimpath -o "${TARGET}" -tags "${GO_BUILDTAGS}" --ldflags "${GO_LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}" 31+(set -x ; ${GO} build -trimpath -o "${TARGET}" -tags "${GO_BUILDTAGS}" -ldflags "${GO_LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}")
25 32
26 ln -sf "$(basename "${TARGET}")" "$(dirname "${TARGET}")/docker" 33 ln -sf "$(basename "${TARGET}")" "$(dirname "${TARGET}")/docker"