summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/docker/docker-ce_git.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-containers/docker/docker-ce_git.bb b/recipes-containers/docker/docker-ce_git.bb
index ef840697..3c8a339f 100644
--- a/recipes-containers/docker/docker-ce_git.bb
+++ b/recipes-containers/docker/docker-ce_git.bb
@@ -44,6 +44,8 @@ PV = "${DOCKER_VERSION}+git${SRCREV_docker}"
44PACKAGES =+ "${PN}-contrib" 44PACKAGES =+ "${PN}-contrib"
45 45
46DOCKER_PKG="github.com/docker/docker" 46DOCKER_PKG="github.com/docker/docker"
47# in order to exclude devicemapper and btrfs - https://github.com/docker/docker/issues/14056
48BUILD_TAGS = "exclude_graphdriver_btrfs exclude_graphdriver_devicemapper"
47 49
48inherit go 50inherit go
49inherit goarch 51inherit goarch
@@ -71,8 +73,7 @@ do_compile() {
71 export CGO_ENABLED="1" 73 export CGO_ENABLED="1"
72 export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}" 74 export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
73 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 75 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
74 # in order to exclude devicemapper and btrfs - https://github.com/docker/docker/issues/14056 76 export DOCKER_BUILDTAGS='${BUILD_TAGS} ${PACKAGECONFIG_CONFARGS}'
75 export DOCKER_BUILDTAGS='exclude_graphdriver_btrfs exclude_graphdriver_devicemapper'
76 77
77 export DISABLE_WARN_OUTSIDE_CONTAINER=1 78 export DISABLE_WARN_OUTSIDE_CONTAINER=1
78 79