diff options
4 files changed, 35 insertions, 45 deletions
diff --git a/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch b/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch index 79e63322..4d35e58e 100644 --- a/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch +++ b/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 0fe50d2ca4517f5e3070585040f35ace413acd44 Mon Sep 17 00:00:00 2001 | 1 | From 0fe50d2ca4517f5e3070585040f35ace413acd44 Mon Sep 17 00:00:00 2001 |
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | 2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> |
3 | Date: Tue, 24 Aug 2021 11:38:23 -0400 | 3 | Date: Tue, 24 Aug 2021 11:38:23 -0400 |
4 | Subject: [PATCH] Makefile: respect GOBUILDFLAGS for runc and remove recvtty | 4 | Subject: [PATCH] Makefile: respect GOBUILDFLAGS for runc and remove recvtty |
5 | from static | 5 | from static |
6 | 6 | ||
7 | Signed-off-by: Chen Qi <Qi.Chen@windriver.com> | 7 | Signed-off-by: Chen Qi <Qi.Chen@windriver.com> |
@@ -11,20 +11,16 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | |||
11 | Makefile | 3 +-- | 11 | Makefile | 3 +-- |
12 | 1 file changed, 1 insertion(+), 2 deletions(-) | 12 | 1 file changed, 1 insertion(+), 2 deletions(-) |
13 | 13 | ||
14 | diff --git a/Makefile b/Makefile | 14 | Index: git/src/import/Makefile |
15 | index e3af9bc1..f9d6de96 100644 | 15 | =================================================================== |
16 | --- a/Makefile | 16 | --- git.orig/src/import/Makefile |
17 | +++ b/Makefile | 17 | +++ git/src/import/Makefile |
18 | @@ -24,8 +24,7 @@ ifneq (,$(filter $(GOARCH),386 amd64 arm arm64 ppc64le riscv64 s390x)) | 18 | @@ -20,7 +20,7 @@ |
19 | GO_BUILDMODE := "-buildmode=pie" | 19 | endif |
20 | endif | 20 | endif |
21 | endif | 21 | endif |
22 | -GO_BUILD := $(GO) build -trimpath $(GO_BUILDMODE) \ | 22 | -GO_BUILD := $(GO) build -trimpath $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ |
23 | - $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ | ||
24 | +GO_BUILD := $(GO) build $(GOBUILDFLAGS) -trimpath $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ | 23 | +GO_BUILD := $(GO) build $(GOBUILDFLAGS) -trimpath $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ |
25 | -ldflags "$(LDFLAGS_COMMON) $(EXTRA_LDFLAGS)" | 24 | -ldflags "-X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" |
26 | 25 | GO_BUILD_STATIC := CGO_ENABLED=1 $(GO) build -trimpath $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo" \ | |
27 | GO_BUILDMODE_STATIC := | 26 | -ldflags "-extldflags -static -X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" |
28 | -- | ||
29 | 2.40.0 | ||
30 | |||
diff --git a/recipes-containers/runc/runc-docker/0001-runc-Add-console-socket-dev-null.patch b/recipes-containers/runc/runc-docker/0001-runc-Add-console-socket-dev-null.patch index 2a24df90..bcf4c103 100644 --- a/recipes-containers/runc/runc-docker/0001-runc-Add-console-socket-dev-null.patch +++ b/recipes-containers/runc/runc-docker/0001-runc-Add-console-socket-dev-null.patch | |||
@@ -12,11 +12,11 @@ Signed-off-by: Jason Wessel <jason.wessel@windriver.com> | |||
12 | utils_linux.go | 5 +++++ | 12 | utils_linux.go | 5 +++++ |
13 | 1 file changed, 5 insertions(+) | 13 | 1 file changed, 5 insertions(+) |
14 | 14 | ||
15 | diff --git a/utils_linux.go b/utils_linux.go | 15 | Index: git/src/import/utils_linux.go |
16 | index 60d534e8..ddcab62f 100644 | 16 | =================================================================== |
17 | --- a/utils_linux.go | 17 | --- git.orig/src/import/utils_linux.go |
18 | +++ b/utils_linux.go | 18 | +++ git/src/import/utils_linux.go |
19 | @@ -234,6 +234,11 @@ type runner struct { | 19 | @@ -267,6 +267,11 @@ |
20 | } | 20 | } |
21 | 21 | ||
22 | func (r *runner) run(config *specs.Process) (int, error) { | 22 | func (r *runner) run(config *specs.Process) (int, error) { |
@@ -28,6 +28,3 @@ index 60d534e8..ddcab62f 100644 | |||
28 | var err error | 28 | var err error |
29 | defer func() { | 29 | defer func() { |
30 | if err != nil { | 30 | if err != nil { |
31 | -- | ||
32 | 2.40.0 | ||
33 | |||
diff --git a/recipes-containers/runc/runc-docker/0001-runc-docker-SIGUSR1-daemonize.patch b/recipes-containers/runc/runc-docker/0001-runc-docker-SIGUSR1-daemonize.patch index 1065f23e..4350c40f 100644 --- a/recipes-containers/runc/runc-docker/0001-runc-docker-SIGUSR1-daemonize.patch +++ b/recipes-containers/runc/runc-docker/0001-runc-docker-SIGUSR1-daemonize.patch | |||
@@ -25,15 +25,15 @@ is set. | |||
25 | 25 | ||
26 | Signed-off-by: Jason Wessel <jason.wessel@windriver.com> | 26 | Signed-off-by: Jason Wessel <jason.wessel@windriver.com> |
27 | --- | 27 | --- |
28 | signals.go | 56 ++++++++++++++++++++++++++++++++++++++++++++++---- | 28 | signals.go | 54 ++++++++++++++++++++++++++++++++++++++++++++++++++---- |
29 | utils_linux.go | 2 +- | 29 | utils_linux.go | 2 +- |
30 | 2 files changed, 53 insertions(+), 5 deletions(-) | 30 | 2 files changed, 51 insertions(+), 5 deletions(-) |
31 | 31 | ||
32 | diff --git a/signals.go b/signals.go | 32 | Index: git/src/import/signals.go |
33 | index 2555b765..1266ee66 100644 | 33 | =================================================================== |
34 | --- a/signals.go | 34 | --- git.orig/src/import/signals.go |
35 | +++ b/signals.go | 35 | +++ git/src/import/signals.go |
36 | @@ -3,7 +3,9 @@ package main | 36 | @@ -5,7 +5,9 @@ |
37 | import ( | 37 | import ( |
38 | "os" | 38 | "os" |
39 | "os/signal" | 39 | "os/signal" |
@@ -43,7 +43,7 @@ index 2555b765..1266ee66 100644 | |||
43 | "github.com/opencontainers/runc/libcontainer" | 43 | "github.com/opencontainers/runc/libcontainer" |
44 | "github.com/opencontainers/runc/libcontainer/system" | 44 | "github.com/opencontainers/runc/libcontainer/system" |
45 | "github.com/opencontainers/runc/libcontainer/utils" | 45 | "github.com/opencontainers/runc/libcontainer/utils" |
46 | @@ -53,9 +55,6 @@ type signalHandler struct { | 46 | @@ -55,9 +57,6 @@ |
47 | func (h *signalHandler) forward(process *libcontainer.Process, tty *tty, detach bool) (int, error) { | 47 | func (h *signalHandler) forward(process *libcontainer.Process, tty *tty, detach bool) (int, error) { |
48 | // make sure we know the pid of our main process so that we can return | 48 | // make sure we know the pid of our main process so that we can return |
49 | // after it dies. | 49 | // after it dies. |
@@ -53,7 +53,7 @@ index 2555b765..1266ee66 100644 | |||
53 | 53 | ||
54 | pid1, err := process.Pid() | 54 | pid1, err := process.Pid() |
55 | if err != nil { | 55 | if err != nil { |
56 | @@ -65,12 +64,61 @@ func (h *signalHandler) forward(process *libcontainer.Process, tty *tty, detach | 56 | @@ -67,12 +66,61 @@ |
57 | if h.notifySocket != nil { | 57 | if h.notifySocket != nil { |
58 | if detach { | 58 | if detach { |
59 | _ = h.notifySocket.run(pid1) | 59 | _ = h.notifySocket.run(pid1) |
@@ -116,11 +116,11 @@ index 2555b765..1266ee66 100644 | |||
116 | // Perform the initial tty resize. Always ignore errors resizing because | 116 | // Perform the initial tty resize. Always ignore errors resizing because |
117 | // stdout might have disappeared (due to races with when SIGHUP is sent). | 117 | // stdout might have disappeared (due to races with when SIGHUP is sent). |
118 | _ = tty.resize() | 118 | _ = tty.resize() |
119 | diff --git a/utils_linux.go b/utils_linux.go | 119 | Index: git/src/import/utils_linux.go |
120 | index ddcab62f..280051ea 100644 | 120 | =================================================================== |
121 | --- a/utils_linux.go | 121 | --- git.orig/src/import/utils_linux.go |
122 | +++ b/utils_linux.go | 122 | +++ git/src/import/utils_linux.go |
123 | @@ -315,7 +315,7 @@ func (r *runner) run(config *specs.Process) (int, error) { | 123 | @@ -345,7 +345,7 @@ |
124 | if err != nil { | 124 | if err != nil { |
125 | r.terminate(process) | 125 | r.terminate(process) |
126 | } | 126 | } |
@@ -129,6 +129,3 @@ index ddcab62f..280051ea 100644 | |||
129 | return 0, nil | 129 | return 0, nil |
130 | } | 130 | } |
131 | if err == nil { | 131 | if err == nil { |
132 | -- | ||
133 | 2.40.0 | ||
134 | |||
diff --git a/recipes-containers/runc/runc-docker_git.bb b/recipes-containers/runc/runc-docker_git.bb index afecac67..97373a72 100644 --- a/recipes-containers/runc/runc-docker_git.bb +++ b/recipes-containers/runc/runc-docker_git.bb | |||
@@ -2,13 +2,13 @@ include runc.inc | |||
2 | 2 | ||
3 | # Note: this rev is before the required protocol field, update when all components | 3 | # Note: this rev is before the required protocol field, update when all components |
4 | # have been updated to match. | 4 | # have been updated to match. |
5 | SRCREV_runc-docker = "a9833ff391a71b30069a6c3f816db113379a4346" | 5 | SRCREV_runc-docker = "974efd2dfca0abec041a3708a2b66bfac6bd2484" |
6 | SRC_URI = "git://github.com/opencontainers/runc;branch=release-1.1;name=runc-docker;protocol=https \ | 6 | SRC_URI = "git://github.com/opencontainers/runc;branch=release-1.1;name=runc-docker;protocol=https \ |
7 | file://0001-runc-Add-console-socket-dev-null.patch;patchdir=src/import \ | 7 | file://0001-runc-Add-console-socket-dev-null.patch \ |
8 | file://0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch;patchdir=src/import \ | 8 | file://0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch \ |
9 | file://0001-runc-docker-SIGUSR1-daemonize.patch;patchdir=src/import \ | 9 | file://0001-runc-docker-SIGUSR1-daemonize.patch \ |
10 | " | 10 | " |
11 | 11 | ||
12 | RUNC_VERSION = "1.1.12" | 12 | RUNC_VERSION = "1.1.4" |
13 | 13 | ||
14 | CVE_PRODUCT = "runc" | 14 | CVE_PRODUCT = "runc" |