diff options
-rw-r--r-- | recipes-core/runx/runx_git.bb | 59 |
1 files changed, 5 insertions, 54 deletions
diff --git a/recipes-core/runx/runx_git.bb b/recipes-core/runx/runx_git.bb index 36fede67..e405df7d 100644 --- a/recipes-core/runx/runx_git.bb +++ b/recipes-core/runx/runx_git.bb | |||
@@ -2,7 +2,7 @@ HOMEPAGE = "https://github.com/lf-edge/runx" | |||
2 | SUMMARY = "runx stuff" | 2 | SUMMARY = "runx stuff" |
3 | DESCRIPTION = "Xen Runtime for OCI" | 3 | DESCRIPTION = "Xen Runtime for OCI" |
4 | 4 | ||
5 | SRCREV_runx = "a6fe5ca3081f44e9085972d424c74707d4f0fc71" | 5 | SRCREV_runx = "da0c75c58ae5232d19b1791c33545db3225e1ea9" |
6 | SRC_URI = "\ | 6 | SRC_URI = "\ |
7 | git://github.com/lf-edge/runx;nobranch=1;name=runx \ | 7 | git://github.com/lf-edge/runx;nobranch=1;name=runx \ |
8 | https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.15.tar.xz;destsuffix=git/kernel/build \ | 8 | https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.15.tar.xz;destsuffix=git/kernel/build \ |
@@ -21,11 +21,6 @@ PV = "0.1-git${SRCREV_runx}" | |||
21 | inherit distro_features_check | 21 | inherit distro_features_check |
22 | REQUIRED_DISTRO_FEATURES = "vmsep" | 22 | REQUIRED_DISTRO_FEATURES = "vmsep" |
23 | 23 | ||
24 | |||
25 | # TODO: for if we need a go shim | ||
26 | # GO_IMPORT = "import" | ||
27 | # inherit go | ||
28 | # inherit goarch | ||
29 | inherit pkgconfig | 24 | inherit pkgconfig |
30 | 25 | ||
31 | # for the kernel build | 26 | # for the kernel build |
@@ -33,14 +28,14 @@ inherit kernel-arch | |||
33 | 28 | ||
34 | # we have a busybox bbappend that makes /bin available to the | 29 | # we have a busybox bbappend that makes /bin available to the |
35 | # sysroot, and hence gets us the target binary that we need | 30 | # sysroot, and hence gets us the target binary that we need |
36 | DEPENDS = "busybox" | 31 | DEPENDS = "busybox go-build" |
37 | 32 | ||
38 | # for the kernel build phase | 33 | # for the kernel build phase |
39 | DEPENDS += "openssl-native coreutils-native util-linux-native xz-native bc-native" | 34 | DEPENDS += "openssl-native coreutils-native util-linux-native xz-native bc-native" |
40 | DEPENDS += "qemu-native" | 35 | DEPENDS += "qemu-native" |
41 | 36 | ||
42 | RDEPENDS_${PN} += " jq bash" | 37 | RDEPENDS_${PN} += " jq bash" |
43 | RDEPENDS_${PN} += " xen-xl" | 38 | RDEPENDS_${PN} += " xen-xl go-build socat daemonize" |
44 | 39 | ||
45 | do_compile() { | 40 | do_compile() { |
46 | # we'll need this for the initrd later, so lets error if it isn't what | 41 | # we'll need this for the initrd later, so lets error if it isn't what |
@@ -86,52 +81,6 @@ do_compile() { | |||
86 | ${S}/kernel/make-initrd | 81 | ${S}/kernel/make-initrd |
87 | } | 82 | } |
88 | 83 | ||
89 | do_build_go_shim() { | ||
90 | |||
91 | # placeholder for any go shim code we may need, i.e. console | ||
92 | |||
93 | # export GOARCH="${TARGET_GOARCH}" | ||
94 | # export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go" | ||
95 | # export GOPATH="${S}/src/import:${S}/src/import/vendor" | ||
96 | |||
97 | # # Pass the needed cflags/ldflags so that cgo | ||
98 | # # can find the needed headers files and libraries | ||
99 | # export CGO_ENABLED="1" | ||
100 | # export CFLAGS="" | ||
101 | # export LDFLAGS="" | ||
102 | # export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}" | ||
103 | # export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" | ||
104 | |||
105 | # # link fixups for compilation | ||
106 | # rm -f ${S}/src/import/vendor/src | ||
107 | # ln -sf ./ ${S}/src/import/vendor/src | ||
108 | |||
109 | # mkdir -p ${S}/src/import/vendor/github.com/hyperhq/runv | ||
110 | |||
111 | # ln -sf src/import/cli | ||
112 | # ln -sf ../../../../api ${S}/src/import/vendor/github.com/hyperhq/runv/api | ||
113 | # ln -sf ../../../../cli ${S}/src/import/vendor/github.com/hyperhq/runv/cli | ||
114 | # ln -sf ../../../../lib ${S}/src/import/vendor/github.com/hyperhq/runv/lib | ||
115 | # ln -sf ../../../../driverloader ${S}/src/import/vendor/github.com/hyperhq/runv/driverloader | ||
116 | # ln -sf ../../../../factory ${S}/src/import/vendor/github.com/hyperhq/runv/factory | ||
117 | # ln -sf ../../../../hyperstart ${S}/src/import/vendor/github.com/hyperhq/runv/hyperstart | ||
118 | # ln -sf ../../../../hypervisor ${S}/src/import/vendor/github.com/hyperhq/runv/hypervisor | ||
119 | # ln -sf ../../../../template ${S}/src/import/vendor/github.com/hyperhq/runv/template | ||
120 | |||
121 | # export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" | ||
122 | # export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go" | ||
123 | |||
124 | # # Pass the needed cflags/ldflags so that cgo | ||
125 | # # can find the needed headers files and libraries | ||
126 | # export CGO_ENABLED="1" | ||
127 | # export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}" | ||
128 | # export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" | ||
129 | |||
130 | # oe_runmake build-shim | ||
131 | |||
132 | true | ||
133 | } | ||
134 | |||
135 | do_install() { | 84 | do_install() { |
136 | install -d ${D}${bindir} | 85 | install -d ${D}${bindir} |
137 | install -m 755 ${S}/runX ${D}${bindir} | 86 | install -m 755 ${S}/runX ${D}${bindir} |
@@ -142,6 +91,8 @@ do_install() { | |||
142 | install -m 755 ${S}/files/start ${D}/${datadir}/runX | 91 | install -m 755 ${S}/files/start ${D}/${datadir}/runX |
143 | install -m 755 ${S}/files/state ${D}/${datadir}/runX | 92 | install -m 755 ${S}/files/state ${D}/${datadir}/runX |
144 | install -m 755 ${S}/files/delete ${D}/${datadir}/runX | 93 | install -m 755 ${S}/files/delete ${D}/${datadir}/runX |
94 | install -m 755 ${S}/files/serial_bridge ${D}/${datadir}/runX | ||
95 | install -m 755 ${S}/files/serial_start ${D}/${datadir}/runX | ||
145 | 96 | ||
146 | 97 | ||
147 | } | 98 | } |