diff options
-rw-r--r-- | recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen-4.18.patch | 43 | ||||
-rw-r--r-- | recipes-extended/xen/xen-tools_4.18.bb | 21 | ||||
-rw-r--r-- | recipes-extended/xen/xen_4.18.bb | 22 |
3 files changed, 0 insertions, 86 deletions
diff --git a/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen-4.18.patch b/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen-4.18.patch deleted file mode 100644 index 7ac1a399..00000000 --- a/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen-4.18.patch +++ /dev/null | |||
@@ -1,43 +0,0 @@ | |||
1 | Upstream-Status: Pending | ||
2 | |||
3 | diff --git a/tools/pygrub/Makefile b/tools/pygrub/Makefile | ||
4 | index 4963bc89c6..c1c05eb421 100644 | ||
5 | --- a/tools/pygrub/Makefile | ||
6 | +++ b/tools/pygrub/Makefile | ||
7 | @@ -13,14 +13,14 @@ setup.py = CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDSHARED="$(CC)" LDFLAGS="$(PY_LDFLA | ||
8 | all: build | ||
9 | .PHONY: build | ||
10 | build: | ||
11 | - $(setup.py) build | ||
12 | + $(setup.py) build $(DISTUTILS_BUILD_ARGS) | ||
13 | |||
14 | .PHONY: install | ||
15 | install: all | ||
16 | $(INSTALL_DIR) $(DESTDIR)/$(bindir) | ||
17 | $(INSTALL_DIR) $(DESTDIR)/$(LIBEXEC_BIN) | ||
18 | $(setup.py) install --record $(INSTALL_LOG) $(PYTHON_PREFIX_ARG) \ | ||
19 | - --root="$(DESTDIR)" --force | ||
20 | + --root="$(DESTDIR)" --force $(DISTUTILS_INSTALL_ARGS) | ||
21 | $(INSTALL_PYTHON_PROG) src/pygrub $(DESTDIR)/$(LIBEXEC_BIN)/pygrub | ||
22 | set -e; if [ $(bindir) != $(LIBEXEC_BIN) -a \ | ||
23 | "`readlink -f $(DESTDIR)/$(bindir)`" != \ | ||
24 | diff --git a/tools/python/Makefile b/tools/python/Makefile | ||
25 | index 437431c48e..0a99c2067e 100644 | ||
26 | --- a/tools/python/Makefile | ||
27 | +++ b/tools/python/Makefile | ||
28 | @@ -16,13 +16,13 @@ setup.py = CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDSHARED="$(CC)" LDFLAGS="$(PY_LDFLA | ||
29 | |||
30 | .PHONY: build | ||
31 | build: | ||
32 | - $(setup.py) build | ||
33 | + $(setup.py) build $(DISTUTILS_BUILD_ARGS) | ||
34 | |||
35 | .PHONY: install | ||
36 | install: | ||
37 | $(INSTALL_DIR) $(DESTDIR)$(LIBEXEC_BIN) | ||
38 | $(setup.py) install --record $(INSTALL_LOG) $(PYTHON_PREFIX_ARG) \ | ||
39 | - --root="$(DESTDIR)" --force | ||
40 | + --root="$(DESTDIR)" --force $(DISTUTILS_INSTALL_ARGS) | ||
41 | $(INSTALL_PYTHON_PROG) scripts/convert-legacy-stream $(DESTDIR)$(LIBEXEC_BIN) | ||
42 | $(INSTALL_PYTHON_PROG) scripts/verify-stream-v2 $(DESTDIR)$(LIBEXEC_BIN) | ||
43 | |||
diff --git a/recipes-extended/xen/xen-tools_4.18.bb b/recipes-extended/xen/xen-tools_4.18.bb deleted file mode 100644 index 5dbe180a..00000000 --- a/recipes-extended/xen/xen-tools_4.18.bb +++ /dev/null | |||
@@ -1,21 +0,0 @@ | |||
1 | # tag: RELEASE-4.18.0 | ||
2 | SRCREV ?= "4da8ca9cb9cfdb92c9dd09d5270ae16a3b2dbc89" | ||
3 | |||
4 | XEN_REL ?= "4.18" | ||
5 | XEN_BRANCH ?= "stable-4.18" | ||
6 | |||
7 | SRC_URI = " \ | ||
8 | git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \ | ||
9 | file://0001-python-pygrub-pass-DISTUTILS-xen-4.18.patch \ | ||
10 | " | ||
11 | |||
12 | LIC_FILES_CHKSUM ?= "file://COPYING;md5=d1a1e216f80b6d8da95fec897d0dbec9" | ||
13 | |||
14 | PV = "${XEN_REL}+stable" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | DEFAULT_PREFERENCE ??= "-1" | ||
19 | |||
20 | require xen.inc | ||
21 | require xen-tools.inc | ||
diff --git a/recipes-extended/xen/xen_4.18.bb b/recipes-extended/xen/xen_4.18.bb deleted file mode 100644 index d0b19013..00000000 --- a/recipes-extended/xen/xen_4.18.bb +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | # tag: RELEASE-4.18.0 | ||
2 | SRCREV ?= "01f7a3c792241d348a4e454a30afdf6c0d6cd71c" | ||
3 | |||
4 | XEN_REL ?= "4.18.2" | ||
5 | XEN_BRANCH ?= "stable-4.18" | ||
6 | |||
7 | SRC_URI = " \ | ||
8 | git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \ | ||
9 | file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \ | ||
10 | file://0001-arm-silence-gcc14-warning-error-on-irq-bounds-check.patch \ | ||
11 | " | ||
12 | |||
13 | LIC_FILES_CHKSUM ?= "file://COPYING;md5=d1a1e216f80b6d8da95fec897d0dbec9" | ||
14 | |||
15 | PV = "${XEN_REL}+stable" | ||
16 | |||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | DEFAULT_PREFERENCE ??= "-1" | ||
20 | |||
21 | require xen.inc | ||
22 | require xen-hypervisor.inc | ||