summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/skopeo/skopeo_git.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-containers/skopeo/skopeo_git.bb b/recipes-containers/skopeo/skopeo_git.bb
index f5a62313..be72dc13 100644
--- a/recipes-containers/skopeo/skopeo_git.bb
+++ b/recipes-containers/skopeo/skopeo_git.bb
@@ -20,13 +20,13 @@ RDEPENDS_${PN} = " \
20" 20"
21 21
22SRC_URI = " \ 22SRC_URI = " \
23 git://github.com/containers/skopeo \ 23 git://github.com/containers/skopeo;branch=release-1.2 \
24 file://storage.conf \ 24 file://storage.conf \
25 file://registries.conf \ 25 file://registries.conf \
26" 26"
27 27
28SRCREV = "1cf1e06582142c522543560f2bc6d6756696e8ad" 28SRCREV = "6c0e35a50c404c88eba84b4c611e6ea06ed33a44"
29PV = "v0.1.39-dev+git${SRCPV}" 29PV = "v1.2.2-dev+git${SRCPV}"
30GO_IMPORT = "import" 30GO_IMPORT = "import"
31 31
32S = "${WORKDIR}/git" 32S = "${WORKDIR}/git"
@@ -63,14 +63,14 @@ do_compile() {
63 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 63 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
64 cd ${S}/src/import 64 cd ${S}/src/import
65 65
66 oe_runmake binary-local 66 oe_runmake bin/skopeo
67} 67}
68 68
69do_install() { 69do_install() {
70 install -d ${D}/${sbindir} 70 install -d ${D}/${sbindir}
71 install -d ${D}/${sysconfdir}/containers 71 install -d ${D}/${sysconfdir}/containers
72 72
73 install ${S}/src/import/skopeo ${D}/${sbindir}/ 73 install ${S}/src/import/bin/skopeo ${D}/${sbindir}/
74 install ${S}/src/import/default-policy.json ${D}/${sysconfdir}/containers/policy.json 74 install ${S}/src/import/default-policy.json ${D}/${sysconfdir}/containers/policy.json
75 75
76 install ${WORKDIR}/storage.conf ${D}/${sysconfdir}/containers/storage.conf 76 install ${WORKDIR}/storage.conf ${D}/${sysconfdir}/containers/storage.conf