diff options
-rw-r--r-- | recipes-extended/libvirt/libvirt-1.2.17/0001-to-fix-build-error.patch | 44 | ||||
-rw-r--r-- | recipes-extended/libvirt/libvirt-python.inc | 4 | ||||
-rw-r--r-- | recipes-extended/libvirt/libvirt_1.2.17.bb (renamed from recipes-extended/libvirt/libvirt_1.2.15.bb) | 5 |
3 files changed, 49 insertions, 4 deletions
diff --git a/recipes-extended/libvirt/libvirt-1.2.17/0001-to-fix-build-error.patch b/recipes-extended/libvirt/libvirt-1.2.17/0001-to-fix-build-error.patch new file mode 100644 index 00000000..61a54e18 --- /dev/null +++ b/recipes-extended/libvirt/libvirt-1.2.17/0001-to-fix-build-error.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | From 62514c8c2925e48a4f20ce3d7d48387851cb76a5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Lei Maohui <leimaohui@cn.fujitsu.com> | ||
3 | Date: Fri, 31 Jul 2015 03:17:07 +0900 | ||
4 | Subject: [PATCH] to fix build error | ||
5 | |||
6 | The error likes as following | ||
7 | |||
8 | | Generating internals/command.html.tmp | ||
9 | | /bin/sh: line 3: internals/command.html.tmp: No such file or directory | ||
10 | | rm: Generating internals/locking.html.tmp | ||
11 | | cannot remove `internals/command.html.tmp': No such file or directory | ||
12 | | make[3]: *** [internals/command.html.tmp] Error 1 | ||
13 | | make[3]: *** Waiting for unfinished jobs.... | ||
14 | |||
15 | Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> | ||
16 | --- | ||
17 | docs/Makefile.am | 4 ++-- | ||
18 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
19 | |||
20 | diff --git a/docs/Makefile.am b/docs/Makefile.am | ||
21 | index daf37b6..125c5fd 100644 | ||
22 | --- a/docs/Makefile.am | ||
23 | +++ b/docs/Makefile.am | ||
24 | @@ -162,7 +162,7 @@ EXTRA_DIST= \ | ||
25 | sitemap.html.in aclperms.htmlinc \ | ||
26 | todo.pl hvsupport.pl todo.cfg-example | ||
27 | |||
28 | -acl_generated = aclperms.htmlinc | ||
29 | +acl.html:: $(srcdir)/aclperms.htmlinc | ||
30 | |||
31 | $(srcdir)/aclperms.htmlinc: $(top_srcdir)/src/access/viraccessperm.h \ | ||
32 | $(srcdir)/genaclperms.pl Makefile.am | ||
33 | @@ -227,7 +227,7 @@ internals/%.html.tmp: internals/%.html.in subsite.xsl page.xsl sitemap.html.in | ||
34 | $(top_srcdir)/docs/subsite.xsl $< > $@ \ | ||
35 | || { rm $@ && exit 1; }; fi | ||
36 | |||
37 | -%.html.tmp: %.html.in site.xsl page.xsl sitemap.html.in $(acl_generated) | ||
38 | +%.html.tmp: %.html.in site.xsl page.xsl sitemap.html.in | ||
39 | @if [ -x $(XSLTPROC) ] ; then \ | ||
40 | echo "Generating $@"; \ | ||
41 | name=`echo $@ | sed -e 's/.tmp//'`; \ | ||
42 | -- | ||
43 | 1.8.4.2 | ||
44 | |||
diff --git a/recipes-extended/libvirt/libvirt-python.inc b/recipes-extended/libvirt/libvirt-python.inc index 550236ac..f42e4913 100644 --- a/recipes-extended/libvirt/libvirt-python.inc +++ b/recipes-extended/libvirt/libvirt-python.inc | |||
@@ -18,8 +18,8 @@ FILES_${PN}-python = "${bindir}/* ${libdir}/* ${libdir}/${PYTHON_DIR}/*" | |||
18 | SRC_URI += "http://libvirt.org/sources/python/libvirt-python-${PV}.tar.gz;name=libvirt_python" | 18 | SRC_URI += "http://libvirt.org/sources/python/libvirt-python-${PV}.tar.gz;name=libvirt_python" |
19 | SRC_URI += "file://libvirt_api_xml_path.patch;patchdir=../libvirt-python-${PV}" | 19 | SRC_URI += "file://libvirt_api_xml_path.patch;patchdir=../libvirt-python-${PV}" |
20 | 20 | ||
21 | SRC_URI[libvirt_python.md5sum] = "f13b566b54fe71ec0f26992aee11dd09" | 21 | SRC_URI[libvirt_python.md5sum] = "a695e323e33db562d86e947f7ac77f09" |
22 | SRC_URI[libvirt_python.sha256sum] = "9a6dfbd487d49f887a41aca4bfb1b4e043fd9fbdfc041252cae84023f5c387ba" | 22 | SRC_URI[libvirt_python.sha256sum] = "f4d3db4012a800a2519e62bbef4ce14a37e030a20ab18f5b66759533a39b36ed" |
23 | 23 | ||
24 | export LIBVIRT_API_PATH = "${S}/docs/libvirt-api.xml" | 24 | export LIBVIRT_API_PATH = "${S}/docs/libvirt-api.xml" |
25 | export LIBVIRT_CFLAGS = "-I${S}/include" | 25 | export LIBVIRT_CFLAGS = "-I${S}/include" |
diff --git a/recipes-extended/libvirt/libvirt_1.2.15.bb b/recipes-extended/libvirt/libvirt_1.2.17.bb index 8abd41ef..9f8c3af2 100644 --- a/recipes-extended/libvirt/libvirt_1.2.15.bb +++ b/recipes-extended/libvirt/libvirt_1.2.17.bb | |||
@@ -31,10 +31,11 @@ SRC_URI = "http://libvirt.org/sources/libvirt-${PV}.tar.gz;name=libvirt \ | |||
31 | file://run-ptest \ | 31 | file://run-ptest \ |
32 | file://tests-allow-separated-src-and-build-dirs.patch \ | 32 | file://tests-allow-separated-src-and-build-dirs.patch \ |
33 | file://libvirt-use-pkg-config-to-locate-libcap.patch \ | 33 | file://libvirt-use-pkg-config-to-locate-libcap.patch \ |
34 | file://0001-to-fix-build-error.patch \ | ||
34 | " | 35 | " |
35 | 36 | ||
36 | SRC_URI[libvirt.md5sum] = "08c2ea825d076ee67b1bbc600c220b97" | 37 | SRC_URI[libvirt.md5sum] = "a1f49050223be3cbd7678c32b1ee2756" |
37 | SRC_URI[libvirt.sha256sum] = "5f88041b8c212f8f687c672fe583108833240d6175b512ce4de92ab6660194c6" | 38 | SRC_URI[libvirt.sha256sum] = "e07eaf20b0590fae05ba3b53ad4dac3e5fbd771437563cc78b692f23ddd02fad" |
38 | 39 | ||
39 | inherit autotools gettext update-rc.d pkgconfig ptest | 40 | inherit autotools gettext update-rc.d pkgconfig ptest |
40 | 41 | ||