summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/k3s/k3s_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-containers/k3s/k3s_git.bb b/recipes-containers/k3s/k3s_git.bb
index 6c11f9c2..28d6ce0c 100644
--- a/recipes-containers/k3s/k3s_git.bb
+++ b/recipes-containers/k3s/k3s_git.bb
@@ -40,8 +40,12 @@ do_compile() {
40 export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" 40 export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go"
41 export CGO_ENABLED="1" 41 export CGO_ENABLED="1"
42 export GOFLAGS="-mod=vendor" 42 export GOFLAGS="-mod=vendor"
43
44 TAGS="static_build ctrd no_btrfs netcgo osusergo providerless"
45
43 cd ${S}/src/import 46 cd ${S}/src/import
44 ${GO} build -tags providerless -ldflags "${GO_BUILD_LDFLAGS}" -o ./dist/artifacts/k3s ./cmd/server/main.go 47 ${GO} build -tags "$TAGS" -ldflags "${GO_BUILD_LDFLAGS} -w -s" -o ./dist/artifacts/k3s ./cmd/server/main.go
48
45 # Use UPX if it is enabled (and thus exists) to compress binary 49 # Use UPX if it is enabled (and thus exists) to compress binary
46 if command -v upx > /dev/null 2>&1; then 50 if command -v upx > /dev/null 2>&1; then
47 upx -9 ./dist/artifacts/k3s 51 upx -9 ./dist/artifacts/k3s