summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/python/python-docker-pycreds.inc7
-rw-r--r--recipes-devtools/python/python-docker-pycreds_0.3.0.bb3
-rw-r--r--recipes-devtools/python/python-docker.inc14
-rw-r--r--recipes-devtools/python/python-docker_3.4.0.bb6
-rw-r--r--recipes-devtools/python/python3-docker-pycreds_0.3.0.bb8
-rw-r--r--recipes-devtools/python/python3-docker_3.4.0.bb16
6 files changed, 32 insertions, 22 deletions
diff --git a/recipes-devtools/python/python-docker-pycreds.inc b/recipes-devtools/python/python-docker-pycreds.inc
new file mode 100644
index 00000000..ca0995f5
--- /dev/null
+++ b/recipes-devtools/python/python-docker-pycreds.inc
@@ -0,0 +1,7 @@
1SUMMARY = "Python bindings for the docker credentials store API"
2HOMEPAGE = "https://github.com/shin-/dockerpy-creds"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6SRC_URI[md5sum] = "2370ea3b62198b788a26231ab58844af"
7SRC_URI[sha256sum] = "8b0e956c8d206f832b06aa93a710ba2c3bcbacb5a314449c040b0b814355bbff"
diff --git a/recipes-devtools/python/python-docker-pycreds_0.3.0.bb b/recipes-devtools/python/python-docker-pycreds_0.3.0.bb
new file mode 100644
index 00000000..6dc45219
--- /dev/null
+++ b/recipes-devtools/python/python-docker-pycreds_0.3.0.bb
@@ -0,0 +1,3 @@
1inherit pypi setuptools
2require python-docker-pycreds.inc
3
diff --git a/recipes-devtools/python/python-docker.inc b/recipes-devtools/python/python-docker.inc
new file mode 100644
index 00000000..eec7cda0
--- /dev/null
+++ b/recipes-devtools/python/python-docker.inc
@@ -0,0 +1,14 @@
1SUMMARY = "A Python library for the Docker Engine API."
2HOMEPAGE = "https://github.com/docker/docker-py"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=34f3846f940453127309b920eeb89660"
5
6SRC_URI[md5sum] = "02491d168c048cdb99cc20d0b352ea0f"
7SRC_URI[sha256sum] = "e9cc39e24905e67ba9e2df14c94488f5cf030fb72ae1c60de505ce5ea90503f7"
8
9RDEPENDS_${PN} += " \
10 ${PYTHON_PN}-six \
11 ${PYTHON_PN}-docker-pycreds \
12 ${PYTHON_PN}-requests \
13 ${PYTHON_PN}-websocket-client \
14"
diff --git a/recipes-devtools/python/python-docker_3.4.0.bb b/recipes-devtools/python/python-docker_3.4.0.bb
new file mode 100644
index 00000000..a9642543
--- /dev/null
+++ b/recipes-devtools/python/python-docker_3.4.0.bb
@@ -0,0 +1,6 @@
1inherit pypi setuptools
2require python-docker.inc
3
4RDEPENDS_${PN} += " \
5 python-backports-ssl \
6 "
diff --git a/recipes-devtools/python/python3-docker-pycreds_0.3.0.bb b/recipes-devtools/python/python3-docker-pycreds_0.3.0.bb
index 4d39f529..75a83e06 100644
--- a/recipes-devtools/python/python3-docker-pycreds_0.3.0.bb
+++ b/recipes-devtools/python/python3-docker-pycreds_0.3.0.bb
@@ -1,9 +1,3 @@
1SUMMARY = "Python bindings for the docker credentials store API"
2HOMEPAGE = "https://github.com/shin-/dockerpy-creds"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6inherit pypi setuptools3 1inherit pypi setuptools3
2require python-docker-pycreds.inc
7 3
8SRC_URI[md5sum] = "2370ea3b62198b788a26231ab58844af"
9SRC_URI[sha256sum] = "8b0e956c8d206f832b06aa93a710ba2c3bcbacb5a314449c040b0b814355bbff"
diff --git a/recipes-devtools/python/python3-docker_3.4.0.bb b/recipes-devtools/python/python3-docker_3.4.0.bb
index 6e813025..052cbe8a 100644
--- a/recipes-devtools/python/python3-docker_3.4.0.bb
+++ b/recipes-devtools/python/python3-docker_3.4.0.bb
@@ -1,17 +1,3 @@
1SUMMARY = "A Python library for the Docker Engine API."
2HOMEPAGE = "https://github.com/docker/docker-py"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=34f3846f940453127309b920eeb89660"
5
6inherit pypi setuptools3 1inherit pypi setuptools3
7
8SRC_URI[md5sum] = "02491d168c048cdb99cc20d0b352ea0f"
9SRC_URI[sha256sum] = "e9cc39e24905e67ba9e2df14c94488f5cf030fb72ae1c60de505ce5ea90503f7"
10
11DEPENDS += "${PYTHON_PN}-pip-native" 2DEPENDS += "${PYTHON_PN}-pip-native"
12 3require python-docker.inc
13RDEPENDS_${PN} += " \
14 python3-docker-pycreds \
15 python3-requests \
16 python3-websocket-client \
17"