diff options
-rw-r--r-- | recipes-devtools/go/go-build_git.bb | 43 |
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-devtools/go/go-build_git.bb b/recipes-devtools/go/go-build_git.bb new file mode 100644 index 00000000..4ea800f0 --- /dev/null +++ b/recipes-devtools/go/go-build_git.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | HOMEPAGE = "https://github.com/lf-edge/runx" | ||
2 | SUMMARY = "console for runx" | ||
3 | DESCRIPTION = "Xen Runtime for OCI" | ||
4 | |||
5 | SRCREV_runx = "da0c75c58ae5232d19b1791c33545db3225e1ea9" | ||
6 | SRC_URI = "\ | ||
7 | git://github.com/lf-edge/runx;nobranch=1;name=runx \ | ||
8 | " | ||
9 | SRC_URI[md5sum] = "0d701ac1e2a67d47ce7127432df2c32b" | ||
10 | SRC_URI[sha256sum] = "5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769" | ||
11 | |||
12 | LICENSE = "Apache-2.0" | ||
13 | LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=945fc9aa694796a6337395cc291ddd8c" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | PV = "0.1-git${SRCREV_runx}" | ||
17 | |||
18 | inherit distro_features_check | ||
19 | REQUIRED_DISTRO_FEATURES = "vmsep" | ||
20 | |||
21 | inherit pkgconfig | ||
22 | |||
23 | GO_IMPORT = "import" | ||
24 | inherit go | ||
25 | |||
26 | RDEPENDS_${PN}-dev = "bash" | ||
27 | |||
28 | do_compile() { | ||
29 | |||
30 | export GOARCH="${TARGET_GOARCH}" | ||
31 | cd ${S}/src/import/gobuild | ||
32 | oe_runmake | ||
33 | } | ||
34 | |||
35 | do_install() { | ||
36 | |||
37 | install -d ${D}${datadir}/runX | ||
38 | install -m 755 ${B}/src/import/gobuild/serial_fd_handler ${D}${datadir}/runX/ | ||
39 | install -m 755 ${B}/src/import/gobuild/recvtty ${D}${datadir}/runX/ | ||
40 | |||
41 | } | ||
42 | |||
43 | FILES_${PN} += "${datadir}/runX/*" | ||