diff options
-rw-r--r-- | recipes-core/busybox/busybox-initrd/initrd.cfg | 14 | ||||
-rw-r--r-- | recipes-core/busybox/busybox-initrd/runx.cfg | 1 | ||||
-rw-r--r-- | recipes-core/busybox/busybox-initrd_1.32.0.bb | 20 |
3 files changed, 35 insertions, 0 deletions
diff --git a/recipes-core/busybox/busybox-initrd/initrd.cfg b/recipes-core/busybox/busybox-initrd/initrd.cfg new file mode 100644 index 00000000..9f64c4c6 --- /dev/null +++ b/recipes-core/busybox/busybox-initrd/initrd.cfg | |||
@@ -0,0 +1,14 @@ | |||
1 | CONFIG_INIT=y | ||
2 | CNOFIG_FEATURE_UTMP=y | ||
3 | CONFIG_RUNLEVEL=y | ||
4 | CONFIG_FEATURE_USE_INITTAB=y | ||
5 | CONFIG_HALT=y | ||
6 | CONFIG_POWEROFF=y | ||
7 | CONFIG_FEATURE_KILL_DELAY=0 | ||
8 | CONFIG_TELINIT_PATH="" | ||
9 | CONFIG_INIT_TERMINAL_TYPE="" | ||
10 | |||
11 | # CONFIG_FEATURE_SHADOWPASSWDS is not set | ||
12 | CONFIG_USE_BB_PWD_GRP=y | ||
13 | |||
14 | CONFIG_STATIC=y | ||
diff --git a/recipes-core/busybox/busybox-initrd/runx.cfg b/recipes-core/busybox/busybox-initrd/runx.cfg new file mode 100644 index 00000000..1f1ac6af --- /dev/null +++ b/recipes-core/busybox/busybox-initrd/runx.cfg | |||
@@ -0,0 +1 @@ | |||
CONFIG_FEATURE_INSTALLER=y | |||
diff --git a/recipes-core/busybox/busybox-initrd_1.32.0.bb b/recipes-core/busybox/busybox-initrd_1.32.0.bb new file mode 100644 index 00000000..82edb570 --- /dev/null +++ b/recipes-core/busybox/busybox-initrd_1.32.0.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/busybox-initrd:${COREBASE}/meta/recipes-core/busybox/busybox:${COREBASE}/meta/recipes-core/busybox/files:" | ||
2 | |||
3 | require recipes-core/busybox/busybox_${PV}.bb | ||
4 | |||
5 | SRC_URI += "file://init.cfg \ | ||
6 | file://mdev.cfg \ | ||
7 | file://runx.cfg \ | ||
8 | file://initrd.cfg" | ||
9 | |||
10 | S = "${WORKDIR}/busybox-${PV}" | ||
11 | |||
12 | # override security-flags settings, we have some warnings to ignore | ||
13 | SECURITY_STRINGFORMAT = "" | ||
14 | |||
15 | # we do this to get the target binary available to recipes that | ||
16 | # depend on busybox | ||
17 | SYSROOT_DIRS += "/bin" | ||
18 | BUSYBOX_SPLIT_SUID = "0" | ||
19 | |||
20 | FILES_${PN} += "${sysconfdir}/init.d/*" | ||