summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/docker/docker_git.bb4
-rw-r--r--recipes-devtools/go-cross/go-cross-1.3_1.3.bb (renamed from recipes-devtools/go-cross/go-cross_1.3.bb)11
2 files changed, 9 insertions, 6 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index 46714fef..69c45ae3 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -37,7 +37,7 @@ S = "${WORKDIR}/git"
37DOCKER_VERSION = "1.6.2" 37DOCKER_VERSION = "1.6.2"
38PV = "${DOCKER_VERSION}+git${SRCREV}" 38PV = "${DOCKER_VERSION}+git${SRCREV}"
39 39
40DEPENDS = "go-cross \ 40DEPENDS = "go-cross-1.3 \
41 go-cli \ 41 go-cli \
42 go-pty \ 42 go-pty \
43 go-context \ 43 go-context \
@@ -66,6 +66,8 @@ do_configure() {
66} 66}
67 67
68do_compile() { 68do_compile() {
69 export PATH=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/go-1.3:$PATH
70
69 export GOARCH="${TARGET_ARCH}" 71 export GOARCH="${TARGET_ARCH}"
70 # supported amd64, 386, arm 72 # supported amd64, 386, arm
71 if [ "${TARGET_ARCH}" = "x86_64" ]; then 73 if [ "${TARGET_ARCH}" = "x86_64" ]; then
diff --git a/recipes-devtools/go-cross/go-cross_1.3.bb b/recipes-devtools/go-cross/go-cross-1.3_1.3.bb
index 1fb48700..775e28f3 100644
--- a/recipes-devtools/go-cross/go-cross_1.3.bb
+++ b/recipes-devtools/go-cross/go-cross-1.3_1.3.bb
@@ -25,7 +25,7 @@ SRC_URI += "\
25 25
26do_compile() { 26do_compile() {
27 ## Setting `$GOBIN` doesn't do any good, looks like it ends up copying binaries there. 27 ## Setting `$GOBIN` doesn't do any good, looks like it ends up copying binaries there.
28 export GOROOT_FINAL="${SYSROOT}${libdir}/go" 28 export GOROOT_FINAL="${SYSROOT}${libdir}/go-1.3"
29 29
30 export GOHOSTOS="linux" 30 export GOHOSTOS="linux"
31 export GOOS="linux" 31 export GOOS="linux"
@@ -61,11 +61,12 @@ do_compile() {
61do_install() { 61do_install() {
62 ## It should be okay to ignore `${WORKDIR}/go/bin/linux_arm`... 62 ## It should be okay to ignore `${WORKDIR}/go/bin/linux_arm`...
63 ## Also `gofmt` is not needed right now. 63 ## Also `gofmt` is not needed right now.
64 install -d "${D}${bindir}" 64 install -d "${D}${bindir}/go-1.3"
65 install -m 0755 "${WORKDIR}/go/bin/go" "${D}${bindir}" 65 install -m 0755 "${WORKDIR}/go/bin/go" "${D}${bindir}/go-1.3/"
66 install -d "${D}${libdir}/go" 66 install -d "${D}${libdir}/go-1.3"
67
67 ## TODO: use `install` instead of `cp` 68 ## TODO: use `install` instead of `cp`
68 for dir in include lib pkg src test 69 for dir in include lib pkg src test
69 do cp -a "${WORKDIR}/go/${dir}" "${D}${libdir}/go/" 70 do cp -a "${WORKDIR}/go/${dir}" "${D}${libdir}/go-1.3/"
70 done 71 done
71} 72}