summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/docker/docker-moby.bb15
-rw-r--r--recipes-containers/docker/docker-moby/0001-cli-use-go-cross-compiler.patch19
-rw-r--r--recipes-containers/docker/docker-moby/0001-dynbinary-use-go-cross-compiler.patch27
-rw-r--r--recipes-containers/docker/docker-moby/0001-imporve-hardcoded-CC-on-cross-compile-docker-ce.patch61
4 files changed, 27 insertions, 95 deletions
diff --git a/recipes-containers/docker/docker-moby.bb b/recipes-containers/docker/docker-moby.bb
index 03f681a2..1427784f 100644
--- a/recipes-containers/docker/docker-moby.bb
+++ b/recipes-containers/docker/docker-moby.bb
@@ -35,16 +35,15 @@ DESCRIPTION = "Linux container runtime \
35# to a docker.inc recipe 35# to a docker.inc recipe
36 36
37# moby commit matches the docker-engine bump on the 19.03 branch' 37# moby commit matches the docker-engine bump on the 19.03 branch'
38SRCREV_moby = "7d75c1d40d88ddef08653dbd611f41df42bdf087" 38SRCREV_moby = "11ecfe8a81b7040738333f777681e55e2a867160"
39SRCREV_libnetwork = "55e924b8a84231a065879156c0de95aefc5f5435" 39SRCREV_libnetwork = "b3507428be5b458cb0e2b4086b13531fb0706e46"
40SRCREV_cli = "fd3371eb7df1adeceff5935cf3ade0576a0f48d5" 40SRCREV_cli = "41b3ea7e472c504c1b7fe8e3347d329ab97b8112"
41SRC_URI = "\ 41SRC_URI = "\
42 git://github.com/moby/moby.git;branch=19.03;name=moby \ 42 git://github.com/moby/moby.git;branch=20.10;name=moby \
43 git://github.com/docker/libnetwork.git;branch=bump_19.03;name=libnetwork;destsuffix=git/libnetwork \ 43 git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork \
44 git://github.com/docker/cli;branch=19.03;name=cli;destsuffix=git/cli \ 44 git://github.com/docker/cli;branch=20.10;name=cli;destsuffix=git/cli \
45 file://docker.init \ 45 file://docker.init \
46 file://0001-libnetwork-use-GO-instead-of-go.patch \ 46 file://0001-libnetwork-use-GO-instead-of-go.patch \
47 file://0001-imporve-hardcoded-CC-on-cross-compile-docker-ce.patch \
48 file://0001-cli-use-go-cross-compiler.patch \ 47 file://0001-cli-use-go-cross-compiler.patch \
49 file://0001-dynbinary-use-go-cross-compiler.patch \ 48 file://0001-dynbinary-use-go-cross-compiler.patch \
50 " 49 "
@@ -59,7 +58,7 @@ GO_IMPORT = "import"
59 58
60S = "${WORKDIR}/git" 59S = "${WORKDIR}/git"
61 60
62DOCKER_VERSION = "19.03.14" 61DOCKER_VERSION = "20.10.3"
63PV = "${DOCKER_VERSION}+git${SRCREV_moby}" 62PV = "${DOCKER_VERSION}+git${SRCREV_moby}"
64 63
65PACKAGES =+ "${PN}-contrib" 64PACKAGES =+ "${PN}-contrib"
diff --git a/recipes-containers/docker/docker-moby/0001-cli-use-go-cross-compiler.patch b/recipes-containers/docker/docker-moby/0001-cli-use-go-cross-compiler.patch
index 9419d547..f065e184 100644
--- a/recipes-containers/docker/docker-moby/0001-cli-use-go-cross-compiler.patch
+++ b/recipes-containers/docker/docker-moby/0001-cli-use-go-cross-compiler.patch
@@ -8,18 +8,15 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
8 git/cli/scripts/build/dynbinary | 2 +- 8 git/cli/scripts/build/dynbinary | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-) 9 1 file changed, 1 insertion(+), 1 deletion(-)
10 10
11diff --git git/cli/scripts/build/dynbinary git/cli/scripts/build/dynbinary 11Index: git/cli/scripts/build/dynbinary
12index 4feb7e71d8..f990d0e040 100755 12===================================================================
13--- git/cli/scripts/build/dynbinary 13--- git.orig/cli/scripts/build/dynbinary
14+++ git/cli/scripts/build/dynbinary 14+++ git/cli/scripts/build/dynbinary
15@@ -9,6 +9,6 @@ source ./scripts/build/.variables 15@@ -19,6 +19,6 @@
16 ;;
17 esac
16 18
17 echo "Building dynamically linked $TARGET" 19-go build -o "${TARGET}" -tags pkcs11 --ldflags "${LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}"
18 export CGO_ENABLED=1 20+${GO} build -o "${TARGET}" -tags pkcs11 --ldflags "${LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}"
19-go build -o "${TARGET}" -tags pkcs11 --ldflags "${LDFLAGS}" -buildmode=pie "${SOURCE}"
20+${GO} build -o "${TARGET}" -tags pkcs11 --ldflags "${LDFLAGS}" -buildmode=pie "${SOURCE}"
21 21
22 ln -sf "$(basename "${TARGET}")" build/docker 22 ln -sf "$(basename "${TARGET}")" build/docker
23--
242.19.1
25
diff --git a/recipes-containers/docker/docker-moby/0001-dynbinary-use-go-cross-compiler.patch b/recipes-containers/docker/docker-moby/0001-dynbinary-use-go-cross-compiler.patch
index d9cdfb01..971c60d7 100644
--- a/recipes-containers/docker/docker-moby/0001-dynbinary-use-go-cross-compiler.patch
+++ b/recipes-containers/docker/docker-moby/0001-dynbinary-use-go-cross-compiler.patch
@@ -8,19 +8,16 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
8 hack/make/.binary | 2 +- 8 hack/make/.binary | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-) 9 1 file changed, 1 insertion(+), 1 deletion(-)
10 10
11diff --git a/src/import/hack/make/.binary b/src/import/hack/make/.binary 11Index: git/src/import/hack/make/.binary
12index 53de6749e5..47ab2a754f 100644 12===================================================================
13--- a/src/import/hack/make/.binary 13--- git.orig/src/import/hack/make/.binary
14+++ b/src/import/hack/make/.binary 14+++ git/src/import/hack/make/.binary
15@@ -81,7 +81,7 @@ esac 15@@ -81,7 +81,7 @@
16 16
17 echo "Building: $DEST/$BINARY_FULLNAME" 17 echo "Building: $DEST/$BINARY_FULLNAME"
18 echo "GOOS=\"${GOOS}\" GOARCH=\"${GOARCH}\" GOARM=\"${GOARM}\"" 18 echo "GOOS=\"${GOOS}\" GOARCH=\"${GOARCH}\" GOARM=\"${GOARM}\""
19-go build \ 19- go build \
20+${GO} build \ 20+ ${GO} build \
21 -o "$DEST/$BINARY_FULLNAME" \ 21 -o "$DEST/$BINARY_FULLNAME" \
22 "${BUILDFLAGS[@]}" \ 22 "${BUILDFLAGS[@]}" \
23 -ldflags " 23 -ldflags "
24--
252.19.1
26
diff --git a/recipes-containers/docker/docker-moby/0001-imporve-hardcoded-CC-on-cross-compile-docker-ce.patch b/recipes-containers/docker/docker-moby/0001-imporve-hardcoded-CC-on-cross-compile-docker-ce.patch
deleted file mode 100644
index 766425a8..00000000
--- a/recipes-containers/docker/docker-moby/0001-imporve-hardcoded-CC-on-cross-compile-docker-ce.patch
+++ /dev/null
@@ -1,61 +0,0 @@
1From 1263fdb50a540e9db742694b7cee08284ad986d0 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Wed, 17 Jul 2019 17:34:04 +0800
4Subject: [PATCH] imporve hardcoded CC on cross compile
5
6Since commit applied in moby [61a3285 Support cross-compile for arm]
7it hardcoded var-CC to support cross-compile for arm
8
9Correct it with "${parameter:-word}" format, it is helpful for user
10define toolchains
11
12(Use Default Values. If parameter is unset or null, the expansion of
13word is substituted. Otherwise, the value of parameter is substituted.)
14
15Upstream-Status: Submitted [https://github.com/moby/moby/pull/39546]
16
17Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
18---
19 components/engine/hack/make/.binary | 10 +++++-----
20 1 file changed, 5 insertions(+), 5 deletions(-)
21
22diff --git a/src/import/hack/make/.binary b/src/import/hack/make/.binary
23index 53de6749e5..66f4ca05f3 100644
24--- a/src/import/hack/make/.binary
25+++ b/src/import/hack/make/.binary
26@@ -44,27 +44,27 @@ if [ "$(go env GOOS)/$(go env GOARCH)" != "$(go env GOHOSTOS)/$(go env GOHOSTARC
27 # must be cross-compiling!
28 case "$(go env GOOS)/$(go env GOARCH)" in
29 windows/amd64)
30- export CC=x86_64-w64-mingw32-gcc
31+ export CC="${CC:-x86_64-w64-mingw32-gcc}"
32 export CGO_ENABLED=1
33 ;;
34 linux/arm)
35 case "${GOARM}" in
36 5|"")
37- export CC=arm-linux-gnueabi-gcc
38+ export CC="${CC:-arm-linux-gnueabi-gcc}"
39 export CGO_ENABLED=1
40 ;;
41 7)
42- export CC=arm-linux-gnueabihf-gcc
43+ export CC="${CC:-arm-linux-gnueabihf-gcc}"
44 export CGO_ENABLED=1
45 ;;
46 esac
47 ;;
48 linux/arm64)
49- export CC=aarch64-linux-gnu-gcc
50+ export CC="${CC:-aarch64-linux-gnu-gcc}"
51 export CGO_ENABLED=1
52 ;;
53 linux/amd64)
54- export CC=x86_64-linux-gnu-gcc
55+ export CC="${CC:-x86_64-linux-gnu-gcc}"
56 export CGO_ENABLED=1
57 ;;
58 esac
59--
602.23.0
61