summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/docker/docker-moby_git.bb8
-rw-r--r--recipes-containers/docker/files/0001-cli-use-external-GO111MODULE-and-cross-compiler.patch15
2 files changed, 10 insertions, 13 deletions
diff --git a/recipes-containers/docker/docker-moby_git.bb b/recipes-containers/docker/docker-moby_git.bb
index f7f0f6fa..dea5a8ea 100644
--- a/recipes-containers/docker/docker-moby_git.bb
+++ b/recipes-containers/docker/docker-moby_git.bb
@@ -34,9 +34,9 @@ DESCRIPTION = "Linux container runtime \
34# - The common components of this recipe and docker-ce do need to be moved 34# - The common components of this recipe and docker-ce do need to be moved
35# to a docker.inc recipe 35# to a docker.inc recipe
36 36
37SRCREV_moby = "f756502055d2e36a84f2068e6620bea5ecf09058" 37SRCREV_moby = "3949ff121ee486eb73484f6c4708d199f68c930e"
38SRCREV_libnetwork = "339b972b464ee3d401b5788b2af9e31d09d6b7da" 38SRCREV_libnetwork = "f6ccccb1c082a432c2a5814aaedaca56af33d9ea"
39SRCREV_cli = "a224086349269551becacce16e5842ceeb2a98d6" 39SRCREV_cli = "100c70180fde3601def79a59cc3e996aa553c9b9"
40SRCREV_FORMAT = "moby_libnetwork" 40SRCREV_FORMAT = "moby_libnetwork"
41SRC_URI = "\ 41SRC_URI = "\
42 git://github.com/moby/moby.git;branch=20.10;name=moby;protocol=https \ 42 git://github.com/moby/moby.git;branch=20.10;name=moby;protocol=https \
@@ -54,7 +54,7 @@ require docker.inc
54LICENSE = "Apache-2.0" 54LICENSE = "Apache-2.0"
55LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28" 55LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28"
56 56
57DOCKER_VERSION = "20.10.16" 57DOCKER_VERSION = "20.10.17"
58PV = "${DOCKER_VERSION}+git${SRCREV_moby}" 58PV = "${DOCKER_VERSION}+git${SRCREV_moby}"
59 59
60CVE_PRODUCT = "docker" 60CVE_PRODUCT = "docker"
diff --git a/recipes-containers/docker/files/0001-cli-use-external-GO111MODULE-and-cross-compiler.patch b/recipes-containers/docker/files/0001-cli-use-external-GO111MODULE-and-cross-compiler.patch
index dc322612..16b5f9e5 100644
--- a/recipes-containers/docker/files/0001-cli-use-external-GO111MODULE-and-cross-compiler.patch
+++ b/recipes-containers/docker/files/0001-cli-use-external-GO111MODULE-and-cross-compiler.patch
@@ -8,20 +8,17 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
8 git/cli/scripts/build/binary | 3 +-- 8 git/cli/scripts/build/binary | 3 +--
9 1 file changed, 1 insertion(+), 2 deletions(-) 9 1 file changed, 1 insertion(+), 2 deletions(-)
10 10
11diff --git git/cli/scripts/build/binary git/cli/scripts/build/binary 11Index: git/cli/scripts/build/binary
12index e4c5e12a6b..7c47b75c2f 100755 12===================================================================
13--- git/cli/scripts/build/binary 13--- git.orig/cli/scripts/build/binary
14+++ git/cli/scripts/build/binary 14+++ git/cli/scripts/build/binary
15@@ -73,8 +73,7 @@ fi 15@@ -73,8 +73,7 @@
16 16
17 echo "Building $GO_LINKMODE $(basename "${TARGET}")" 17 echo "Building $GO_LINKMODE $(basename "${TARGET}")"
18 18
19-export GO111MODULE=auto 19-export GO111MODULE=auto
20 20
21-go build -o "${TARGET}" -tags "${GO_BUILDTAGS}" --ldflags "${LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}" 21-go build -o "${TARGET}" -tags "${GO_BUILDTAGS}" --ldflags "${GO_LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}"
22+${GO} build -o "${TARGET}" -tags "${GO_BUILDTAGS}" --ldflags "${LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}" 22+${GO} build -o "${TARGET}" -tags "${GO_BUILDTAGS}" --ldflags "${GO_LDFLAGS}" ${GO_BUILDMODE} "${SOURCE}"
23 23
24 ln -sf "$(basename "${TARGET}")" "$(dirname "${TARGET}")/docker" 24 ln -sf "$(basename "${TARGET}")" "$(dirname "${TARGET}")/docker"
25--
262.19.1
27