summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/meta-virt-xen.inc4
-rw-r--r--dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend10
2 files changed, 14 insertions, 0 deletions
diff --git a/conf/distro/include/meta-virt-xen.inc b/conf/distro/include/meta-virt-xen.inc
index 0a91ef9a..44853d95 100644
--- a/conf/distro/include/meta-virt-xen.inc
+++ b/conf/distro/include/meta-virt-xen.inc
@@ -17,3 +17,7 @@ RPI_SDIMG_EXTRA_DEPENDS_append_raspberrypi4-64 = " xen:do_deploy"
17DEPLOYPAYLOAD_raspberrypi4-64 = "xen-${MACHINE}:xen" 17DEPLOYPAYLOAD_raspberrypi4-64 = "xen-${MACHINE}:xen"
18# We need the GIC enabled for Xen to work 18# We need the GIC enabled for Xen to work
19RPI_EXTRA_CONFIG_append_raspberrypi4-64 = "\nenable_gic=1" 19RPI_EXTRA_CONFIG_append_raspberrypi4-64 = "\nenable_gic=1"
20# Increase boot partition for space for kernel and Xen
21BOOT_SPACE_raspberrypi4-64 = "61440"
22# Override the meta-raspberrypi default kernel preference
23PREFERRED_PROVIDER_virtual/kernel_raspberrypi4-64 = "linux-yocto-dev"
diff --git a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend
new file mode 100644
index 00000000..85d6febe
--- /dev/null
+++ b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -0,0 +1,10 @@
1# For a Xen-enabled distro on the Raspberry Pi, override the contents of cmdline.txt
2# with Xen-on-ARM-specific command line options
3
4DEFAULT_CMDLINE := "${CMDLINE}"
5XEN_LINUX_CMDLINE ?= "console=hvc0 clk_ignore_unused earlycon=xenboot debug root=/dev/mmcblk0p2 rootwait"
6CMDLINE = "${@bb.utils.contains('DISTRO_FEATURES', 'xen', '${XEN_LINUX_CMDLINE}', '${DEFAULT_CMDLINE}', d)}"
7
8KBRANCH_raspberrypi4-64 = "standard/bcm-2xxx-rpi"
9KMACHINE_raspberrypi4-64 = "bcm-2xxx-rpi4"
10COMPATIBLE_MACHINE_raspberrypi4-64 = "(raspberrypi4-64)"